
Authorized Publisher

Learning Guide

Autodesk® Revit® 2022
BIM Management: Template and Family 

Creation

Imperial Units - 1st Edition

Cover Page

Sam
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 



Sam
pl

A

ASCENT - Center for Technical Knowledge®

Autodesk® Revit® 2022 
BIM Management: Template and Family Creation

Imperial Units - 1st Edition

ASCENT - Center for Technical Knowledge (a division of Rand Worldwide Inc.) is a leading developer of 
professional learning materials and knowledge products for engineering software applications. ASCENT 
specializes in designing targeted content that facilitates application-based learning with hands-on software 
experience. For over 25 years, ASCENT has helped users become more productive through tailored 
custom learning solutions. 

We welcome any comments you may have regarding this guide, or any of our products. To contact us 
please email: feedback@ASCENTed.com. 

© ASCENT - Center for Technical Knowledge, 2021

All rights reserved. No part of this guide may be reproduced in any form by any photographic, electronic, 
mechanical or other means or used in any information storage and retrieval system without the written 
permission of ASCENT, a division of Rand Worldwide, Inc.

The following are registered trademarks or trademarks of Autodesk, Inc., and/or its subsidiaries and/or affiliates in the 
USA and other countries: 123D, 3ds Max, ADSK, Alias, ATC, AutoCAD LT, AutoCAD, Autodesk, the Autodesk logo, 
Autodesk 123D, Autodesk Alias, Autodesk Docs, ArtCAM, Autodesk Forge, Autodesk Fusion, Autodesk Inventor, 
AutoSnap, BIM 360, Buzzsaw, CADmep, CAMduct, Civil 3D, Configurator 360, Dancing Baby (image), DWF, DWG, DWG 
(DWG logo), DWG Extreme, DWG TrueConvert, DWG TrueView, DWGX, DXF, Eagle, ESTmep, FBX, FeatureCAM, 
Flame, FormIt 360, Fusion 360, The Future of Making Things, Glue, Green Building Studio, InfraWorks, Instructables, 
Instructables (Instructables logo), Inventor, Inventor CAM, Inventor HSM, Inventor LT, Make Anything, Maya, Maya LT, 
Moldflow, MotionBuilder, Mudbox, Navisworks, Netfabb,  Opticore, PartMaker,  Pier 9, PowerInspect, PowerMill, 
PowerShape, Publisher 360, RasterDWG, RealDWG, ReCap, ReCap 360, Remake, Revit LT, Revit, Scaleform, Shotgun, 
Showcase, Showcase 360, SketchBook, Softimage, Tinkercad, TrustedDWG, VRED.

NASTRAN is a registered trademark of the National Aeronautics Space Administration.

All other brand names, product names, or trademarks belong to their respective holders.

General Disclaimer: 

Notwithstanding any language to the contrary, nothing contained herein constitutes nor is intended to constitute an offer, 
inducement, promise, or contract of any kind. The data contained herein is for informational purposes only and is not 
represented to be error free. ASCENT, its agents and employees, expressly disclaim any liability for any damages, losses 
or other expenses arising in connection with the use of its materials or in connection with any failure of performance, error, 
omission even if ASCENT, or its representatives, are advised of the possibility of such damages, losses or other 
expenses. No consequential damages can be sought against ASCENT or Rand Worldwide, Inc. for the use of these 
materials by any third parties or for any direct or indirect result of that use.

The information contained herein is intended to be of general interest to you and is provided "as is", and it does not 
address the circumstances of any particular individual or entity. Nothing herein constitutes professional advice, nor does 
it constitute a comprehensive or complete statement of the issues discussed thereto. ASCENT does not warrant that the 
document or information will be error free or will meet any particular criteria of performance or quality. In particular (but 
without limitation) information may be rendered inaccurate by changes made to the subject of the materials (i.e. applicable 
software). Rand Worldwide, Inc. specifically disclaims any warranty, either expressed or implied, including the warranty 
of fitness for a particular purpose.

Prepared and produced by:

ASCENT Center for Technical Knowledge
630 Peter Jefferson Parkway, Suite 175
Charlottesville, VA 22911

866-527-2368
www.ASCENTed.com

Lead Contributor: Cherisse Biddulph
Copyright

e p
rov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

ll c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
AS-REV2201-BIM1IM-SG      //      IS-REV2201-BIM1IM-SG

mailto:feedback@ASCENTed.com


S

Contents

Preface ............................................................................................................ ix

In This Guide ................................................................................................ xiii

Practice Files ................................................................................................. xv

Chapter 1: Creating Custom Templates ..................................................... 1-1

1.1 Preparing Project Templates ......................................................... 1-2
Managing Settings ............................................................................ 1-4
Families in Templates ....................................................................... 1-4
Review Loaded Families ................................................................... 1-8
Purging Unused Components ........................................................... 1-9
Using Resource Projects................................................................. 1-10
Setting Default Template Files ........................................................ 1-13

Practice 1a Prepare Project Templates: Architecture.......................  1-14

Practice 1b Prepare Project Templates: MEP....................................  1-21

Practice 1c Prepare Project Templates: Structural...........................  1-27

1.2 Customizing Annotation Types ................................................... 1-35
Creating Text Types........................................................................ 1-36
Creating Dimension Types.............................................................. 1-38
Loading Tags and Symbols............................................................. 1-40
Specifying View Tags...................................................................... 1-42

Practice 1d Customize Annotation Types: All Disciplines...............  1-45

1.3 Creating Title Blocks .................................................................... 1-51
Adding Labels ................................................................................. 1-53
Adding Revision Schedules ............................................................ 1-56
Adding Sheets to Project Templates............................................... 1-62

Practice 1e Create Title Blocks: All Disciplines ................................  1-64

1.4 Setting Up View Filters ................................................................. 1-71

Practice 1f Set Up View Filters: Architecture ....................................  1-76

Practice 1g Set Up View Filters: MEP.................................................  1-80

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2021, ASCENT - Center for Technical Knowledge® i



Autodesk Revit 2022 BIM Management: Template and Family Creation 

S

Practice 1h Set Up View Filters: Structure.........................................  1-84

1.5 Adding View Templates................................................................ 1-88

Practice 1i Add View Templates: Architecture ..................................  1-95

Practice 1j Add View Templates: MEP ...............................................  1-99

Practice 1k Add View Templates: Structure ....................................  1-103

Chapter Review Questions................................................................. 1-108

Command Summary ........................................................................... 1-109

Chapter 2: Creating Schedules ................................................................... 2-1

2.1 Introduction to Schedules.............................................................. 2-2
Importing and Exporting Schedules .................................................. 2-3

2.2 Creating Building Component Schedules .................................... 2-6
Schedule Properties........................................................................ 2-15
Filtering Elements from Schedules ................................................. 2-17

Practice 2a Create Schedules for Architectural Projects .................  2-19

Practice 2b Create Schedules for MEP Projects ...............................  2-25

Practice 2c Create Schedules for Structural Projects ......................  2-30

2.3 Modifying Schedule Appearance................................................. 2-36
Setting Up Parameter Values.......................................................... 2-37
Modifying Columns and Rows......................................................... 2-38
Modifying Titles and Headers.......................................................... 2-39
Setting the Appearance................................................................... 2-41
Adding Image Fields and Images.................................................... 2-42

Practice 2d Modify Schedules for Architectural Projects ................  2-47

Practice 2e Modify Schedules for MEP Projects ...............................  2-52

Practice 2f Modify Schedules for Structural Projects.......................  2-57

2.4 Additional Schedule Types .......................................................... 2-60
Creating Key Schedules.................................................................. 2-60
Creating Material Takeoff Schedules .............................................. 2-64

2.5 Advanced Schedule Options ....................................................... 2-68
Conditional Formatting .................................................................... 2-68
Embedded Schedules ..................................................................... 2-69

2.6 Working with Project Parameters................................................ 2-71
Creating Fields from Formulas........................................................ 2-76
Combining Parameters ................................................................... 2-79

Practice 2g Create Complex Schedules for 
Architectural Projects ..........................................................................  2-81

Practice 2h Create Complex Schedules for MEP Projects ...............  2-89

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
ii © 2021, ASCENT - Center for Technical Knowledge®



Contents

S

Practice 2i Create Complex Schedules for Structural Projects .......  2-94

Chapter Review Questions................................................................. 2-102

Command Summary ........................................................................... 2-104

Introduction to Revit Families

Chapter 3: Custom System Families .......................................................... 3-1

3.1 Creating Wall, Roof, Floor, and Ceiling Types ............................. 3-2

Practice 3a Create an Architectural Wall Type..................................  3-11

Practice 3b Create a Structural Floor Type........................................  3-16

3.2 Vertically Compound Walls.......................................................... 3-19

Practice 3c Create a Vertically Compound Wall................................  3-26

3.3 Stacked and Embedded Walls ..................................................... 3-33

Practice 3d Create Stacked and Embedded Walls ............................  3-36

3.4 Creating MEP System Families.................................................... 3-38

Practice 3e Create MEP System Families: Duct ................................  3-46

Practice 3f Create MEP System Families: Pipe .................................  3-49

Chapter Review Questions................................................................... 3-53

Command Summary ............................................................................. 3-55

Chapter 4: Component Family Concepts ................................................... 4-1

4.1 Creating Component Families ....................................................... 4-2
Preparing to Create Families ............................................................ 4-4
Saving Custom Family Files.............................................................. 4-5

4.2 Creating the Parametric Framework ............................................. 4-6
Adding Dimensions and Labels......................................................... 4-8
Flexing Geometry............................................................................ 4-11
Creating and Modifying Parameters................................................ 4-12

Practice 4a Set Up a Bookcase Family...............................................  4-17

Practice 4b Set Up a Heat Pump Family.............................................  4-22

Practice 4c Set Up a Structural Column Family ................................  4-27

4.3 Creating Family Elements ............................................................ 4-34
Creating 3D Elements ..................................................................... 4-34
Extrusions ....................................................................................... 4-35
Blends ............................................................................................. 4-36
Revolves ......................................................................................... 4-38
Sweeps ........................................................................................... 4-39
Swept Blends .................................................................................. 4-40
Aligning and Locking ....................................................................... 4-41

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2021, ASCENT - Center for Technical Knowledge® iii



Autodesk Revit 2022 BIM Management: Template and Family Creation 

S

Practice 4d Create Family Geometry for the Bookcase....................  4-42

Practice 4e Create Family Geometry for the Heat Pump..................  4-50

Practice 4f Create Family Geometry for the Structural Column ......  4-57

4.4 Creating Family Types.................................................................. 4-65
Working with Families in Projects ................................................... 4-67

Practice 4g Create Family Types for the Bookcase ..........................  4-68

Practice 4h Create Family Types for the Heat Pump ........................  4-71

Practice 4i Create Family Types for the Structural Column.............  4-74

Chapter Review Questions................................................................... 4-77

Command Summary ............................................................................. 4-79

Chapter 5: Advanced Family Techniques .................................................. 5-1

5.1 Additional Tools for Families......................................................... 5-2
Adding Controls................................................................................. 5-2
Setting Room Calculation Points....................................................... 5-3
Adding Connectors............................................................................ 5-4
Adding Openings............................................................................... 5-6
Adding Components.......................................................................... 5-6
Associating Family Parameters......................................................... 5-7

Practice 5a Add a Component to the Bookcase..................................  5-8

Practice 5b Add a Component and Connectors to the 
Heat Pump.............................................................................................  5-16

Practice 5c Modify the Structural Column.........................................  5-25

5.2 Visibility Display Settings ............................................................ 5-33
Adding Lines ................................................................................... 5-35
Creating Masking Regions .............................................................. 5-36

Practice 5d Modify the Visibility of Elements in the Bookcase .......  5-37

Practice 5e Modify the Visibility of Elements in the Heat Pump......  5-44

Practice 5f Modify the Visibility of Elements in the 
Structural Column................................................................................  5-50

Chapter Review Questions................................................................... 5-55

Command Summary ............................................................................. 5-56

Chapter 6: Additional Family Types............................................................ 6-1

6.1 Creating 2D Families....................................................................... 6-2
Creating Detail Items......................................................................... 6-2
Creating Profiles................................................................................ 6-3
Creating Tags and Symbols.............................................................. 6-4

Practice 6a Create 2D Families: Arrow Symbol...................................  6-8

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
iv © 2021, ASCENT - Center for Technical Knowledge®



Contents

S

Practice 6b Create 2D Families: Curtain Wall Mullion Profile ..........  6-10

Practice 6c Create 2D Families: Electrical Trunking Line Profile ....  6-15

Practice 6d Create 2D Families: Structural Floor Profile..................  6-18

6.2 Creating Line-based Families ...................................................... 6-23
Family Category and Parameters ................................................... 6-26

Practice 6e Create Line-based Families: GWB Detail .......................  6-28

Practice 6f Create Line-based Families: Electrical Trunking...........  6-32

Practice 6g Create Line-based Families: Services Symbol Array ...  6-37

Practice 6h Create Line-based Families: Solar Panel Array ............  6-46

6.3 Creating In-Place Families ........................................................... 6-53

Practice 6i Create In-Place Families: Door Opening.........................  6-55

Practice 6j Create In-Place Families: Concrete Corbeling ...............  6-59

6.4 Working with Shared Parameters................................................ 6-64
Shared Parameters ......................................................................... 6-64

Practice 6k Work with Shared Parameters in 
Architectural Projects ..........................................................................  6-70

Practice 6l Work with Shared Parameters in MEP Projects .............  6-80

Practice 6m Work with Shared Parameters in 
Structural Projects ...............................................................................  6-89

Chapter Review Questions................................................................... 6-98

Command Summary ........................................................................... 6-100

Chapter 7: Creating Architectural-Specific Families................................. 7-1

7.1 Creating Custom Doors and Windows.......................................... 7-2

Practice 7a Create Custom Doors ........................................................  7-3

Practice 7b Create Custom Windows...................................................  7-9

7.2 Creating Angled Cornices and Copings ..................................... 7-15
Creating Fascias ............................................................................. 7-15

Practice 7c Create Angled Cornices and Copings............................  7-18

7.3 Creating Custom Railings ............................................................ 7-22
Creating Rail Profiles ...................................................................... 7-22
Creating Baluster, Post, and Panel Families................................... 7-23
Creating Railing Types.................................................................... 7-26

Practice 7d Create Custom Railings...................................................  7-33

Chapter Review Questions................................................................... 7-43

Command Summary ............................................................................. 7-45

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2021, ASCENT - Center for Technical Knowledge® v



Autodesk Revit 2022 BIM Management: Template and Family Creation 

S

Chapter 8: Creating MEP-Specific Families ............................................... 8-1

Practice 8a Upgrade an Architectural Plumbing Fixture to MEP.......  8-2

Practice 8b Upgrade an Architectural Lighting Fixture to MEP.........  8-6

Practice 8c Create a Data Device with Annotation Parameters .......  8-10

Practice 8d Create a Pipe Fitting Flange (Advanced) .......................  8-17

Chapter Review Questions................................................................... 8-32

Chapter 9: Creating Structural-Specific Families ...................................... 9-1

Practice 9a Parametric Gusset Plate ....................................................  9-2

Practice 9b In-Place Column Stiffeners ...............................................  9-9

Practice 9c In-Place Slab Depression ................................................  9-14

Practice 9d Built-Up Column...............................................................  9-20

Practice 9e Tapered Concrete Column ..............................................  9-28

Practice 9f Truss Family ......................................................................  9-31

Practice 9g Precast Hollow Core Slab................................................  9-36

Practice 9h Tapered Moment Frame...................................................  9-43

Chapter Review Questions................................................................... 9-55

Appendix A: Additional Management Tools ..............................................A-1

A.1 General Settings..............................................................................A-2
Specifying Units ................................................................................A-2
Snap Settings....................................................................................A-4
Temporary Dimension Settings.........................................................A-5
Setting Up Arrowheads .....................................................................A-6

A.2 Creating Object Styles....................................................................A-7
Line Color..........................................................................................A-9
Line Patterns ...................................................................................A-10
Line Styles.......................................................................................A-11

A.3 Creating Fill Patterns ....................................................................A-12

A.4 Creating Materials .........................................................................A-15
Working with Assets........................................................................A-22

A.5 Settings for Mechanical Projects.................................................A-24
Mechanical Settings ........................................................................A-24

A.6 Settings for Electrical Projects ....................................................A-31

A.7 Settings for Structural Projects ...................................................A-37

A.8 Additional Schedule Types ..........................................................A-41
Sheet List Schedules ......................................................................A-41
View List Schedules ........................................................................A-45
Note Blocks .....................................................................................A-46

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
vi © 2021, ASCENT - Center for Technical Knowledge®



Contents

S

A.9 Basic User Interface Customization............................................A-49
Configuring the Ribbon ...................................................................A-50
Customizing Shortcuts ....................................................................A-50
Customizing Double-click Settings..................................................A-52
Customizing the Browser Organization...........................................A-53

Command Summary .............................................................................A-55

Index ......................................................................................................  Index-1

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2021, ASCENT - Center for Technical Knowledge® vii



S

Preface

Building Information Modeling (BIM) is an approach to the entire building life 
cycle. Autodesk® Revit® is a powerful BIM program for architecture, MEP, and 
structure that supports the ability to coordinate, update, and share design data 
with team members throughout the design construction and management phases 
of a building’s life. A key component in managing the BIM process is to establish a 
company foundation for different types of projects by creating standard templates 
and custom family elements. Having this in place makes the process of any new 
project flow smoothly and efficiently.

The objective of the Autodesk® Revit® 2022 BIM Management: Template and 
Family Creation guide is to enable users who have worked with the software to 
expand their knowledge in setting up office standards with templates that include 
annotation styles, preset views, sheets, and schedules, as well as creating 
custom system, in-place, and component families. 

This guide contains practices that are specific to each discipline.

Topics Covered

• Create custom templates with annotation styles, title blocks, and custom 
element types.

• Create schedules, including material takeoff schedules with formulas.

• Create custom wall, roof, and floor types, as well as MEP system families.

• Set up a component family file with a parametric framework.

• Create family geometry.

• Create family types.

• Modify the visibility of components and incorporate additional family items 
such as controls, MEP connectors, and nested components.

• Create specific families, including in-place families, profiles, annotations, and 
parameters.

This guide also contains discipline-specific practices for families, including doors, 
windows, railings, pipe fittings, light fixtures, gusset plates, and built-up columns.
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Prerequisites

• Access to the 2022.0 version of the software, to ensure compatibility with this 
guide. Future software updates that are released by Autodesk may include 
changes that are not reflected in this guide. The practices and files included 
with this guide might not be compatible with prior versions (e.g., 2021). 

• You should be comfortable with the fundamentals of the Autodesk Revit 
software, as found in the Autodesk Revit 2022: Fundamentals for Architecture, 
Autodesk Revit 2022: Fundamentals for Structure, or Autodesk Revit 2022: 
Fundamentals for MEP guides. Knowledge of basic techniques is assumed, 
such as creating standard elements, copying and moving elements, and 
creating and working with views. Information on Collaboration Tools, 
Conceptual Design, and Site and Structural Design are covered in other 
guides.

Note on Software Setup

This guide assumes a standard installation of the software using the default 
preferences during installation. Lectures and practices use the standard software 
templates and default options for the Content Libraries.

Students and Educators Can Access Free Autodesk Software 
and Resources

Autodesk challenges you to get started with free educational licenses for 
professional software and creativity apps used by millions of architects, 
engineers, designers, and hobbyists today. Bring Autodesk software into your 
classroom, studio, or workshop to learn, teach, and explore real-world design 
challenges the way professionals do.

Get started today - register at the Autodesk Education Community and download 
one of the many Autodesk software applications available. 

Visit www.autodesk.com/education/home/

Note: Free products are subject to the terms and conditions of the end-user 
license and services agreement that accompanies the software. The software is 
for personal use for education purposes and is not intended for classroom or lab 
use.am
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Lead Contributor: Cherisse Biddulph

Cherisse is an Autodesk Certified Professional for Revit as well as an Autodesk 
Certified Instructor. She brings over 19 years of industry, teaching, and technical 
support experience to her role as a Learning Content Developer with ASCENT. 
With a passion for design and architecture, she received her Associates of 
Applied Science in Drafting and Design and has worked in the industry assisting 
firms with their CAD management and software implementation needs as they 
modernize to a Building Information Modeling (BIM) design environment. 
Although her main passion is the Revit design product, she is also proficient in 
AutoCAD, Autodesk BIM 360, and Autodesk Navisworks. Today, Cherisse 
continues to expand her knowledge in the ever-evolving AEC industry and the 
software used to support it.

Cherisse Biddulph has been the Lead Contributor for Autodesk Revit BIM 
Management: Template and Family Creation since 2020.
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In This Guide

The following highlights the key features of this guide. 

Feature Description

Practice Files The Practice Files page includes a link to the practice files and 
instructions on how to download and install them. The practice files 
are required to complete the practices in this guide.

Chapters A chapter consists of the following - Learning Objectives, 
Instructional Content, Practices, Chapter Review Questions, and 
Command Summary. 

• Learning Objectives define the skills you can acquire by learning 
the content provided in the chapter.

• Instructional Content, which begins right after Learning 
Objectives, refers to the descriptive and procedural information 
related to various topics. Each main topic introduces a product 
feature, discusses various aspects of that feature, and provides 
step-by-step procedures on how to use that feature. Where 
relevant, examples, figures, helpful hints, and notes are provided.

• Practice for a topic follows the instructional content. Practices 
enable you to use the software to perform a hands-on review of a 
topic. It is required that you download the practice files (using the 
link found on the Practice Files page) prior to starting the first 
practice.

• Chapter Review Questions, located close to the end of a 
chapter, enable you to test your knowledge of the key concepts 
discussed in the chapter. 

• Command Summary concludes a chapter. It contains a list of the 
software commands that are used throughout the chapter and 
provides information on where the command can be found in the 
software.

Appendices Appendices provide additional information to the main course 
content. It could be in the form of instructional content, practices, 
tables, projects, or skills assessment.
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C h a p t e r

Creating Custom Templates

Custom templates can save you time and effort when creating similar projects by 
providing an efficient way to apply your organization’s graphic and documentation 
standards. Templates can include items such as levels, views, sheets, schedules, 
and annotation types for text, dimensions, and tags. A custom title block is a 
typical family that is added to templates that ensures that sheets are created with 
the appropriate information. You may also want to add rule-based view filters and 
view templates to project template files for improved workflow within the project.

 Learning Objectives in This Chapter

• Create project templates.

• Use resource projects to store additional system families, details, schedules, and other data.

• Create standard text and dimension types for use in your projects.

• Modify callout, elevation, and section tags and specify which tags are loaded in a template.

• Create title blocks, including detail lines, text, labels, symbols, regions, and revision 
schedules.

• Set up visibility/graphic override filters for various categories of elements.

• Create and apply view templates.
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1.1 Preparing Project Templates
A project template is a file that contains information that can be 
used over and over to create new projects. The goal is to save 
time by using company standards, enabling you to concentrate 
on the design. For example, predefined levels (as shown in 
Figure 1–1 for a residential project) and the associated plan 
views and elevations provides a starting point for a model.

Figure 1–1

• Some items in a project template include: 

• Project views - Levels, schedules, legends, sheets, plan 
views, and view templates.

• Project-based settings - Project units, object styles, fill 
patterns, line styles, discipline-specific settings, etc.

• Families - System families, component families, custom 
families, and title blocks.

• Print settings - Define printers and print settings.

• Annotation types - Dimension style, text, arrowheads, 
and tags.

• If you provide constant work to a specific client (e.g., a school 
system or government entity), you can create a template 
specific to their projects with associated title blocks and other 
information. 

• You can also store items such as sheets, schedules, families, 
and drafting views (details) in a separate resource file and 
add the elements to the current project, as needed.

• As you create new templates, families, and title blocks, it is 
recommended that you save them in a safe location where 
they will not be deleted and are outside of the Revit file 
structure.
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How To: Create a Project Template File

Project templates are 
located in the 
C:\ProgramData\
Autodesk\RVT 2022\
Templates\English
(Metric) or 
English-Imperial folder.

1. In the File tab, expand  (New) and click (Project). 

• Alternatively, on the Revit Home screen, click (New...) 
in the MODELS area, as shown in Figure 1–2. 

Figure 1–2

2. In the New Project dialog box, in the Template file area, 
select a template file to begin with or select <None> to use a 
blank project file.

3. In the Create new area, select Project template, as shown in 
Figure 1–3.

• Project template files have the extension .rte.

Figure 1–3

4. Click OK.
5. Add settings, families, views, etc., as needed to the new file.
6. Save the project template file.

• To save time, use an existing project or template that includes 
some of the basics you need rather than starting from 
scratch. Note: Make sure to clean up all existing project data 
that is not standard.
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• If you select <None> in the Template file list, you are 
prompted to specify the initial unit system for the project: 
Imperial or Metric, as shown in Figure 1–4. Choosing this 
option requires all settings to be defined and updated versus 
choosing a predefined template that is similar to your needs.

Figure 1–4

Managing
Settings

Most of the settings stored in a template file are found in the 
Manage tab>Settings panel, as shown in Figure 1–5. These 
settings include Materials, Object Styles, Snaps, and Additional 
Settings (e.g., Line Styles, Fill Patterns, Annotations, etc.)

Figure 1–5

• Specific Structural Settings, MEP Settings, and Panel 
Schedule Templates are also included in the Settings panel.

For more information on managing settings, see: 

• A.1 General Settings

• A.2 Creating Object Styles

• A.3 Creating Fill Patterns

• A.4 Creating Materials

• A.5 Settings for Mechanical Projects

• A.6 Settings for Electrical Projects

• A.7 Settings for Structural Projects

Families in
Templates

There are two kinds of families that can be set up in template 
files: system families, such as the duct shown in Figure 1–6, and 
component families, such as the air terminal shown in 
Figure 1–6.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–4 © 2021, ASCENT - Center for Technical Knowledge®



Creating Custom Templates

S

Figure 1–6

For more information on 
setting up system 
families, see Chapter 3: 
Custom System 
Families.

System Families are families that are predefined in Revit 
projects and templates. Unlike external loadable families, system 
families can be created by duplicating existing types and 
modifying the Type Parameters, as shown in Figure 1–7. This 
can only be done within a project and helps to establish the 
company standard for the families set up in a template file. 
System families include walls, wall foundations, floors, structural 
slabs, ceilings, stairs, railings, and roofs. They also include duct, 
pipe, cable tray, and conduit types, along with some annotation 
types, such as text and dimensions.

Figure 1–7

For more information on 
creating component 
families, see Chapter 4: 
Component Family 
Concepts.

Component Families are external loadable families that are 
created outside of a project and can be loaded directly in a 
template file with types and sizes that are used frequently. 
Component families include elements such as furniture, trees, 
beams, columns, mechanical equipment, and electrical fixtures. 
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How To: Load a Family from the Revit Library

1. In the Insert tab>Load from Library panel,  click 

(Load Family).

• Alternatively, you can load a family by starting a loadable 
family command, then in the Modify contextual tab>Mode 

panel, click  (Load Family). 

2. In the Load Family dialog box, locate the folder that contains 
the family or families you want to load, as shown in 
Figure 1–8. 

• The program remembers the last-used folder. If the Load 
Family dialog box does not default to the Revit Library 
folder, click on Imperial Library in the Places panel.

Figure 1–8

3. Select the family or families you want to load. You can hold 
<Ctrl> to select multiple families.

4. Click Open.

• Note: When inserting a family using a loadable family 
command, after you load the family your cursor will have the 
loaded element at the end of the cursor to prompt you to 
place the element. You will need to press <Esc> twice or click 

 (Modify) to clear the cursor.

Places panel

Click on library 
shortcut
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How To: Load an Autodesk Family

In addition to loading families from the installed Revit Library, you 
can also load families from the Autodesk online library using hte 
Load Autodesk Family command.

1. In the Insert tab>Load from Library panel, click  (Load 
Autodesk Family).

2. In the Load Autodesk Family dialog box, filter your search by 
typing in what kind of family you are looking for or click on a 
category in the Browse section, as shown in Figure 1–9.

Figure 1–9

3. Click Load to load the family into your project.

Search bar
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Review Loaded
Families

You can review which families have already been loaded to 
determine which families still need to be loaded.

How To: Review the Loaded Families

1. In the Project Browser, expand the Families node.
2. Expand various nodes within the Families node, such as the 

Cable Trays>Cable Tray with Fittings node shown on the 
left in Figure 1–10, to verify which families (in this case, which 
cable tray families) have been loaded into the template.

3. Select the family name, such as Channel Cable Tray, to 
review its Properties, as shown on the right in Figure 1–10.

Figure 1–10

• Alternatively, you can start a command like Door, Air 
Terminal, or Plumbing Fixture to verify from the Type 
Selector which families are loaded. If a family is not loaded, a 
dialog box will display (as shown in Figure 1–11). Click Yes to 
launch the Load Family dialog box.

Figure 1–11
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Purging
Unused

Components

You can clean up a template by removing unnecessary elements 
from a project, including individual component types, as shown 
in Figure 1–12.

Figure 1–12

• Some elements are nested in other elements, and it might 
require several rounds of purging the project to remove them.

How To: Purge Unused Elements

1. In the Manage tab>Settings panel, click  (Purge Unused).
2. The Purge Unused dialog box opens and all elements will be 

selected. Click Check None to clear the selection.
3. Select only the elements that you want to purge. 
4. Click OK.

Purging unused components not only helps simplify the 
component list, but also, more importantly, reduces the project 
file size.
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Using Resource
Projects

Although you can use a template file to start a project, you might 
also want to have resource projects that include additional 
system and component families, pre-drawn details (as shown in 
Figure 1–13), schedules, and sheets. You can then copy these 
elements into a new template or the current project, as needed.

Figure 1–13

• To copy drafting views (details), sheets, schedules, or reports 
into the current project, use Insert Views from File.

• To copy system families (e.g., wall, floor, duct, pipe, wire 
types, etc) or annotations (e.g., text and dimension styles, 
materials, etc.), use Transfer Project Standards.

• To copy component families from a resource project, use 
Copy to the Clipboard and either Paste Aligned to 
Selected Levels or Paste Aligned to Selected Views.

How To: Insert Views from an Existing Project

1. In the Insert tab>Load from Library panel, expand  (Insert 

from File) and click  (Insert Views from File).
2. In the Open dialog box, select the project file you want to 

copy from.
3. In the Insert Views dialog box, select the views you want to 

insert into the current project, as shown in Figure 1–14. 
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• In the lower left corner, you can select Preview selection 
to preview your selection.

Figure 1–14

4. Click OK. The views are added to the file.

• Schedules are completed with the information in the current 
project. Sheets are added, but do not include any views.

How To: Transfer Project Standards

1. Open the project from which you want to transfer information.
2. Switch to the current project you are copying to.

3. In the Manage tab>Settings panel, click  (Transfer Project 
Standards).

4. In the Select Items To Copy dialog box, expand the Copy 
from drop-down list and select the file to copy from.am
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Click Check None or 
Check All, as needed.

5. Select the items you want to copy into the current project, as 
shown in Figure 1–15. Then, click OK.

Figure 1–15

• All types of the selected category will be copied. You do not 
have the option to select individual types.

• If the Duplicate Types dialog box displays (shown in 
Figure 1–16), choose Overwrite or New Only to update the 
existing project.

Figure 1–16

• Floor, ceiling, and elevation section plan view types and Revit 
link visibility settings cannot be transferred and need to be set 
up manually.
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Setting Default
Template Files

If your company uses several different templates, you can create 
a list that displays in the New Project dialog box, as shown in 
Figure 1–17. 

Figure 1–17

How To: Set the Default Template Files List

1. In the File tab, click Options. 
2. In the Options dialog box, in the left pane, select File 

Locations, as shown in Figure 1–18. 

Figure 1–18

• Use  (Add Value) to add additional templates (RTE).

• To put your templates in order, use  (Move Rows Up) 

and  (Move Rows Down). Move the templates that are 
used most often to the top.

•  Use  (Remove Value) if you do not need a template 
anymore.

3. Once the template is loaded, you can click on the name in the 
Name column to change it or leave it with its default file 
name. You can also click on any of the other names in the 
Name column and change them if needed.

4. To update a template, click on the file path in the Path column 

and select the  (Browse) button. 
5. In the Browse for Template File dialog box, navigate to the 

correct folder, select the template file, and click Open.
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Practice 1a Prepare Project Templates: 
Architecture
 

In this practice, you will create a new template file based on an 
existing template and add several levels to the project. You will 
review the existing system and component families and load a 
component family. You will then insert views and transfer project 
standards from a resource project, as shown for text types before 
in Figure 1–19 and after in Figure 1–20.

Task 1 - Establish a project template file.

1. On the Home screen, click New... in the MODELS area, or if 

currently in a model, in the File tab, expand (New) and 

click (Project).

Practice Objectives

• Create a new project template file.

• Add levels with plan views.

• Review existing system and component families.

• Load a component family.

• Insert views and transfer project standards from a resource project.

Figure 1–19 Figure 1–20

Before After
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2. In the New Project dialog box, select Imperial-Architectural 
Template.

3. In the Create new area, select Project template, as shown in 
Figure 1–21, and click OK.

Figure 1–21

4. In the Quick Access Toolbar, click  (Save) and save the 
template in the practice files Architectural >Template Files 
folder as Midrise-Template.rte. 

Task 2 - Add default levels.

1. Open an elevation view. 

2. Click on the level head and rename Level 1 to Floor 1 and 
Level 2 to Floor 2. Click Yes to rename the corresponding 
views. 

3. Change the Floor 2 height to 16'-0", as shown in 
Figure 1–22.

Figure 1–22

4. In the Architecture tab>Datum panel, click  (Level).

5. In the Options Bar, verify that the Make Plan View option is 
selected and click Plan View Types....
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6. In the Plan View Types dialog box, select the Ceiling Plan 
and Floor Plan view types, as shown in Figure 1–23, and 
click OK.

Figure 1–23

7. Add three more levels above Floor 2 with a distance of 
12'-0" between each level, and two levels below Floor 1 with 
a distance of 10'-0" between them. Rename them as shown 
in Figure 1–24. Click Yes to rename the corresponding views.

Scale change and 
dimensions are added 
for clarity.

Figure 1–24

8. Return to the Floor 1 plan view.

9. Save the template.am
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Task 3 - Load a component family.

1. In the Insert tab>Load from Library panel, click  (Load 
Family).

• By using the Load Family command, you can load any 
type of component. If you use a specific command, such 
as Column or Door, you can only load that type of family.

2. In the Load Family dialog box, navigate to the Revit Library’s 
Columns folder and select the Doric Column.rfa family to 
load, then click Open.

3. Save the template.

Task 4 - Review existing family elements in the template.

In this task, you will review existing families in a project using 
both the Type Selector and the Project Browser.

1. In the Annotate tab>Text panel, click  (Text).

2. Expand the list in the Type Selector. Only a few text types are 
available, as shown in Figure 1–25.

Figure 1–25

3. In the Architecture tab>Build panel, select  (Component) 
and review the list of families in the Type Selector.

4. In the Architecture tab>Build panel, click  (Column) and 
note that Doric Column is showing in the Type Selector.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2021, ASCENT - Center for Technical Knowledge® 1–17



Autodesk Revit 2022 BIM Management: Template and Family Creation 

S

5. In the Project Browser, expand the Families>Columns node 
and note that Doric Column is listed there as well, as shown 
in Figure 1–26. Continue to expand nodes within the Project 
Browser to see what other families are loaded in the project.

Figure 1–26

6. Save the template.

Task 5 - Copy information from a resource project.

1. Close any open projects other than the template file.

2. In the Insert tab>Load from Library panel, expand  (Insert 

from File) and click  (Insert Views from File).

3. In the Open dialog box, navigate to the Revit 2022 BIM 
Management Practice Files>Reference folder, select 
Construction Resource Project.rvt, and click Open.

4. In the Insert Views dialog box, set the Views drop-down list to 
Show all views and sheets.
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5. Select one or two drafting views and one or two schedules 
from the list, as shown in Figure 1–27. 

Figure 1–27

6. Click OK.

7. If the Duplicate Types warning displays, click OK and close 
any warning messages that pop up.

8. In the Project Browser of your template file, review the new 
drafting views and schedules that are added. 

9. Return to the floor plan view.

10. In the Manage tab>Settings panel, click  (Transfer Project 
Standards).

11. In the Select Items To Copy dialog box, note that the Copy 
from drop-down list is set to Construction Resource 
Project.rvt, which is the project that was just used for 
inserting a view from a file.
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Note: If the Insert from 
File command was not 
used, you would have 
had to open the project 
in order to transfer 
standards.

12.Click Check None, select Text Types (as shown in 
Figure 1–28), and click OK.

Figure 1–28

13. If the Duplicate Types dialog box displays, select New Only 
because you do not want to overwrite existing text types in 
your template.

14.Start the Text command and look at the expanded list of text 
types that are now available, as shown in Figure 1–29.

Figure 1–29

15.Click  (Modify).

16.Save and close the template file.
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Practice 1b Prepare Project Templates: MEP
 

In this practice, you will create a new template file based on an 
existing template. You will review the existing system and 
component families and load a component family. You will then 
insert views and transfer project standards from a resource 
project, as shown for text types before in Figure 1–30 and after 
in Figure 1–31.

Task 1 - Establish a project template file.

1. On the Home screen, click New... in the MODELS area, or if 

currently in a model, in the File tab, expand (New) and 

click (Project).

Practice Objectives

• Create a new project template file.

• Review existing system and component families.

• Load a component family.

• Insert views and transfer project standards from a resource project.

Figure 1–30 Figure 1–31

Before After

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2021, ASCENT - Center for Technical Knowledge® 1–21



Autodesk Revit 2022 BIM Management: Template and Family Creation 

S

2. In the New Project dialog box, select the Imperial-Systems 
Template. This template will have electrical, mechanical, and 
plumbing views and families in it.

• For an electrical template, click Browse... and select 
Electrical-Default.rte.

• For a mechanical template, click Browse... and select 
Mechanical-Default.rte.

• For a plumbing template, click Browse... and select 
Plumbing-Default.rte.

3. In the Create new area, select Project template, as shown in 
Figure 1–32, and click OK.

Figure 1–32

4. In the Quick Access Toolbar, click  (Save) and save the 
template in the practice files MEP>Template Files folder as 
Midrise-Template.rte. 

Note: MEP templates typically do not have additional levels. 
Levels are created using Copy/Monitor with a linked file.

Task 2 - Load a component family.

1. In the Insert tab>Load from Library panel, click  (Load 
Family).

• By using the Load Family command, you can load any 
type of component. If you use a specific command, such 
as Mechanical Equipment, you can only load that type of 
family.

2. In the Load Family dialog box, navigate to the Revit Library’s 
Mechanical>MEP folder and select the Indoor AHU - 
Horizontal - Chilled Water Coil.rfa family to load, then click 
Open.
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Task 3 - Review existing family elements in the template.

In this task, you will review existing families in a project using 
both the Type Selector and the Project Browser.

1. In the Annotate tab>Text panel, click  (Text).

2. Expand the list in the Type Selector. Only a few text types are 
available, as shown in Figure 1–33.

Figure 1–33

3. In the Systems tab>Model panel, select  (Component) and 
review the list of families in the Type Selector.

4. In the Systems tab>Mechanical panel, click  (Mechanical 
Equipment). Note that Indoor AHU - Horizontal - Chilled 
Water Coil is showing in the Type Selector.
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5. In the Project Browser, expand the Families>Mechanical 
Equipment node and note that Indoor AHU - Horizontal - 
Chilled Water Coil is listed there as well, as shown in 
Figure 1–34. Continue to expand nodes within the Project 
Browser to see what other families are loaded in the project.

Figure 1–34

6. Save the template.

Task 4 - Copy information from a resource project.

1. Close any open projects other than the template file.

2. In the Insert tab>Load from Library panel, expand  (Insert 

from File) and click  (Insert Views from File).
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3. In the Open dialog box, navigate to the Revit 2022 BIM 
Management Practice Files>Reference folder, select 
Construction Resource Project.rvt, and click Open.

4. In the Insert Views dialog box, set the Views drop-down list to 
Show all views and sheets.

5. Select one or two drafting views and one or two schedules 
from the list, as shown in Figure 1–35. 

Figure 1–35

6. Click OK.

7. If the Duplicate Types warning displays, click OK and close 
any warning messages that pop up.

If you started with the 
systems or electrical 
template, the drafting 
views will be in the 
Architectural section in 
the Project Browser.

8. In the Project Browser of your template file, review the new 
drafting views and schedules that are added. 

9. Return to the floor plan view.

10. In the Manage tab>Settings panel, click  (Transfer Project 
Standards).

11. In the Select Items To Copy dialog box, note that the Copy 
from drop-down list is set to Construction Resource 
Project.rvt, which is the project that was just used for 
inserting a view from a file.
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Note: If the Insert from 
File command was not 
used, you would have 
had to open the project 
in order to transfer 
standards.

12.Click Check None, select Text Types (as shown in 
Figure 1–36), and click OK.

Figure 1–36

13. If the Duplicate Types dialog box displays, select New Only 
because you do not want to overwrite existing text types in 
your template.

14.Start the Text command and look at the expanded list of text 
types that are now available, as shown in Figure 1–37.

Figure 1–37

15.Click  (Modify).

16.Save and close the template file.
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Practice 1c Prepare Project Templates: 
Structural 
 

In this practice, you will create a new template file based on an 
existing template and add several levels to the project. You will 
review the existing system and component families and load a 
component family. You will then insert views and transfer project 
standards from a resource project, as shown for text types 
before in Figure 1–38 and after in Figure 1–39.

Task 1 - Establish a project template file.

1. On the Home screen, click New... in the MODELS area, or if 

currently in a model, in the File tab, expand (New) and 

click (Project).

Practice Objectives

• Create a new project template file.

• Add levels with plan views.

• Review existing system and component families.

• Load a component family.

• Insert views and transfer project standards from a resource project.

Figure 1–38 Figure 1–39

Before After
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2. In the New Project dialog box, select the Imperial-Structural 
Template. 

3. In the Create new area, select Project template, as shown in 
Figure 1–40, and click OK.

Figure 1–40

4. In the Quick Access Toolbar, click  (Save) and save the 
template in the practice files Structural>Template Files folder 
as Midrise-Template.rte. 

Task 2 - Add default levels.

1. Open an elevation view. 

2. Click on the level head and rename Level 1 to Ground Floor 
and Level 2 to TOS-Floor 1. Click Yes to rename the 
corresponding views. 

3. Change the TOS-Floor 1 height to 14'-7", as shown in 
Figure 1–41.

Figure 1–41

4. In the Structure tab>Datum panel, click  (Level).

5. In the Options Bar, verify that the Make Plan View option is 
selected and click Plan View Types....
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6. In the Plan View Types dialog box, select the Structural Plan 
view type, as shown in Figure 1–42, and click OK.

Figure 1–42

7. Add three more levels above TOS-Floor 1 with a distance of 
15'-0" between each level, and one level below Ground 
Floor with a distance of 15'-0" between them. Rename them 
as shown in Figure 1–43. Click Yes to rename the 
corresponding views.

Scale change and 
dimensions are added 
for clarity.

Figure 1–43

8. Return to the Ground Floor plan view.

9. Save the template.
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Task 3 - Load a component family.

1. In the Insert tab>Load from Library panel, click  (Load 
Family).

• By using the Load Family command, you can load any 
type of component. If you use a specific command, such 
as Column or Truss, you can only load that type of 
family.

2. In the Load Family dialog box, navigate to the Revit Library’s 
Structural Columns>Steel folder, select Pipe-Column.rfa, 
and click Open.

3. In the Specify Types dialog box, select Pipe8STD and click 
OK.

4. Save the template.

Task 4 - Review existing family elements in the template.

In this task, you will review existing families in a project using 
both the Type Selector and the Project Browser.

1. In the Annotate tab>Text panel, click  (Text).

2. Expand the list in the Type Selector. Only a few text types are 
available, as shown in Figure 1–44.

Figure 1–44

3. In the Structure tab>Model panel, select  (Component) 
and review the list of families in the Type Selector.

4. In the Structural tab>Structure panel, select  (Column). 
Note that Pipe8STD is displayed in the Type Selector.
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5. In the Project Browser, expand the Families>Structural 
Columns>Pipe-Column node and note that Pipe8STD is 
listed there as well, as shown in Figure 1–45. Continue to 
expand nodes within the Project Browser to see what other 
families are loaded in the project.

Figure 1–45

6. Save the template.
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Task 5 - Copy information from a resource project.

1. Close any open projects other than the template file.

2. In the Insert tab>Load from Library panel, expand  (Insert 

from File) and click  (Insert Views from File).

3. In the Open dialog box, navigate to the Revit 2022 BIM 
Management Practice Files>Reference folder, select 
Construction Resource Project.rvt, and click Open.

4. In the Insert Views dialog box, set the Views drop-down list to 
Show all views and sheets.

5. Select one or two drafting views and one or two schedules 
from the list, as shown in Figure 1–46. 

Figure 1–46

6. Click OK.

7. If the Duplicate Types warning displays, click OK and close 
any warning messages that pop up.

8. In the Project Browser of your template file, review the new 
drafting views and schedules that are added. 

9. Return to the floor plan view.
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10. In the Manage tab>Settings panel, click  (Transfer Project 
Standards).

11. In the Select Items To Copy dialog box, note that the Copy 
from drop-down list is set to Construction Resource 
Project.rvt, which is the project that was just used for 
inserting a view from a file.

Note: If the Insert from 
File command was not 
used, you would have 
had to open the project 
in order to transfer 
standards.

12.Click Check None, select Text Types (as shown in 
Figure 1–47), and click OK.

Figure 1–47

13. If the Duplicate Types dialog box displays, select New Only 
because you do not want to overwrite existing text types in 
your template.
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14.Start the Text command and look at the expanded list of text 
types that are now available, as shown in Figure 1–48.

Figure 1–48

15.Click  (Modify).

16.Save and close the template file.
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1.2 Customizing Annotation 
Types

Establishing annotation style types is an important part of 
template creation. You can customize annotation types in your 
project template file, including dimensions, text, arrowheads, and 
tags. Figure 1–49 shows the different types of annotations. 
Within each annotation type, you can customize font, text size, 
background, leaders, etc.

Figure 1–49

Text, Dimensions, and Arrowheads are all system families and 
are depicted with the label System Family in front of the name in 
their Type Properties (as shown in Figure 1–50) and component 
families. This means they have a standard set of parameters, 
which you can modify and save as a type. 

Figure 1–50

Callout, section, and elevation tags can be modified in Revit. 
Most other tags, like door, window, and beam tags, are created 
using component families.
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Creating Text
Types

Text types are used to standardize text formatting (such as the 
font, text height, etc.), as shown in Figure 1–51. They can be 
created for both annotative text and model text.

Figure 1–51

• The Text command places 2D text at the height you need for 
the final plot. The view scale controls the height of the 
standard text in the views.

• The Text Size parameter represents the height of an upper 
case letter. (Verify that the text in projects created in earlier 
versions of the software displays as expected.)

• The Model Text command places work plane based 3D text 
that is typically used on buildings, walls, doors, or signs, as 
shown in Figure 1–52. Text types for model text should be the 
actual height of the final signage element and are not 
affected by the view scale.

Figure 1–52

Model Text
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How To: Create a Text Type

1. Start the Text command. 

2. In Properties, click  (Edit Type) or in the Annotate 

tab>Text panel title, click  (Text Types).
3. In the Type Properties dialog box, click Duplicate....
4. Type a new name and click OK.The new type is activated.
5. Modify the parameters as needed for the new type, as shown 

for annotation text in Figure 1–53.

Figure 1–53

6. Click OK to finish.

How To: Create a Model Text Type

1. In the Architecture tab>Model panel, click  (Model Text). 
Alternatively, in the Structure tab>Model panel, click 

(Model Text).
2. In the Edit Text dialog box, keep the default text and click OK, 

then place the text in the view.

3. Select the model text and from Properties, click Edit Type. 

4. In the Type Properties dialog box, click Duplicate....
5. Type a new name and click OK. The new type is activated.
6. Modify the parameters as needed for the new text type.
7. Click OK to finish.
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Creating
Dimension

Types

Dimensions are one of the more complex system families in 
terms of the number of parameters you can modify. They include 
options for the Dimension Text, Dimension Line, Tick Marks, and 
Witness Lines. You can specify information such as the units, 
color, and all of the gap sizes between elements, as shown in 
Figure 1–54.

Figure 1–54

• You can add a suffix or prefix to a dimension type by creating 
a type-driven dimension style. Duplicate the dimension style 
and specify a set prefix and suffix within the type parameters. 
This eliminates the need for users to manually modify the 
dimension every time they need to add a prefix or suffix.

How To: Create Dimension Types

1. In the Annotate tab>Dimension panel, expand the Dimension 
panel title (as shown in Figure 1–55) and click the dimension 

type with the  icon next to it that you want to create.

You create separate 
types for each 
dimension method. 

Figure 1–55

Witness Line

Set gap between witness 
line and reference

Tick Mark

Dimension Text

Dimension Line
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2. In the Type Properties dialog box, click Duplicate....
3. Type a new name and click OK. The new type is activated.
4. Modify the parameters as needed for the new type, as shown 

in Figure 1–56. 

• Values for parameters (such as text size, witness line 
extension, etc.) are the actual plot size for these 
elements. The view scale controls how large they are in 
the specific view.

• Specify a prefix or suffix for Primary Units, as shown in 
Figure 1–56.

Figure 1–56

5. Click OK when you are finished.

• For linear dimensions, you can specify a Leader Type, 
Shoulder Length, and Leader Tick Mark, as well as the Show 
Leader When Text Moves option that is used when the text is 
pulled away from the dimension string. You can also specify 
the text inserted for Equality Text (the default is EQ).

• You can specify a Text Background option. If you set the 
value to opaque, it automatically masks any elements behind 
the text. If it is set to transparent, anything the text overlaps 
is still visible.
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• If you are dimensioning doors and windows by their widths 
rather than their centers, you can also have the opening 
height displayed with the dimension. Select Show Opening 
Height.

Loading Tags
and Symbols

Tags and symbols are 2D component families that must be 
loaded into a project. Not all types of tags need to be in each 
project, so you can choose which ones you want to include in 
your templates. For example, if you are working in an 
architectural project, you can load tags such as the door, 
window, and wall shown in Figure 1–57. 

Figure 1–57

How To: Specify Loaded Tags and Symbols

1. In the Annotate tab>Tag panel, expand the panel title and 

click  (Loaded Tags and Symbols).
2. In the Loaded Tags and Symbols dialog box, use the Filter list 

field to limit the types of tags you are looking for by discipline, 
as shown in Figure 1–58.
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Some elements, such 
as Floors and Structural 
Fabric Reinforcement, 
have both tags and 
symbols. They can both 
be specified in this 
dialog box.

Figure 1–58

3. Click Load Family....
4. In the Load Family dialog box, navigate to the appropriate 

library and folder. Note, tags are typically found in the Revit 
Library’s Annotations folder and sorted within discipline 
sub-folders.

5. Select the required tags and click Open. Hold <Ctrl> or 
<Shift> to select multiple tags.

6. The selected tags are assigned to their appropriate 
categories.

7. When you have loaded all of the tags that you need for a 
project, click OK.

8. If multiple tags are loaded for a category, you can choose 
which one is the default tag by choosing it in the Loaded Tags 
column, as shown in Figure 1–59.

Figure 1–59
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Specifying
View Tags

Callouts, Elevations, and Section markers are system family 
view tags and can be modified to suit office standards. For 
example, you can create a new Elevation view type containing a 
tag that displays the view name by duplicating an existing one 
and modifying the properties, as shown in Figure 1–60.

Figure 1–60

How To: Create Custom System Family Tags for 
View Types

1. In the View tab>Create panel, click  (Callout), 

(Elevation), or  (Section), and in Properties, click 

(Edit Type). In the Type Properties dialog box, select an 
existing type, then duplicate and name the new view type, as 
shown for an elevation view in Figure 1–61.

Each view type has 
different parameters.

Figure 1–61
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2. Beside any of the tag parameters, click in the Value column 

and then click  (Browse). 
3. In the Type Properties dialog box for the tag, select from an 

existing tag type or duplicate a tag type, and specify a new 
mark element from a list of families that have been loaded 
into the project, as shown in Figure 1–62.

Figure 1–62

4. Click OK to apply the tag type.
5. Modify the other parameters as needed and click OK to close 

the Type Properties dialog box.

• Levels (shown in Figure 1–63) and grids (shown in 
Figure 1–64) are also system families that are set up in Type 
Properties and include component families such as the 
Symbol Level Head-Circle and Grid Head-Circle.

Tag type

Figure 1–63 Figure 1–64
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How To: Create Custom System Family Tag Types 
from an Existing Tag

1. In the Manage tab>Settings panel, expand (Additional 

Settings), expand  (Annotations), and select  (Callout 

Tags), (Elevation Tags), (Arrowheads), or 

(Section Tags). 
2. In the Type Properties dialog box for the tag, select from an 

existing tag type or duplicate a tag type, as shown in 
Figure 1–65.

Figure 1–65

3. In the Type Parameters area, in the Graphics section, specify 
a new mark element from a list of families that have been 
loaded into the project, as shown in Figure 1–66.

Figure 1–66

4. Click OK.
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Practice 1d Customize Annotation Types: All 
Disciplines
 

In this practice, you will create text types, duplicate and modify 
dimension styles (as shown in Figure 1–67), and load typical 
tags into the project template file. You will also create a new 
elevation tag that includes the view name information.

Figure 1–67

Task 1 - Create text types.

1. Open the project template Midrise-Template.rte that you 
created in the previous practice. If you did not complete the 
previous practice, open the template found in the practice 
files folder that relates to your discipline:

• Architectural>Template Files> 
Midrise-Template-Architectural-1.rte 

• MEP>Template Files>Midrise-Template-MEP-1.rte

• Structural>Template Files> 
Midrise-Template-Structural-1.rte

2. Start the Text command. 

3. In Properties, click  (Edit Type)

4. In the Type Properties dialog box, click Duplicate....

Practice Objectives

• Set up text and dimension types.

• Load tags.

• Create a new view tag.
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5. Type the Name Title Small and click OK.The new type is 
activated.

6. In the Text section, select a font and other options, as 
needed. Set the Text Size to 1/4", as shown in Figure 1–68.

Figure 1–68

7. Click OK and type in some text using the new text type.

8. Create a duplicate of the new text type named Title Large. 
Change the Text Size to 1/2" and add some text using the 
new type.

9. Save the template file.

Task 2 - Create dimension styles.

1. Model a few linear elements (such as walls, beams, or duct) 
and add two linear and two angular dimensions shown in 
Figure 1–69.

Figure 1–69
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2. Click  (Modify).

3. Select the outer most linear dimension.

4. In the Properties, click Edit Type. 

5. In the Type Properties dialog box, duplicate the type and 
name it Linear - Standard.

6. In the Text group, change the Text Size to 1/8".

7. Click on Units Format. In the Format dialog box, clear the 
check mark for Use project settings and change the 
Rounding to the nearest 1/8", as shown in Figure 1–70.

Figure 1–70

8. Click OK twice to finish. The linear dimension updates to the 
new style.

9. Select the outermost angular dimension. Duplicate the type 
and name it Angular - Standard.

10. In the Type Properties dialog box, in the Graphics group, 
change the Tick Mark to Arrow Filled 30 Degree.

11. In the Text group, change the Text Size to 1/8" and the Units 
Format to 0 decimal places. 
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12.Click OK twice to finish. The angular dimension updates as 
shown in Figure 1–71.

Figure 1–71

13.Select and delete the sample text, elements, and dimensions. 
Note that the types did not delete from the project.

14.Save the template.

Task 3 - Load tags.

1. In the Annotate tab, expand the Tag panel title, and click

 (Loaded Tags and Symbols).

2. In the Loaded Tags and Symbols dialog box, set the Filter list 
to match your discipline(s).

3. Click Load Family... and load the following tags from the 
Revit Library’s Annotations folder’s subfolders into the 
discipline-specific project template.

Architecture:

MEP:

Folder Tag Name

Architectural Casework Tag.rfa, Furniture Tag.rfa, and Furniture 
System Tag.rfa

Folder Tag Name

Mechanical>Duct Duct Fitting Tag.rfa

Electrical Lighting Fixture Tag.rfa

Pipe Pipe Fitting Size Tag.rfa
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Structure:

4. The tags are automatically assigned to the correct Category, 
as shown for the Architectural tags in Figure 1–72. 

Figure 1–72

5. Click OK.

6. Save the template file.

Task 4 - Modify an elevation tag.

1. In the plan view, zoom to where you can see one of the 
existing building elevation view markers.

2. Select the pointed end of the marker.

3. In the Type Selector, verify that Elevation>Building 
Elevation is displayed. 

4. In Properties, click Edit Type.

5. In the Type Parameters, select the Value beside Elevation 

Tag and then click the  (Browse) button.

Folder Tag Name

Architectural Floor Tag.rfa, Wall Tag.rfa

Structural Structural Column Tag-45.rfa
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6. A second Type Properties dialog box displays for the 
Elevation Tag System Family. Duplicate this type and add 
with Name to the end.

7. In the Elevation Mark drop-down list, select Elevation Mark 
Body_Square: Detail Number and View Name, as shown 
in Figure 1–73.

Figure 1–73

8. Click OK. The Elevation Tag updates as shown in 
Figure 1–74.

Figure 1–74

9. Click OK and zoom to fit the view.

10.Save and close the template.
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1.3 Creating Title Blocks
Title blocks (as shown in Figure 1–75) are a Revit family and 
contain information about the company and consultants 
designing the project, project information (such as project name 
and number), and sheet-specific information (such as sheet 
numbers and drawn by). They are created by sketching detail 
lines and adding text, symbols, and regions, as well as image 
files for company logos. The variable information is stored in 
labels. Some of these parameters never change, some are 
project-specific, and some are sheet-specific.

Figure 1–75

• Once you have title blocks customized, you can add them to 
templates and set up views and sheets in the template.am
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How To: Create a Title Block

Title block  templates 
are located in the 
C:\ProgramData\
Autodesk\RVT 2022\
Family Templates\
English(Metric) or 
English-Imperial folder.

1. In the File tab, expand  (New) and click  (Title Block).

• Alternatively, on the Home screen, in the FAMILIES area, 

click  (New...), as shown in Figure 1–76. Navigate to 
the Revit Library’s Family Templates>English-Imperial> 
Titleblocks folder.

Figure 1–76

You can select from 
several preset sizes or 
create a custom size by 
selecting New Size.rft.

2. In the New Title Block - Select Template File dialog box, you 
should default to the Titleblocks folder location, as shown in 
Figure 1–77. Select a template file size from the list and click 
Open.

Figure 1–77

• A new family file opens and you will now be in Family Editor 
mode with a modified ribbon, as shown in part in Figure 1–78. 

Figure 1–78
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3. Add lines, filled regions, symbols, text, and labels (which are 
covered next).

• If you select a template with a standard size, a rectangle 
of that size displays in the view.

• If you select New Size, a rectangle with dimensions 
displays. Edit the dimensions to modify the size.

• You can use reference lines and dimensions to help place 
the elements in the title block family. They are not 
displayed when the title block is inserted.

4. You will save your new title block as a Revit family (.rfa) file 
type. 

Adding Labels Labels are not just text but elements that are assigned to specific 
parameters and can be added to title blocks or tags. They can 
change without modifying the rest of the elements. For example, 
you would use annotation text for the words Drawn By: and a 
label for the initials of the person who did the work (by default 
displaying DRW in Figure 1–79), because that varies from sheet 
to sheet.

Figure 1–79

• The title block template comes with one text type and one 
label type already defined. You can create additional types in 
Properties by duplicating types. The Text and Label 
parameters are similar, but you must create separate types 
for each of them.

• Labels use Rich Text Format so that they match text notes.

How To: Create a Label

1. Open a new or existing tag or title block family with an .rft 
extension.

2. In the Family Editor, in the Create tab>Text panel, click 

 (Label).
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3. In the Modify | Place Label tab>Alignment panel, specify the 
alignments: Left, Center, Right, Top, Center Middle, or 
Bottom, as shown in Figure 1–80.

Figure 1–80

4. Click in the view window to place the label, as shown in 
Figure 1–81. 

Figure 1–81

5. In the Edit Label dialog box (shown in Figure 1–82), select a 
label from the Category Parameters list and double-click or 

click  (Add parameter(s) to label). You can select more 
than one by holding <Ctrl> or <Shift>. 

Figure 1–82
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6. Enter the Sample Value and specify any other options, if 
needed.

• If you are using several parameters in one label, select 
Wrap between parameters only and Break (in column) 
options to separate them while still permitting a word 
wrap, as shown in Figure 1–83.

Figure 1–83

• Click  (Move parameter up) and  (Move 
parameter down) to reorder multiple parameters.

• If you select a numerical parameter, click  (Edit 
parameter’s units format) to change, if needed.

For more information on 
creating parameters and 
calculated parameters, 
see 2.6 Working with 
Project Parameters.

• Click  (Add calculated parameter to label) to use a 
formula based on other parameters.

Click  (Add Parameter) to create a new parameter for the 
project. This option requires the use of a Shared parameter. For 
more information, see 6.4 Working with Shared Parameters.

7. Click OK when you have finished editing the label.

• While placing the label, you can rotate or stretch it (as shown 
in Figure 1–84), or select a point for an additional label.

Figure 1–84

• You can also rotate or stretch a label once it has been placed 
in the title block.

Two labels without break

Two labels with break
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Adding
Revision

Schedules

A table of revisions included in a project and/or sheet is typically 
added to a company title block, as shown in Figure 1–85. In 
Revit, you can create a Revision Schedule that is then linked to 
the Sheet Issues/Revision Table in the project. 

Figure 1–85

How To: Add Revision Schedules to Title Blocks

1. Open a new or existing title block with an .rft extension.
2. In the Family Editor, in the View tab>Create panel, click

 (Revision Schedule). 
Within the tabs, there 
are tools that are grayed 
out that you will not be 
able to use.

3. The Revision Properties dialog box displays. Click on each of 
the tabs along the top and modify the settings as needed.

Fields Tab

In the Fields tab, you can select from a list of available fields and 
organize them in the order in which you want them to display in 
the schedule. Several are already selected for you, as shown in 
Figure 1–86. You can also sort the available fields by Parameter 
Type, Discipline, or Value Type.

You can also 
double-click on a field to 
move it from the 
Available fields area to 
the Scheduled fields 
area or double-click on 
a field to remove it from 
the Scheduled fields 
area.

• In the Available fields area, select one or more fields you 

want to add to the schedule and click  (Add parameter(s)). 
The field(s) are placed in the Scheduled fields (in order) area. 

• Click  (Remove parameter(s)) to move a field from the 
Scheduled fields area back to the Available fields area.

• Use  (Move parameter up) and  (Move parameter 
down) to change the order of the scheduled fields.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–56 © 2021, ASCENT - Center for Technical Knowledge®



Creating Custom Templates

S

Figure 1–86

Other Fields Tab Options

Select available 
fields from

Enables you to select additional category fields for the 
specified schedule. The available list of fields 
depends on the original category of the schedule. 
Typically, it includes room information.

 (Add 
Calculated 
parameter)

Enables you to create a field that uses a formula 
based on other fields.

  (Combine 
parameters)

Enables you to combine two or more parameters in 
one column.You can put any fields together even if 
they are used in another column. 
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Sorting/Grouping Tab

In the Sorting/Grouping tab, you can set how you want the 
information to be sorted, as shown in Figure 1–87. For example, 
you can sort by Revision Sequence and add another option in 
the Then by section(s). You can also check or uncheck the 
Itemize every instance option.

Figure 1–87

Sort by/Then 
by

Enables you to select the field(s) you want to sort by. You 
can select up to four levels of sorting.

Ascending/
Descending

Enables you to sort fields in Ascending or Descending 
order.

Itemize every 
instance

If selected, displays each instance of the element in the 
schedule. If not selected, displays only one instance of 
each type.am
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Formatting Tab

In the Formatting tab, you can control how the headers of each 
field display, as shown in Figure 1–88. The Multiple values 
indication options enable you to control how fields with multiple 
values display. 

Figure 1–88
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Appearance Tab

In the Appearance tab, you can select how you want to build the 
schedule: from the Top-down or Bottom-up, as shown in 
Figure 1–89. You can also set the Height to Variable or User 
defined.

Figure 1–89

• If the Height is set to Variable, it will add lines to the 
schedule as revisions are added to a project. If the Height 
is set to User defined, a predefined number of rows is 
created within the revision schedule on the title block.

• The Stripe Rows option allows you to highlight alternating 
rows within the schedule to help differentiate the rows in 
large schedules. You can select the option for the 
highlight to start on the first or second row and select the 
color option. This will appear on the sheet and in print.

4. Click OK. The schedule view displays, as shown in 
Figure 1–90.

Click to 
choose a color
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Figure 1–90

5. Click on the sheet view tab (it has no name) to make it the 
active view, as shown in Figure 1–91.

Figure 1–91

6. In the Project Browser, expand Views (all)>Schedules and 
drag and drop the schedule onto the sheet.

• If the height is set to User defined, an additional control 
displays at the bottom of the schedule. Use it to set the height 
of the schedule, as shown in Figure 1–92.

Figure 1–92

• In the Options Bar, you can change the Rotation on the Sheet 
to None, 90° Clockwise, or 90° Counterclockwise.

7. Save the title block.

Sheet view tab

User-defined control
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Adding Sheets
to Project
Templates

You can create sheets that are typically used in projects in the 
template and even place views on them as placeholders, as 
shown in Figure 1–93. Note that the view is empty in the 
template, but as you draw elements in the project they 
automatically display in the view and on the sheet.

Figure 1–93

• You can create many sheets that are typically used in a 
project or you can create a Sheet List and populate it with 
sheet names that can be used as placeholder sheets.

• You can also copy sheets from a resource project.

Presetting a Starting View

For more information on 
creating Sheet Lists, 
see A.8 Additional 
Schedule Types.

When you create a project template or project, it can help to 
specify a starting view. This can be any of the standard views, 
such as plan, elevation, 3D view, or one that is specifically 
created. This is often a Drafting View (as shown in Figure 1–94), 
a Legend View with information about the project (such as a 
project bulletin board), or the cover sheet for the project. You can 
add text as placeholders for project information you will add 
when the project is started.
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Figure 1–94

How To: Set a Starting View

1. Within your company template, set up the view or sheet that 
you want to use as the starting view.

2. In the Manage tab>Manage Project panel, click  (Starting 
View).

3. In the Starting View dialog box, select the view or sheet that 
you want to use, as shown in Figure 1–95.

By default, the starting 
view is the last view that 
was open before closing 
or <Last Viewed>.

Figure 1–95

4. Click OK and save your template.
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Practice 1e Create Title Blocks: All 
Disciplines

In this practice, you will create a new title block by adding lines, 
text, labels, logo, and a revision schedule similar to Figure 1–96. 
You will then load it into a project template file and create several 
standard sheets.

Figure 1–96

Practice Objectives

• Draw a custom title block including detail lines, text, labels, and a 
revision table.

• Set up sheets in the template using the new title block.
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Task 1 - Create a title block.

1. In the File tab, expand  (New) and click 

 (Title Block). Alternatively, on the Home screen, in the 

FAMILIES area, click  (New...). 

2. In the New Title Block - Select Template File dialog box, 
select D - 36 x24.rft and click Open.

3. Save the title block by going to the File menu>Save as>
Family and save the title block as Company TBLK.rfa in the 
practice files Reference folder.

4. Create the title block linework by going to the Create tab> 

Detail panel and clicking  (Line). Create lines on the 
inside of the existing rectangle 1/4" away from the top, 
bottom, and right sides. Draw a line 1" away on the left 
margin. Trim the lines in all four corners.

5. Draw lines in the lower right corner of the title block, as 
shown in Figure 1–97.

Figure 1–97

6. In the Create tab>Detail panel, click  (Symbol). When 
prompted to load a generic annotation family, click Yes.

7. In the Load Family dialog box, navigate to the Revit 2022 BIM 
Management Practice Files>Reference folder, select 
Company Logo.rfa, and click Open. Add the symbol to the 
lower left corner of the new title block. It is designed to fit 
within the square.
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8. In the Create tab>Text panel, click  (Text). In Properties, 

click  (Edit Type) and create the following Text type:

9. In the Create tab>Text panel, click  (Label). 

10. In Properties, click  (Edit Type) and create the following 
Label types:

11. Using the following steps, add text and labels to the title 
block, as shown in Figure 1–98.

Figure 1–98

You can use Reference 
Lines to place the text 
and labels exactly.

• Text:

• Use  (Text) with the text type Arial 1/16" to add text in 
the lower right spaces for the Date, Project Number, 
Drawn By, and Sheet Number.

• Labels:

Type Name Font Size Bold Background

Arial 1/16" Arial 1/16" No Transparent

Type Name Font Size Bold Background

Arial 1/8" Arial 1/8" No Transparent

Arial 1/4" Arial 1/4" No Transparent
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• Use  (Label) with the label type Arial 1/4" and

 (Align Center) justification to add the Sheet Name, 
Project Name, and Sheet Number. Move and stretch the 
labels to fit in the title block.

• Using the label type Arial 1/8" and  (Align Center) 
justification, add the Project Address below the Project 
Name.

• Using the label type Arial 1/8" and  (Align Right) 
justification, add the Project Issue Date, Project Number, 
and Drawn By.

Task 2 - Add a revision schedule to the title block.

1. In the title block Family Editor, in the View tab>Create panel, 

click  (Revision Schedule).

2. In the Revision Properties dialog box>Fields tab, set up the 
fields as shown in Figure 1–99. 

Figure 1–99

3. Accept the defaults for the Sorting/Grouping and Formatting 
tabs. 

4. Select the Appearance tab and change the Height to User 
defined.

5. Click OK.
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6. Return to the sheet view.

7. In the Project Browser, expand Views (all)>Schedules to 
display the available schedules, as shown in Figure 1–100.

Figure 1–100

8. Drag and drop the revision schedule onto the sheet.

9. Move it above the sheet name and resize it to display several 
lines, as shown in Figure 1–101. Align it to the edge of the 
title block.

Figure 1–101

10.Save and close the title block.

Task 3 - Set up sheets in a project template using the new 
title block.

1. Open the template found in the practice files folder that 
relates to your discipline:

• Architectural>Template Files> 
Midrise-Template-Architectural-2.rte 

• MEP>Template Files>Midrise-Template-MEP-2.rte 

• Structural>Template Files> 
Midrise-Template-Structural-2.rte 

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–68 © 2021, ASCENT - Center for Technical Knowledge®



Creating Custom Templates

S

2. In the View tab>Sheet Composition panel, click  (Sheet).

3. In the New Sheet dialog box, click Load.... 

4. In the Load Family dialog box, navigate to the practice files 
folder, select Company TBLK.rfa (that you just created), and 
click Open. 

• If you did not complete the previous tasks, open Sample 
TBLK.rfa from the Revit 2022 BIM Management Practice 
Files>Reference folder and click Open. In the New Sheet 
dialog box, select the title block that you just loaded and 
click OK.

5. In the Project Browser, select the new sheet, right-click, and 
select Rename and rename it to CS000 – Cover Sheet.

6. Using the Title Large text type, add text for the project name 
and address, as shown in Figure 1–102.

Figure 1–102

7. In the Manage tab>Manage Project panel, click  (Starting 
View).
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8. In the Starting View dialog box, select Sheet: CS000 - Cover 
Sheet as shown in Figure 1–103. 

Figure 1–103

9. Create another sheet with the new title block and name it 
according to your discipline below. Make sure to use the grips 
to stretch the text box.

• A201 – First Floor Plan

• M201 - First Floor Plan Mechanical

• E201 - First Floor Plan Electrical

• P201 - First Floor Plan Plumbing

• S201 - First Floor Plan Structural

10.Open this sheet view. Drag the associated Level 1 floor plan 
view onto the sheet, as shown in Figure 1–104.

No elements are on the 
view, but it acts as a 
placeholder on the 
sheet. Elements display 
as they are drawn.

Figure 1–104

11. Save and close the template file.
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1.4 Setting Up View Filters
Rule-based view filters used in conjunction with Visibility/Graphic 
Overrides are a powerful tool that can be saved in template files. 
They can be used to test conditions in a project or modify the 
information that display in a view. For example, a fire evacuation 
plan might have walls with different fire ratings that display with 
thicker lineweights, as shown in Figure 1–105. MEP projects 
frequently use view filters to control which systems display in a 
view.

Figure 1–105

• There are two types of filters: rule-based filters, used in 
Visibility/Graphic Overrides, and selection-based filters, 
used by selection sets.

• Selection-based filters are not something you would set 
up in a template, but are used when you want to modify 
multiple elements at the same time in a view. You cannot 
add categories or apply rules to a selection-based filter 
like you can with a rule-based filter, but you can use 
selection-based filters to isolate, hide, or apply graphic 
settings to the set.
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How To: Create a Rule-Based Filter

1. In the View tab>Graphics panel, click  (Filters). The Filters 
dialog box opens, as shown in Figure 1–106.

Figure 1–106

2. In the Filters area, select the Rule-based Filters node or an 

existing filter and click  (New) or  (Duplicate), as shown 
in Figure 1–107. Name the new filter and click OK.

3. In the Categories area, filter the list by discipline and then 
select the categories to include in the filter, as shown in 
Figure 1–107. Use Check All and Check None to help select 
the categories.

Figure 1–107

Create new, rename,
or duplicate filter
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• Although you can select multiple categories, you can only 
filter by the parameters the categories have in common.

4. In the Filter Rules area, select the Condition (type of filter) 
you want to create (AND or OR) as shown in Figure 1–108.

Figure 1–108

5. For each filter, specify the Categories, Parameter, Operator, 
and Value, as shown in Figure 1–109. 

Figure 1–109

• Click Add Rule to add a rule to the existing Condition.

• Click Add Set to add a nested Condition and filters.

6. Click Apply to save the changes and remain in the dialog 
box, or click OK to finish.

Condition

Parameter

Operator

Value

Categories
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• If you create more than one filter rule, they are applied in 
order.

• OR rules can reference multiple categories and all 
parameters from the selected categories can be used in the 
rule, not just those that are common to the categories.

• Building nested filters is complex. It is recommended to start 
with an AND condition and then add OR conditions to further 
identify the elements.

• Test your filters thoroughly before applying them in a 
template.

How To: Apply Visibility/Graphic Overrides Filters

1. Type VG or VV or in the View tab>Graphics panel, click

 (Visibility/Graphics) to open the Visibility/Graphic 
Overrides dialog box for the view that you are in. Select the 
Filters tab, as shown in Figure 1–110.

Figure 1–110

2. Click Add to add a filter to the list.
3. In the Add Filters dialog box, select the filter(s) you want to 

add, as shown in Figure 1–111. Then, click OK.

Figure 1–111

Shows which view you are 
specifying overrides for
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• If the filter you want is not defined, click Edit/New... to 
open the Filters dialog box, where you can define a new 
filter or edit an existing one.

• Filters added are applied to the current view only.

4. In the Visibility/Graphic Overrides dialog box, assign the 
overrides you want for the filter, as shown in Figure 1–112.

• Visibility: To hide the filtered elements in the view, 
uncheck this box.

• Enable Filter: To disable the filter effects in the view, 
uncheck this box.

Figure 1–112
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Practice 1f Set Up View Filters: Architecture

In this practice, you will create rule-based filters for wall fire 
ratings. You will duplicate a view and add the filters with 
overrides set up in Visibility/Graphic Overrides. The original view 
and modified view are shown in Figure 1–113. 

Figure 1–113

Note: This practice uses view filters in an existing project so you 
can add a filter and then see the impact of what it does. They 
should be set up originally in a template.

Task 1 - Create filters.

1. In the practice files Architectural folder, open Office-Fire 
Ratings.rvt.

2. In the View tab>Graphics panel, click  (Filters).

3. In the Filters dialog box, click  (New), name the new filter 
Fire Rating - 1 Hour, and click OK.

4. In the Categories area, set the Filter list to Architecture. 
Select Walls.

Practice Objectives

• Create rule-based filters.

• Add view filters to a view and set up overrides.

Original view Duplicated view with filters and overrides

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–76 © 2021, ASCENT - Center for Technical Knowledge®



Creating Custom Templates

S

5. In the Filter Rules area, set the AND condition as follows, as 
shown in Figure 1–114: 

• Parameter: Fire Rating 

• Operator: equals 

• Value: 1 Hour

Figure 1–114

6. Click Apply and remain in the Filters dialog box.

7. Select the new Fire Rating - 1 Hour filter and click

 (Duplicate).

8. Select the duplicated filter and click  (Rename) or 
right-click on the duplicated filter and click Rename. In the 
Rename dialog box, type Fire Rating - 2 Hours and 
click OK.

9. Modify the Filter Rule to Fire Rating - equals - 2 Hours, as 
shown in Figure 1–115.

Figure 1–115

• Note: You will need to type in 2 Hours because this fire 
rating does not yet display in the project. 

10.Click OK to close the Filters dialog box.

Task 2 - Test the view filters.

1. Duplicate the Floor Plans>Level 1 view and name it Level 1 - 
Fire Ratings.

2. Open only the Level 1 and Level 1 - Fire Ratings views and 
type WT to tile them side by side. 

3. Zoom in on the core of the building in both views. 
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4. In the Level 1 - Fire Ratings view, open the Visibility/Graphic 
Overrides dialog box. 

5. In the Filters tab, click Add.

6. In the Add Filters dialog box, select the Fire Rating filters, as 
shown in Figure 1–116, and click OK.

Figure 1–116

7. For the Fire Rating - 1 Hour filter, in the Cut>Patterns 
column, select Override.

8. In the Fill Pattern Graphics dialog box, change the 
Foreground Pattern to Solid Fill and Color to an orange, as 
shown in Figure 1–117. Click OK.

Figure 1–117
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9. Repeat the process for the Fire Rating - 2 Hours view filter 
using a different color, as shown in Figure 1–118.

Figure 1–118

10.Click OK. The filter overrides display in the Fire Ratings view 
but not in the original view.

11. Select one of the exterior walls (Basic Wall (WT-04)) and in 
Properties, click Edit Type.

This is an example. 
Typically, exterior walls 
are not set up with this 
type of fire rating unless 
they are part of a fire 
wall.

12.Scroll down to the Identity Data section and beside Fire 
Rating, type in 2 Hours, as shown in Figure 1–119. Then, 
click OK.

Figure 1–119

• The value of the Fire Rating parameter must match the 
name of the filter exactly. Edit the filter if the walls do not 
change color.

13.Save and close the project. 
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Practice 1g Set Up View Filters: MEP

In this practice, you will create rule-based filters. You will 
duplicate a view and add the filters with overrides set up in 
Visibility/Graphic Overrides. The original view and modified view 
are shown in Figure 1–120. 

Figure 1–120

Note: This practice uses view filters in an existing project so you 
can add a filter and then see the impact of what it does. They 
should be set up originally in a project template.

Task 1 - Create three new filters.

1. In the practice files MEP folder, open Office-Velocity.rvt.

2. In the View tab>Graphics panel, click  (Filters).

3. In the Filters dialog box, click  (New), name the new filter 
Mechanical - Low Velocity, and click OK.

4. In the Categories area, set the Filter list to Mechanical. 
Select Ducts and Flex Ducts.

Practice Objectives

• Create rule-based filters.

• Add view filters to a view and set up overrides.

Original view Duplicated view with filters and overrides
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5. In the Filter Rules area, set the AND condition as follows, as 
shown in Figure 1–121: 

• Parameter: Velocity 

• Operator: is less than or equal to 

• Value: 900.00 FPM

Figure 1–121

6. Click Apply and remain in the Filters dialog box.

7. In the Filters section, select the new Mechanical - Low 

Velocity filter and click  (Duplicate).

8. Select the duplicated filter and click  (Rename) or 
right-click on the duplicated filter and click Rename. In the 
Rename dialog box, type Mechanical - Medium Velocity 
and click OK.

• You will see that there is already a filter rule that was 
copied when duplicating the Low Velocity filter.

9. Change the existing Velocity rule’s Operator to is greater 
than or equal to, as shown in Figure 1–122.

10.Click Add Rule to create a second rule and set it up as 
shown in Figure 1–122 using Velocity -  is less than or 
equal to - 1900.00 FPM.

Figure 1–122

11. Click Apply.

New Rule

Change Operator 
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12.Create an additional filter named Mechanical - High 
Velocity set up as shown in Figure 1–123. Use is greater 
than as the condition.

Figure 1–123

13.Click OK to close the Filters dialog box.

Task 2 - Test the view filters.

1. Duplicate with Details the Mechanical>Floor Plans>1 - Mech 
view and name it 1 - Mech - Velocity.

2. Open only the 1 - Mech and 1 - Mech - Velocity views and 
type WT to tile them side by side. 

3. Zoom in on the central core of the building in both views. Both 
views display the duct colors set up in the Duct System 
properties for Supply, Return, and Exhaust.

4. In the 1 - Mech - Velocity view, open the Visibility/Graphic 
Overrides dialog box and open the Filters tab. Three existing 
filters are available for the Mechanical duct systems.

5. In the Filters tab, click Add.

6. In the Add Filters dialog box, select the three new filters as 
shown in Figure 1–124. Click OK.

Figure 1–124
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7. Move the velocity-based filters to the top of the list using the 
Up and Down buttons.

8. For the Mechanical - Low Velocity filter, in the 
Projection/Surface>Patterns column, select Override.

9. In the Fill Pattern Graphics dialog box, change the Pattern to 
Solid Fill and the Color to an orange, as shown in 
Figure 1–125. Click OK.

Figure 1–125

10.For the other velocity filters, create a similar overrides using 
other colors. 

11. For the Supply and Return filters, set the Projection Lines 
override Color to Black. Then, clear the Visibility check on 
the Exhaust filter, as shown in Figure 1–126.

Figure 1–126

12.Click OK. The filter overrides display in the velocity view, but 
not in the original view.

13.Save and close the project.
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Practice 1h Set Up View Filters: Structure

In this practice, you will create rule-based filters for element 
materials. You will duplicate a view and apply the filters with 
overrides set up in Visibility/Graphic Overrides. The modified 
view is shown in Figure 1–127. 

Figure 1–127

Note: This practice uses view filters in an existing project so you 
add a filter and then see the impact of what it does. They should 
be set up originally in a template.

Task 1 - Create filters.

1. In the practice files Structural folder, open 
Office-Materials.rvt.

2. In the View tab>Graphics panel, click  (Filters).

3. In the Filters dialog box, click  (New), name the new filter 
Concrete and click OK.

Practice Objectives

• Create rule-based filters.

• Add view filters to a view and set up overrides.
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4. In the Categories area, set the Filter list to Structure. Select 
Structural Columns, Structural Foundations, Structural 
Framing and Walls.

An alternate way to 
make these filters is to 
do one for each 
material.

5. In the Filter Rules area, set the OR condition as follows, as 
shown in Figure 1–128: 

• Parameter: Structural Material 

• Operator: equals

• Value: Concrete - Cast-in-Place Concrete

Figure 1–128

6. Click Add Rule and add another rule, as follows: 

• Parameter: Structural Material 

• Operator: equals

• Value: Masonry - Concrete Masonry Units

7. Click Apply and remain in the Filters dialog box.

8. Select the new Concrete filter and click  (Duplicate).

9. Select the duplicated filter and click  (Rename) or 
right-click on the duplicated filter and click Rename. In the 
Rename dialog box, type Steel and click OK.

10.Modify the Filter Rules to Structural Material - equals - 
Metal - Steel - ASTM A500 - Grade B - Rectangular and 
Square and Metal - Steel - ASTM A992, as shown in 
Figure 1–129.

Figure 1–129

11. Click OK to close the Filters dialog box.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2021, ASCENT - Center for Technical Knowledge® 1–85



Autodesk Revit 2022 BIM Management: Template and Family Creation 

S

Task 2 - Test the view filters.

1. In the Project Browser, duplicate 3D Views>{3D} view and 
rename it to Structural Materials - 3D.

2. Open the Visibility/Graphic Overrides dialog box. 

3. In the Filters tab, click Add.

4. In the Add Filters dialog box, select both of the filters, as 
shown in Figure 1–130, and click OK.

Figure 1–130

5. For the Concrete Filter in the Projection/Surface>Patterns 
column, select Override.

6. In the Fill Pattern Graphics dialog box, change the 
Foreground Pattern to Solid Fill and Color to an orange, as 
shown in Figure 1–131. Click OK.

Figure 1–131
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7. Repeat the process for the Steel using a different color, as 
shown in Figure 1–132.

Figure 1–132

8. Click OK. The Filter overrides display in the view.

9. Save and close the project.
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1.5 Adding View Templates
View templates applied to views, consisting of specific view 
properties and visibility options, ensure that company standards 
are applied. For example, you can create a view template that 
displays spaces, but hides the MEP systems in a view (as shown 
in Figure 1–133), while another view template displays duct 
systems but not plumbing fixtures (as shown in Figure 1–134).

Figure 1–133

Figure 1–134

• View templates can be applied when creating plan views or to 
new view types. This applies view settings and graphic 
properties more quickly.am
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• A view template can be applied to a view so that users are 
allowed to modify the view settings; however, you can also 
make the view dependent upon the view template so that 
changes to a single view cannot be made by users, as shown 
with the detail level options in Figure 1–135, which are 
grayed out so users cannot change them. Locking the view 
prevents users from modifying the settings and aids in 
establishing a company graphic standard to views.

Figure 1–135

How To: Create a View Template from an Existing 
View

1. Set up a view the way you want it with Scale, Detail Level, 
Visibility Graphic Overrides, and other View Settings. For 
example, you can create a view template for furniture plans 
that displays furniture with black lines, walls, doors, and 
windows as half-tone, and grid lines hidden, as shown in 
Figure 1–136. 

Figure 1–136

2. In the Project Browser, right-click on the view and select 
Create View Template from View or, on the View tab> 

Graphics panel, expand  (View Template), and click 

(Create Template from Current View).
3. In the New View Template dialog box, type a name for the 

view template.
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4. Click OK.
5. In the View Template dialog box, make adjustments as 

needed and then click OK.

How To: Create a View Template

1. In the View tab>Graphics panel, expand  (View Template) 

and then click  (Manage View Templates). 
2. In the View Template dialog box, under the Names list, select 

a view similar to the one you want to create and click  
(Duplicate).

3. In the New View Template dialog box, type a new name for 
the view template and click OK.

4. Select the new view template (as shown in Figure 1–137) 
and modify the parameter values in the View properties area.

• You can adjust the size of the View Template dialog box 
by clicking and dragging the lower right corner.

Figure 1–137

5. Click OK to finish.

Click and drag to
adjust the size of 
the dialog box
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Note that the different 
view types have 
different view 
parameters. For 
example, 3D views have 
options for Rendering 
and Perspectives that 
plan views do not have.

• To limit the number of view templates that display, filter the 
list by selecting an option in the Discipline filter and View type 
filter drop-down lists, as shown in Figure 1–138.

Figure 1–138

• If you do not want a specific View properties Parameter to be 
controlled by the view template that is applied to views, clear 
the check mark in the Include column for the parameters you 
do not want to include. You can also create overrides to the 
view template by changing parameter values.

How To: Create a New View and Apply a View 
Template

1. In the View tab>Create panel, click on  (Plan Views), then 

click  (Floor Plan) or  (Reflected Ceiling) or 

(Structural Plan).
2. In the New Floor Plan dialog box, uncheck Do not duplicate 

existing views and select a view from the list, using the 
<Ctrl> or <Shift> keys to select more than one.

3. Click the Edit Type... button.
4. In the Type Properties dialog box, click on the button next to 

the View Template applied to new view parameter, as shown 
in Figure 1–139.

Figure 1–139

Click this 
button
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5. This opens up the Assign View Template dialog box, where 
you can select the view template you want applied. Select a 
view template and click OK.

6. In the View Properties dialog box, if you check the box next to 
New Views are dependent on template, the settings in the 
view template are used and users cannot override the 
settings. If it is unchecked, users can override the settings, as 
shown in Figure 1–140.

Figure 1–140

How To: Create a New View Type with a View 
Template

1. Open a view of the type you want to create. For example, if 
you want to create a new plan view type, select an existing 
Floor Plan view, or if you want to create a new elevation view 
type, select an existing Elevation view.

2. In Properties, click Edit Type.
3. Duplicate the existing type and give it a new name.
4. Specify the Callout Tag and Reference Label, set the view 

template for the View Template applied to new view option, 
and select New views dependent on template, as shown in 
Figure 1–141. This locks the view to be dependent on the 
view template settings that are applied.

Settings unlocked

Settings locked
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Figure 1–141

5. Click OK.

• When you create a new view, you can select the view type 
from the drop-down list, as shown for a new floor plan in 
Figure 1–142. The view is also placed in its own group in the 
Project Browser, as shown in Figure 1–143.

How To: Set the Default View Template for a View

1. In the Project Browser, select one or more views. 
2. In Properties, in the Identity Data group, click the button next 

to View Template, as shown in Figure 1–144. The name on 
the button varies according to the template that has already 
been assigned.

Figure 1–144

Figure 1–142 Figure 1–143

New Floor Plans 
Group
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3. In the Assign View Template dialog box, select the 
appropriate template and click OK. This locks the view to be 
dependent on the view template settings that are applied.

• You can apply view templates to any view as many times as 
necessary.

• If you want to start a new view template based on an existing 
view, in the Assign View Template dialog box, select Show 
Views. The Names list expands to include all of the related 
views in the project.

Hint: Temporary View Properties

As you are working, it can be helpful to temporarily override 
the view. You can do this by selecting a view template from 
the View Control Bar, as shown in Figure 1–145.

Figure 1–145

1. In the View Control Panel, expand (Temporary View 
Properties) and select Enable Temporary View 
Properties.

2. Expand (Temporary View Properties) again and select 
Temporarily Apply Template Properties. Alternatively, if 
you have already used the process, you can select from a 
list of view templates, as shown in Figure 1–145.

3. In the dialog box, select the view template you want to 
apply and click OK.

4. When you are finished, expand (Temporary View 
Properties) and select Restore View Properties.

• Some companies create a “working view” template to be 
used as a temporary override, rather than having separate 
working views. 
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Practice 1i Add View Templates: 
Architecture

In this practice, you will create view templates from an existing 
view and modify the view template using Manage View 
Templates. You will then duplicate views and apply the view 
templates to other views, as shown in Figure 1–146.

Figure 1–146

Note: This practice uses view templates in an existing project so 
you can create a view template and then see the impact of what 
it does. They should be set up originally in a project template.

Task 1 - Create a view template from an existing view.

1. In the practice files Architectural folder, open 
Office-Rooms.rvt.

2. In the Level 1 - Fire Ratings view hide the grids, elevations, 
sections, furniture, plumbing fixtures, and similar elements. 
(Hint: Select one element of each category and type VH).

3. In the Project Browser, in the Floor Plans group, right-click on 
the Level 1 - Fire Ratings view and select Create View 
Template From View. Name it Fire Ratings.

Practice Objectives

• Create a view template from an existing view.

• Create a view template from within Manage View Templates.

• Duplicate views and apply the view templates.
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4. In the View Templates dialog box, next to V/G Override 
Filters, click the Edit... button.

5. In the Visibility/Graphic Overrides dialog box, Filters tab, 
review the filters and overrides and click OK.

6. In the View properties group, in the Include column, clear the 
check marks from all of the options except Detail Level, V/G 
Overrides Model, V/G Overrides Annotation, V/G Overrides 
Filters, and Model Display, as shown in Figure 1–147. Click 
OK.

Figure 1–147

Task 2 - Apply view templates to views.

1. In the Project Browser, duplicate the Level 2 view and 
rename it as Level 2 - Fire Ratings.

• Note what the view looks like, e.g., note grids, sections, 
elevation marks, etc.

2. In Properties, in the Identity Data group, select the button 
beside View Template.

3. In the Assign View Template dialog box, select Fire Ratings 
and click OK.

4. Review the View Control Bar options. Note that you can’t 
make any changes to the view controls of this view, as shown 
in Figure 1–148.
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Figure 1–148

5. Switch to the Level 1 - Fire Ratings view. Note that you can 
still make changes to the View Controls of this view because 
a view template has not been applied to the view. 

6. Return to the Level 2 - Fire Ratings view. Turn off the floor in 
this view by going to the View tab>Graphics panel, expanding 

 (View Template) and clicking  (Manage View 
Templates). In the View Templates dialog box, select Fire 
Ratings. 

7. In the View properties group, next to V/G Overrides Model, 
click the Edit... button. 

8. In the Visibility/Graphic Overrides dialog box, set the Filter 
List to Architecture and toggle off Floors.

9. Click OK to close each of the dialog boxes. The floor in the 
Level 2 - Fire Ratings view automatically toggles off.

10.Save the project.

Task 3 - Create a view template through Manage View 
Templates.

1. In the View tab>Graphics panel, expand  (View Template) 

and click  (Manage View Templates). 

2. In the View Template dialog box, set the View type filter to 
Floor, Structural, Area Plans.

3. In the Names list, select Architectural Plan and click 

 (Duplicate).

4. Name the new view Room Plan.

5. Next to V/G Overrides Model, click the Edit... button.
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6. Verify the Filter List is set to Architecture.

7. Select the All button and click on one check mark to clear all 
the check marks from all of the model elements.

8. Select the None button to deselect everything.

9. Toggle on Doors, Rooms, Stairs, Walls, and Windows.

10.Select and expand Rooms and select Interior Fill, as shown 
in Figure 1–149.

Figure 1–149

11. Click OK.

12. In the View Templates dialog box, clear the check marks in 
the Include column beside View Scale and View Range. Click 
OK.

13.Use the Duplicate with Detailing command on the 
Level 1 and Level 2 views and rename them as Level 1 - 
Rooms and Level 2 - Rooms.

14. In the Project Browser, select both of the new room views.

15. In Properties, in the Identity Data group, select the button 
beside View Template and apply the Room Plan view 
template to the views.

16.Open Level 1, Level 1 - Fire Ratings, and Level 1 - Rooms 
views and compare them.

17.Save and close the project.
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Practice 1j Add View Templates: MEP

In this practice, you will create view templates from an existing 
view and modify the view template using Manage View 
Templates. You will then duplicate views and apply the view 
templates to other views, as shown in Figure 1–150.

Figure 1–150

Note: This practice uses view templates in an existing project so 
you can create a view template and then see the impact of what 
it does. They should be set up originally in a project template.

Task 1 - Create a view template from an existing view and 
apply view template to views.

1. In the practice files MEP folder, open Office-Spaces.rvt.

2. In the Project Browser, in the Mechanical>Floor Plans area, 
right-click on the 1 - Mech - Velocity view and select Create 
View Template From View.

3. Name the new view template Velocity Duct Plan and 
click OK.

4. In the View Templates dialog box, next to V/G Override 
Filters, click the Edit... button. The Visibility/Graphic 
Overrides dialog box opens with the Filter tab selected. You 
can see that the filters and overrides set up in the view are 
included in the view template.

Practice Objectives

• Create a view template from an existing view.

• Create a view template from within Manage View Templates.

• Duplicate views and apply the view templates.
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5. Click OK twice to close the dialog boxes.

6. Duplicate the 2 - Mech view and rename it as 2 - Mech - 
Velocity.

7. In Properties, in the Identity Data group, select the button 
beside View Template.

8. In the Assign View Template dialog box, select Velocity Duct 
Plan and click OK.

9. Review the View Control Bar options. Note that you cannot 
make any changes to the view controls of this view, as shown 
in Figure 1–151.

Figure 1–151

10.Switch to the 1 - Mech - Velocity view. Note that you can still 
make changes to the View Controls of this view. 

Task 2 - Create a view template through Manage View 
Templates.

1. In the View tab>Graphics panel, expand  (View Template) 

and click  (Manage View Templates). 

2. In the View Templates dialog box, set the View type filter to 
Floor, Structural, Area Plans.

3. In the Names list, select Architectural Plan and click 

 (Duplicate).
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4. Name the new view Space Plan.

5. Next to V/G Overrides Model, click Edit....

6. In the Visibility/Graphic Overrides dialog box, set the Filter 
List to Mechanical, Electrical, and Piping.

7. Select the All button and click on one check mark to clear all 
the check marks from all of the model elements.

8. Select None to deselect the selection.

9. Scroll down, select and expand Spaces, and select Interior, 
as shown in Figure 1–152.

Figure 1–152

10.Click OK.

11. In the View Templates dialog box, clear the check marks in 
the Include column beside View Scale and View Range. 

12.Change the Discipline to Coordination and click OK.

13.Save the project.
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Task 3 - Apply the view template to views.

1. Use Duplicate with Detailing to duplicate the 1 - Mech and 
2 - Mech views and rename them as 1 - Spaces and 
2 - Spaces.

• You need to include the space tags in the views so you 
must duplicate with detailing.

2. In the Project Browser, select both spaces views.

3. In Properties, in the Identity Data group, select the button 
beside View Template. and apply the Space Plan view 
template to the views.

4. In the Project Browser, the views are automatically moved to 
the Coordination node and the spaces display in the view 
but none of the MEP elements display, as shown in 
Figure 1–153.

Figure 1–153

• If the spaces are not showing as expected, reload the 
linked Office-Link.rvt file.

5. Save and close the project.am
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Practice 1k Add View Templates: Structure

In this practice, you will create a view template from an existing 
view and modify the view template using Manage View 
Templates. You will then duplicate views and apply the view 
template to other views, as shown in Figure 1–154.

Figure 1–154

Note: This practice uses view templates in an existing project so 
you can create a view template and then see the impact of what 
it does. They should be set up originally in a project template.

Task 1 - Create a view template from an existing view.

1. In the practice files Structural folder, open Office-View 
Template.rvt.

2. In the Project Browser, in the 3D Views area, right-click on 
the Structural Materials - 3D view and select Create View 
Template From View.

3. Name the new view template Structural Materials and 
click OK.

4. Next to V/G Override Filters, click the Edit... button. The 
Visibility/Graphic Overrides dialog box opens with the Filter 
tab selected. You can see that the filters and overrides set up 
in the view are included in the view template.

Practice Objectives

• Create a view template from an existing view.

• Create a view template from within Manage View Templates.

• Duplicate views and apply the view templates.
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5. Click OK.

6. In the Include column, clear the check marks from everything 
except the Detail Level, V/G Overrides Model, and V/G 
Overrides Filters categories.

7. Click OK.

8. Save the project.

Task 2 - Apply the view template to views.

1. Duplicate the Structural Plans>Level 1 view and rename it 
Level 1 - Materials.

2. Right-click on the new view and select Apply Template 
Properties.

3. In the Apply View Template dialog box, set the View type filter 
to <all> and select Structural Materials, as shown in 
Figure 1–155. 

Figure 1–155

4. Click OK. 
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5. The plan displays with most of the design in the concrete filter 
color. Compare the new floor plan view with the existing 
Level 1 view, as shown in Figure 1–156.

Figure 1–156

6. Duplicate the Level 2 view and rename it as Level 2 - 
Materials.

7. In Properties, in the Identity Data group, select the button 
beside View Template.

8. In the Assign View Template dialog box, set the View type 
filter to <all> and select Structural Materials. Click OK.

9. Review the View Control Bar options. Note that you cannot 
make any changes to the Detail Levels of this view, as shown 
in Figure 1–157, because they are all grayed out and 
controlled by the view template.

Figure 1–157

10.Switch to the Level 1 - Materials view. Note that you can still 
make changes to the Detail Levels of this view. 

Task 3 - Modify a view template through Manage View 
Templates.

1. Switch to the Level 2 - Materials view.

2. In the View tab>Graphics panel, expand  (View Template) 

and click  (Manage View Templates). 
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3. In the Names list, select Structural Materials.

4. Next to V/G Overrides Model, click Edit.... In the Filter list, 
only turn on Structure.

5. In the Visibility/Graphic Overrides dialog box, toggle off 
Floors.

6. Click OK twice to close the dialog boxes. The Steel color now 
displays because the floor has been removed, but the 
masonry concrete walls do not display as expected, as 
shown in Figure 1–158.

Figure 1–158

7. Open the Manage View Templates dialog box again and 
select Structural Materials.

8. Edit the V/G Overrides Filters. 

9. In the Visibility/ Graphic Overrides dialog box, add overrides 
to the Cut Patterns to match the Projection/Surface Pattern 
overrides, as shown in Figure 1–159.

Figure 1–159

No color
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10.Click OK to close the dialog boxes and the information is 
updated in the view as shown in Figure 1–160.

Figure 1–160

11. Save and close the project.

Color added
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Chapter Review Questions

1. Which of the following items are NOT set in a template file?

a. Units

b. Annotation types

c. Title blocks

d. Keyboard shortcuts

2. What is a label?

a. A text type used in title blocks.

b. A dimension with text instead of numbers.

c. A type of text with variable information.

3. When you want to create new text types, such as those 
shown in Figure 1–161, you need to duplicate an existing 
one.

Figure 1–161

a. True

b. False

4. Which of the following enables you to assign a view template 
consistently to a view so that no changes can be made to the 
view parameters?

a. In the view’s Properties, select a view template.

b. In the Project Browser, right-click on the view and select 
Apply Template Properties.

c. In the view’s Properties, click Edit Type and assign a view 
template.

5. Which of the following parameters are included in a view 
template? (Select all that apply.)

a. View Scale

b. V/G Overrides Model

c. Project Units

d. Detail Level 
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Command Summary

Button Command Location
Templates

Callout Tags • Ribbon: Manage tab>Settings panel>
expand Additional Settings

Elevation Tags • Ribbon: Manage tab>Settings panel>
expand Additional Settings

Floor Plan • Ribbon: View tab>Create panel> 
expand Plan Views

Loaded Tags 
and Symbols

• Ribbon: Annotate tab>Tag panel>
expand the panel title

Section Tags • Ribbon: Manage tab>Settings panel>
expand Additional Settings

Annotation 

Dimension 
Types

• Ribbon: Annotate tab>Dimensions 
panel>expand the panel title

Text • Family Editor

• Ribbon: Create tab>Text panel

Title Blocks

Label • Family Editor

• Ribbon: Create tab>Text panel

New Title Block • Ribbon: File tab> New

Revision 
Schedule

• Family Editor

• Ribbon: View tab>Create panel

View Templates and Filters

ApplyTemplate 
Properties to 
Current View

• Ribbon: View tab>Graphics panel>
expand View Templates

• Project Browser: (right-click on a 
view) Apply Template Properties...

Create View 
Template From 
View

• Ribbon: View tab>Graphics panel>
expand View Templates

• Project Browser: (right-click on a 
view)

Filters • Ribbon: View tab>Graphics panel

Manage View 
Templates

• Ribbon: View tab>Graphics panel>
expand View Templates

Temporary 
View Properties

• View Control Bar
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