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Preface

The CATIA V5-6R2018: Advanced Assembly Design and Management learning 
guide builds on the assembly functionality introduced in the CATIA: Introduction to 
Modeling course. Students gain a full understanding of how to design and manage 
a complex assembly in the CATIA software while concentrating on techniques that 
maximize the capabilities of the Assembly workbench. This extensive hands-on 
course contains numerous labs focused on process-based practices to give you 
practical experience and improve design productivity.

Topics Covered

• Assembly operations (reconnecting constraints, specification tree 
customization, save operations, Desk Command, etc.)

• Skeleton Modeling

• Contextual Design

• Publications

• Link Management

• Collaborative Design

• Component Degrees of Freedom

• Assembly Duplication (multi-instantiation, component symmetry, reuse 
patterns, etc.)

• Assembly analysis (measurements, clash, sectioning a model, etc.)

Prerequisites

• Access to CATIA V5-6R2018 software. The practices and files included with 
this guide might not be compatible with prior versions.

• Completion of the CATIA V5-6 R2018: Introduction to Modeling course and an 
additional 80 hours of CATIA experience are recommended.
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Note on Software Setup

This guide assumes a standard installation of the software using the default 
preferences during installation. Lectures and practices use the standard software 
templates and default options for the Content Libraries.

Lead Contributor: Scott Hendren

Scott Hendren has been a trainer and curriculum developer in the PLM industry 
for over 20 years, with experience on multiple CAD systems, including 
Pro/ENGINEER, Creo Parametric, and CATIA. Trained in Instructional Design, 
Scott uses his skills to develop instructor-led and web-based training products.

Scott has held training and development positions with several high profile PLM 
companies, and has been with the Ascent team since 2013.

Scott holds a Bachelor of Mechanical Engineering Degree as well as a Bachelor 
of Science in Mathematics from Dalhousie University, Nova Scotia, Canada.

Scott Hendren has been the Lead Contributor for CATIA: Advanced Assembly 
Design and Management since 2013.
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In this Guide

The following images highlight some of the features that can be found in this 
guide. 

Link to the practice files

Practice Files

The Practice Files page tells 
you how to download and install 
the practice files that are 
provided with this guide. 

Learning Objectives for 
the chapter

Chapters

Each chapter begins with a brief 
introduction and a list of the 
chapter’s Learning Objectives.
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Side notes

Side notes are hints or 
additional information for 
the current topic.

Instructional Content

Each chapter is split into a 
series of sections of 
instructional content on specific 
topics. These lectures include 
the descriptions, step-by-step 
procedures, figures, hints, and 
information you need to achieve 
the chapter's Learning 
Objectives.

Practice Objectives

Practices

Practices enable you to use the 
software to perform a hands-on 
review of a topic. 

Some practices require you to 
use prepared practice files, 
which can be downloaded from 
the link found on the Practice 
Files page.
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C h a p t e r

Assembly Operations

The Assembly Design workbench enables you to explore various design 
configurations and locate missing files. Operations, such as assembly constraints 
and constraint creation modes, help you to create a flexible assembly. This 
chapter introduces operations in the Assembly Design workbench, and compares 
top-down design techniques to bottom-up design techniques when creating 
assemblies.

Learning Objectives in this Chapter

• Review the Assembly Design Workbench and assembly related terms and definitions.

• Understand the Assembly Specification Tree.

• Learn how to work with assembly annotations.

• Learn how to work with assembly constraints.

• Understand the Save operations and the Desk command.
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1.1 Assembly Design 
Workbench

When designing parts in the Part Design workbench, features 
are created and positioned parametrically with respect to each 
other and to other reference features. Parts that belong to an 
assembly can be assembled and positioned parametrically in a 
CATProduct file using the Assembly Design workbench.

Accessing the
Assembly

Design
Workbench

By default, CATIA opens in the Assembly Design workbench. 
You can also activate the Assembly Design workbench by 
selecting Start>Mechanical Design>Assembly Design or 
File>New>Product. 

When the Assembly Design workbench is activated, various 
assembly-specific toolbars open. The Product Structure toolbar 
shown in Figure 1–1 enables you to assemble components, 
create part and product files in context, replace components, 
manage an assembly, and multi-instantiate components.

Figure 1–1
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1.2 Terms and Definitions

Skeleton A skeleton is a CATIA part model that is used to aid the 
construction of a complex assembly model. The part is used as a 
storage location for any critical design information, such as 
industrial design surfaces (e.g., A-side or masterline surfaces), 
and location and sizing information. The skeleton information is 
shared with the other components in the assembly to drive the 
design. The skeleton model is always the first component in an 
assembly and should only contain wireframe and surface 
geometry so that assembly mass properties are not affected.

Contextual
Design

Contextual design involves the creation of part-level geometry in 
the context of an assembly. By visualizing all of the components 
of an assembly while building a part, it is possible to share critical 
design information between components and ensure that 
components do not interfere with each other.

The contextual design approach is driven by the creation of 
external references between assembly components. These links 
add an extra level of complexity to the assembly and must be 
maintained throughout the design process to obtain maximum 
benefits. Building an assembly contextually requires good 
communication in the design team and a clear reference 
structure in the assembly.

Bottom-Up
Design

In a traditional bottom-up design approach, part geometry is 
created independent of the assembly or any other component. 
Any design criteria established before the part is modeled are 
not shared between models. Once all of the part models are 
completed, they are brought together for the first time in the 
assembly. At this point in the design, problems often result with 
the assembly because engineering information is not correctly 
shared or communicated. Problems can include interference 
between components, misalignment between components, or 
incomplete design. In addition, any modifications to components 
must be manually propagated throughout the assembly.am
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Top-Down
Design

The top-down design approach places critical information in a 
top-level assembly and then communicates that information to 
lower levels of the product structure. The first step in creating a 
top-down design model is to create an initial assembly structure. 
Design information is placed in this assembly through the use of 
skeleton models and parameters that are controlled by design 
tables. Any changes made to the top-level information are 
automatically propagated to all affected components.

Top-down design techniques simulate a design team and 
facilitate concurrent engineering. The top-down design approach 
forces you to consider all areas of a final model before creating 
any geometry. Consider the following questions when using this 
technique:

• What does the assembly do?

• How does a specific model interface with other components 
in the assembly?

• What are the inputs and outputs of the assembly?

Planning the assembly using the top-down design approach 
helps to create clean, reusable geometry that interfaces correctly 
with the rest of the assembly.

Collaborative
Design

Collaborative design involves two or more people simultaneously 
developing geometry for an assembly. For example, when 
designing a car, several departments contribute to the finished 
product.

A major concern in a collaborative environment is the loss of 
data or duplication of efforts. If two people open a part model at 
the same time, the last person to save defines the latest revision, 
while the first person’s modifications are lost. Communication is 
one defence against these types of setbacks. Another solution is 
to install a Product Data Management (PDM) application.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–4 © 2019, ASCENT - Center for Technical Knowledge®



Assembly Operations

S

Product Data
Management

Product Data Management (PDM) is a type of software that 
organizes and manages files in a database. Files in a PDM 
system are related to the development of a product. These files 
are stored on a server commonly referred to as the vault. From 
here, you can open files and save them back to the server. The 
PDM system keeps track of and controls all file operations. Only 
one person can work on a file at a time. All other users can only 
display the file, but not make changes to it.

Common capabilities of a PDM system include:

• Tracking revisions of a document.

• Advanced tools to search documents in the database.

• Viewing file information.

• Managing change orders.

• Managing bill of materials.

• Permissions control over files.
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1.3 Assembly Specification Tree
This section discusses the following methods of customizing the 
specification tree for a CATIA Product:

• Node Customization

• Graph Tree Reordering

Node
Customization

When working in the Assembly Design workbench, the 
specification tree displays component part numbers and instance 
numbers by default.

Select Tools>Options to open the Options dialog box. Expand 
Infrastructure and select Product Structure in the tree. Select 
the Nodes Customization tab. The nodes of the specification tree 
can be customized to report information, such as Description, 
Revision, and Source (vendor information). 

Figure 1–2 shows the Nodes Customization tab.

Figure 1–2
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Graph Tree
Reordering

The Graph tree reordering element is useful for reordering 
components of a product. 

How To: Reorder Parts in a Product

You can reorder the 
children of the top level 
product or any of its 
subassemblies.

1. In Product Structure Tools toolbar, click  (Graph tree 
reordering) and select the product whose children are to be 
reordered. The Graph tree reordering dialog box opens, as 
shown in Figure 1–3.

Figure 1–3

2. Use the following options to reorder components:

• Click  to move the selected components up one step 
in the product specification tree.

• Click  to move the selected component down one 
step in the product specification tree.

• Click  and another component to switch its position in 
the specification tree. 

3. Click Apply to apply changes. 
4. Click OK to complete the Graph tree reordering feature.
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1.4 Assembly Annotations
Annotations can be added to an assembly to identify various 
parts and components. The Annotations toolbar is shown in 
Figure 1–4. The following types of annotations can be created:

• Weld Feature

• Text with Leader

• Flag Note with Leader

• Front View/Annotation Plane

• 3D-Annotation-Query Switch On/Switch Off

Figure 1–4

Click  (Text with Leader) to create a text note and then select 
an element to attach the leader. The Text Editor dialog box 
opens, as shown in Figure 1–5 in which you can enter text.

To add another line of 
text to a note, press 
<Shift>+<Enter>.

Figure 1–5
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Annotation features are added under the Annotation node in the 
specification tree. For example, a front view is automatically 
created with annotations, as shown in Figure 1–6.

Views can be hidden.

Figure 1–6

Multiple notes can be associated with a single view. A view is 
useful for displaying all of the notes with one model orientation 
setting.
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1.5 Assembly Constraints
When creating features for part models, parent/child 
relationships result from geometrical, dimensional, and depth 
option references between features. When working with parts in 
a Product file, parent/child relationships are established through 
assembly constraints.

Assembly constraints are created using the Constraints toolbar 
shown in Figure 1–7.

Figure 1–7

The constraints are described as follows:

Icon Description

Coincidence: Aligns axes, planar surfaces, planes, and points.

Contact: Mates two planar surfaces and can force curved 
surfaces to touch.

Offset: Specifies an offset distance between two planar 
elements.

Angle: Permits a keyed-in value between planar selections. 
Parallel and perpendicular can also be specified.

Fix: Constrains a component in 3D space. This option 
constrains all six degrees of freedom.

Fix Together: Prompts you for a name and applies a Fix 
constraint between two or more components.

Quick Constraint: Enables the system to automatically select 
the constraint to use, based on your selection. This constraint 
can be changed later.am
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To change the type of existing constraint, click  (Change 
Constraint) and select the new constraint type in the Possible 
Constraints dialog box, as shown in Figure 1–8.

Figure 1–8

Constraint
Creation

Three different constraint creation modes can be activated. The 
system stays in the selected mode until a different mode has 
been selected. The Constraint Creation toolbar is shown in 
Figure 1–9.

Figure 1–9

The three constraint creation modes are described as follows:

Mode Description

Default mode: Selects references selected between two 
components.

Chain mode: Selects references from multiple components to 
be incrementally offset.

Stack mode: Selects a common reference for multiple 
components.
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1.6 Reconnecting Constraints
If an incorrect constraint reference is selected or if the design 
requires a change to the references of an existing constraint, the 
constraint must be reconnected. Two components with 
constraints that need to be reconnected are shown in 
Figure 1–10.

Figure 1–10

General Steps Use the following general steps to reconnect a constraint:

1. Edit the constraint.
2. Select new reference(s).
3. Update the assembly.

Double-click on the constraint in the specification tree. Click 
More in the Constraint Definition dialog box, as shown in 
Figure 1–11.

Figure 1–11

Step 1 - Edit the constraint.
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Double-click on the Connected in the Status column of the 
reference to be changed. The Plane reference of Fuselage part 
is being redefined, as shown in Figure 1–12.

Figure 1–12

Select a new element to be referenced in the specification tree or 
on the display. Click OK to complete the constraint definition.

Click  (Update All) to update the assembly constraints. The 
updated assembly displays, as shown in Figure 1–13.

Figure 1–13

Step 2 - Select new reference(s).

Step 3 - Update the assembly.
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1.7 Save Operations
New or modified files should be saved frequently to prevent data 
loss. Files can be saved using a variety of options:

• Save

• Save As

• Save All

• Save Management

• Send To

Save To save a file without renaming it, click  (Save) in the 
Standard toolbar or select File>Save. Using this option requires 
no further input from you.

Save As If the file is being saved for the first time, the Save As option is 
performed automatically. You can also use this option to rename 
a file or save a file to another format. Select File>Save As to 
open the Save As dialog box, as shown in Figure 1–14. The 
current name of the file displays in the File name field. To 
rename the file, replace the name in the File name field with the 
required name. Click Save to save the file to the hard drive.

By default, the file is 
saved as a .CATProduct 
file. You can change the 
type of file by selecting 
the file format in the 
Save as type 
drop-down list.

Figure 1–14
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Save All The Save All option performs the Save command on all open 
modified documents. This option enables you to save several 
open documents simultaneously. To perform the operation, 
select File>Save All. If the Save operation can be performed on 
the documents without any user input, a prompt box opens, as 
shown in Figure 1–15. Click Yes to save all of the modified open 
documents.

If any of the files to be saved requires additional user input, the 
prompt box shown in Figure 1–16 opens. Click OK to continue.

If documents cannot be automatically saved, the Save All dialog 
box opens. It lists all of the open modified files that require 
additional input to be saved. For example, in Figure 1–17 two 
files require additional input before they can be saved. The first 
file is a new file, indicating that it has never been saved to the 
hard drive. The second file is a read-only file and cannot be 
saved to the same location with the same name. In both cases, 
select the file and click Save As to perform a Save As operation 
on the selected file. Once all of the files listed in the window have 
had a Save As performed on them, click OK to complete the 
Save All.

Figure 1–17

Figure 1–15 Figure 1–16
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Save
Management

The Save Management option enables you to control where all 
open files are saved. This option is useful when you need to 
rename multiple files.

How To: Rename the Part Files of a Product

1. Select File>Save Management. 
2. Select the part file in the Save Management dialog box, as 

shown in Figure 1–18.

Figure 1–18

3. Click Save As and enter new name for the part file.
Save Management is also useful for exploring an alternative 
product development path. Propagate directory enables you to 
create a copy of a complete assembly in a different directory. 
The part and product files from the new directory can then be 
modified and re-configured without affecting the original product 
and part files.

How To: Propagate a Directory

1. Select a product file in the Save Management dialog box.
2. Click Save As. Specify a different directory to save the 

product file.
3. Click Propagate directory. The system saves a copy of all of 

the part and product files associated with the selected 
product file to the new directory.
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You are prompted to use Save Management when attempting to 
save a file with links to other modified documents. For example, 
when a product is saved and contains a part that has been 
altered, the prompt box shown in Figure 1–19 opens.

Figure 1–19

If you proceed with the Save option, only the selected document 
is saved and not the other modified documents. Instead, try 
clicking Cancel to abort the Save option and then using the 
Save Management or Save All option to avoid problems.

Send To The Send To option copies a product and all of its linked files to 
a specified directory or attaches them to an e-mail. This option 
ensures that all of the files required to open a product file are 
included in an e-mail or moved with the product file. 

How To: Perform a Send To Operation

1. Select File>Send To>Mail or File>Send To>Directory. The 
Send to dialog box opens. The top window lists the selected 
product file and all of the files linked to it, as shown in 
Figure 1–20.

In this example, Send 
To Directory was 
selected. The Send To 
Mail dialog box is the 
same but does not have 
the Copy to field at the 
bottom of the dialog 
box.

Figure 1–20
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2. Click  to copy the product and all of its associated files to 
the E-mail directory. The files move from the top window to 
the bottom window, as shown in Figure 1–21.

Figure 1–21

3. If the Send To Directory operation is performed, the files are 
copied to the directory indicated in the Copy to field. To 
change the directory, click Browse and locate the correct 
directory. The Copy To field updates to reflect the change.

4. Click OK to complete the copy.
5. If you have selected to Send To Mail, an e-mail opens with 

the copied files attached. If you have selected Send To 
Directory, a message window opens, notifying you that the 
copy was successful, as shown in Figure 1–22.

Figure 1–22
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1.8 Desk Command
When a CATIA product model is created, file paths to component 
files (e.g., *.CATPart and *.CATProduct) are written to the 
Product file. If the system cannot locate these files during 
retrieval, a message window opens, similar to the one shown in 
Figure 1–23.

Figure 1–23

If Close is clicked, the system does not include the missing 
component in the assembly.

If Desk is clicked, a Desk window opens, displaying the 
assembly and its components in a tree. Any missing components 
are highlighted in red. To locate the missing component, 
right-click on it in the tree and select Find, as shown in 
Figure 1–24.

Figure 1–24

6. The system then opens a File Selection dialog box for you to 
browse for the missing component. Once the component has 
been located, the Desk window can be closed.
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Practice 1a Assembly Creation

In this practice, you will create an assembly using a variety of 
assembly constraints. The completed model displays, as shown 
in Figure 1–25.

Figure 1–25

Task 1 - Create a Product file.

1. Select File>New and create a new Product file.

2. In the specification tree, right-click on Product1 and select 
Properties.

3. For the part number for the product, enter 71499 and click 
OK.

4. Select Tools>Options to open the Options dialog box. 
Expand General and select Parameters and Measure. 

5. Select the Units tab.

6. Set units for length to Millimeters(mm).

7. Save the product in the Turbine directory with the name 
CompressorRotor.

Practice Objectives

• Create a Product file.

• Assemble components.
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Task 2 - Assemble Impeller.CATPart.

1. Ensure that the Assembly Design workbench  is active. If 
not, select Start>Mechanical Design>Assembly Design.

2. Click  (Existing Component). In the specification tree, 
select 71499.

3. In the Turbine directory, select Impeller.CATPart.

4. In the Constraints toolbar, click  (Fix Component) and 
select the Impeller model. The component displays with the 
fix component anchor symbol, as shown in Figure 1–26.

Figure 1–26

Task 3 - Define Node Customization for the specification 
tree.

1. Select Tools>Options to open the Options dialog box.

2. Expand Infrastructure and select Product Structure.
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3. Select the Nodes Customization tab. The Options dialog box 
opens, as shown in Figure 1–27.

Figure 1–27

4. In the Product instance, reference loaded field, select 
Customized display, as shown in Figure 1–28.

Figure 1–28
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5. Click Configure. The Configure customized display dialog 
box opens, as shown in Figure 1–29. 

Figure 1–29

6. Clear the contents in the upper field, as shown in 
Figure 1–30.

Figure 1–30

7. Select the Part Number (#PN#)

8. Add a left side bracket and select Short Description (#SD#). 
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9. Add a right side bracket. The Display field displays, as shown 
in Figure 1–31.

The Short Description is 
the filename of the part. 
Products do not have 
short descriptions.

Figure 1–31

10.Click Close to close the Configure customized display dialog 
box. 

11. Click OK to close the Options dialog box. The specification 
tree displays, as shown in Figure 1–32.

Figure 1–32

Task 4 - Assemble 6thStage.CATPart.

1. In the specification tree, right-click on 71499 and select 
Components>Existing Component.

2. Open 6thStage.CATPart. The model displays in its default 
location on top of the impeller.
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3. Use the compass to reposition 6thStage. Right-click on the 
red box on the compass and select Snap Automatically to 
Selected Object.

4. In the specification tree, select 1296. The compass snaps to 
the component.

5. Drag the compass to reposition 6thStage, as shown in 
Figure 1–33.

Figure 1–33

6. Drag the compass off 6thStage.

7. Click  (Coincidence Constraint).

8. Select the implicit axis of 6thStage and the Impeller, as 
shown in Figure 1–34.

Figure 1–34
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9. Click  (Contact Constraint). 

10.Select the surface on Impeller shown in Figure 1–35.

Figure 1–35

11. Reorient the model and select the surface on 6thStage, as 
shown in Figure 1–36.

Figure 1–36

Select this 
surface

Select this 
surface
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12.Click  (Update All) to update the assembly, as shown in 
Figure 1–37.

Figure 1–37

Task 5 - Assemble 5thStage.CATPart.

1. Insert the 5thStage.CATPart.

2. Use the compass to reposition 5thStage.

3. Create a Coincidence constraint between the implicit axis of 
5thStage and 6thStage.

4. Create a Contact constraint between the two surfaces shown 
in Figure 1–38.

Figure 1–38

Create a Contact constraint 
between these two surfaces.
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5. Add a third constraint to orient 5thStage. Zoom in on the 
locating tab of 6thStage, as shown in Figure 1–39.

Figure 1–39

6. Click  (Angle Constraint) and create a Parallelism 
constraint between the surface of 6thStage shown in 
Figure 1–40 and the surface of 5thStage shown in 
Figure 1–41. Ensure that the Orientation is set to Same.

Figure 1–40

Zoom in to the 
locating tab

Select this surface
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Figure 1–41

7. Click  (Update All).

8. Click  (Isometric View).

The assembly displays, as shown in Figure 1–42.

Figure 1–42

Select this 
surface
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Task 6 - Assemble the remaining turbine wheel components.

1. Insert the remaining components of the assembly. When 
selecting the components to open, use <Ctrl> to select 
4thStage, 2nd3rdStage, and 1stStage.

2. Use the compass to drag each component out to new 
locations, as shown in Figure 1–43.

Figure 1–43

Task 7 - Change the constraint creation mode.

1. In the Constraint Creation toolbar, click  (Stack Mode).

2. Double-click on  (Coincidence Constraint). 

4thStage

2nd3rdStage

1stStage
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3. Select the axis of 1337, as shown in Figure 1–44.

Figure 1–44

4. Select the axes of the three turbine wheels, as shown in 
Figure 1–45.

Figure 1–45

5. Set the constraint creation mode to  (Default).

6. Create three Parallelism constraints between the turbine 
wheels.

7. Create three Contact constraints between the turbine wheels. 

8. Click  (Update All).
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9. In the specification tree, right-click on the Constraints node 
and select Hide/Show. The updated model displays, as 
shown in Figure 1–46.

Figure 1–46

Task 8 - Assemble TieBolt.CATPart.

1. Hide all of the components except Impeller and 1stStage, as 
shown in Figure 1–47.

When selecting 
components to hide, 
select them in the 
specification tree, 
otherwise you might 
only hide the PartBody 
and not the complete 
instance of the part.

Figure 1–47

2. Insert TieBolt.CATPart.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–32 © 2019, ASCENT - Center for Technical Knowledge®



Assembly Operations

S

3. Apply a Contact constraint to the surface of TieBolt, as 
shown in Figure 1–48 and to the back surface of Impeller, as 
shown in Figure 1–49.

Figure 1–48

Figure 1–49

Select this surface

Select this surface
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4. Constrain the axes of TieBolt and Impeller and update the 
assembly. The assembly displays, as shown in Figure 1–50.

Figure 1–50

Task 9 - Change update options and assemble 
Coupling.CATPart.

1. Select Tools>Options. Expand Mechanical Design and 
select Assembly Design. 

2. Select the General tab and select the Automatic option in 
the Update area, as shown in Figure 1–51.

Figure 1–51

3. Click OK to close the Options dialog box.

4. Hide the Impeller (1337).
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5. Assemble Coupling.CATPart to the impeller end of the 
tiebolt, as shown in Figure 1–52. 

Figure 1–52

Note that the system automatically updates the constraints 
on creation.

Task 10 - Restore options.

1. Select Tools>Options. The Options dialog box opens, 
displaying the General tab in Assembly Design.

2. Click  (Reset parameters values to default ones). The 
Reset dialog box opens, as shown in Figure 1–53.

Figure 1–53
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3. Click Yes to restore the options in the General tab.

4. Select Infrastructure>Product Structure>Nodes 
Customization tab and repeat Steps 2 and 3 to restore the 
settings.

5. Click OK to close the Options dialog box.

6. Show all of the components, 

7. Drag the compass away from the parts.

8. Select View>Reset Compass.

9. Right-click on the compass and clear the Snap 
Automatically to Selected Object option.

10.Save the model and close the file.
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