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Preface

Autodesk® Revit® 2021 Structure: Autodesk Certified Professional Exam Topics 
Review is a comprehensive review guide to assist in preparing for the Autodesk 
Certified Professional: Revit for Structural Design exam. This certification 
preparation guide enables experienced users to review learning content from 
ASCENT that is related to the exam objectives. It is divided into sections that align 
with the topics in the exam. The beginning of each section includes a list of the 
objectives that are covered in that section and the corresponding chapter where 
the review content is presented.

This guide is intended for experienced users of the Autodesk Revit software. New 
users of the Autodesk Revit 2021 software should refer to the following ASCENT 
learning guides:

• Autodesk Revit 2021: Fundamentals for Structure

• Autodesk Revit 2021 BIM Management: Template and Family Creation

• Autodesk Revit 2021: Collaboration Tools

• Autodesk Revit 2021 Architecture: Conceptual Design and Visualization

• Autodesk Revit 2021: Site Planning and Design

Autodesk Certified Professional Exam Objectives

Exam Objective Chapter(s)

1.1 Create and modify structural elements

1.1.a Work with foundations Ch. 1

1.1.b Work with structural floors Ch. 2

1.1.c Work with structural walls and wall types Ch. 1

1.1.d Work with structural columns Ch. 3

1.1.e Work with structural framing and connections* See p. 4-1

1.1.f Work with stairs Ch. 5

1.1.g Understand the functions and limitations of model and detail groups Ch. 6

1.1.h Work with reinforcement tools Ch. 7
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1.2 Use and modify element materials

1.2.a Associate a material with an object or a style Ch. 8

1.2.b Create and edit a basic material and its properties Ch. 8

1.2.c Load a material library See p. 8-1

1.3 Use selection sets

1.3.a Create, edit, and load selection sets Ch. 6

2.1 Manage family categories and types

2.1.a Configure family types Ch. 1

Ch. 9

2.1.b Understand concepts of family categories and types Ch. 9

2.1.c Differentiate between various types of families Ch. 9

2.1.d Transfer system families between projects Ch. 9

2.2 Use family parameters

2.2.a Create or delete an instance or type parameter Ch. 9

2.2.b Determine the appropriate parameter discipline, type, and grouping Ch. 9

2.3 Create family content

2.3.a Select the appropriate family template Ch. 9

2.3.b Export a family to create a type catalog Ch. 9

2.3.c Add reference planes, lines, and dimensions Ch. 9

2.3.d Create geometry Ch. 9

2.3.e Associate dimensional parameters Ch. 9

3.1 Annotate views

3.1.a Use dimensions Ch. 10

3.1.b Create and modify annotation families for documentation Ch. 10

3.1.c Create legend views Ch. 10

3.1.d Annotate rebar Ch. 10

3.2 Create and use detail components

3.2.a Load and create a detail component family Ch. 11

3.2.b Add a detail component Ch. 11

3.2.c Define a repeating detail Ch. 11

Exam Objective Chapter(s)
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3.3 Demonstrate an understanding of phases and design options

3.3.a Use phase filters Ch. 12

3.3.b Assign, display, and accept primary design options Ch. 12

3.4 Use document revisions

3.4.a Understand sheet issues/revisions Ch. 13

3.4.b Create a revision cloud Ch. 13

3.5 Configure export and print settings

3.5.a Configure export settings Ch. 13

3.5.b Configure custom print setup Ch. 13

4.1 Apply advanced view techniques

4.1.a Understand browser organization Ch. 14

4.1.b Set view properties Ch. 14

Ch. 19

4.1.c Apply visibility/graphic overrides Ch. 9

Ch. 14

4.1.d Apply and edit view templates Ch. 14

4.1.e Create and manage elevation and call-out views Ch. 14

4.1.f Set up a sheet Ch. 13

4.1.g Apply worksharing display modes to a view Ch. 17

4.1.h Use duplicate views Ch. 14

4.2 Manage, create, and modify schedules

4.2.a Develop and customize schedules Ch. 15

4.2.b Manipulate schedule data Ch. 15

5.1 Link or import files

5.1.a Understand the difference between imported and linked files Ch. 16

5.1.b Manage linked files Ch. 16

5.1.c Understand the concept of copy and monitor elements from a linked 
file

Ch. 16

5.2 Define worksharing concepts

5.2.a Understand why worksharing features are used Ch. 17

Exam Objective Chapter(s)
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*Objectives marked with an asterisk are not explicitly covered in this 
learning guide. Refer to each section for more information.

Prerequisites

• Access to the 2021.0 version of the software, to ensure compatibility with this 
guide. Future software updates that are released by Autodesk may include 
changes that are not reflected in this guide. The practices and files included 
with this guide are not compatible with prior versions (e.g., 2020). 

Note on Software Setup

This guide assumes a standard installation of the software using the default 
preferences during installation. Lectures and practices use the standard software 
templates and default options for the Content Libraries.

5.3 Use levels and grids

5.3.a Modify level and grid types Ch. 18

5.3.b Edit level and grid properties Ch. 18

5.4 Transfer project standards and establish shared coordinates

5.4.a Transfer and review project standards Ch. 9

5.4.b Understand the concept of shared coordinates Ch. 19

5.5 Edit object styles

5.5.a Control the appearance of elements at a project level Ch. 14

Ch. 16

Ch. 20

5.6 Conduct maintenance on a Revit project

5.6.a Understand and use purge Ch. 3

5.6.b Understand and use the audit and compact tools Ch. 17

5.6.c Assess review warnings in Revit Ch. 16

5.6.d Check a model for interferences Ch. 16

5.7 Understand shared, project, and global parameters Ch. 10

Ch. 21

Exam Objective Chapter(s)
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Students and Educators Can Access Free Autodesk Software 
and Resources

Autodesk challenges you to get started with free educational licenses for 
professional software and creativity apps used by millions of architects, 
engineers, designers, and hobbyists today. Bring Autodesk software into your 
classroom, studio, or workshop to learn, teach, and explore real-world design 
challenges the way professionals do.

Get started today - register at the Autodesk Education Community and download 
one of the many Autodesk software applications available. 

Visit www.autodesk.com/education/home/

Note: Free products are subject to the terms and conditions of the end-user 
license and services agreement that accompanies the software. The software is 
for personal use for education purposes and is not intended for classroom or lab 
use.

Lead Contributor: Cherisse Biddulph

Cherisse is an Autodesk Certified Professional for Revit as well as an Autodesk 
Certified Instructor. She brings over 15 years of industry, teaching, and technical 
support experience to her role as a Learning Content Developer with ASCENT. 
With a passion for design and architecture, she received her Associate of Applied 
Science in Drafting and Design and has worked in the industry assisting firms with 
their CAD Management and software implementation needs as they modernize to 
a Building Information Modeling (BIM) design environment. Although her main 
passion is the Revit design product, she is also proficient in AutoCAD, Autodesk 
BIM 360, and Autodesk Navisworks. Today, Cherisse continues to expand her 
knowledge in the ever-evolving AEC industry and the software used to support it.

Cherisse Biddulph has been the Lead Contributor for Autodesk Revit Structure: 
Autodesk Certified Professional Exam Topics Review since 2020.
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In This Guide

The following highlights the key features of this guide. 

Feature Description

Practice Files The Practice Files page includes a link to the practice files and 
instructions on how to download and install them. The practice 
files are required to complete the practices in this guide.

Sections This guide is divided into sections that align with the topics in the 
Autodesk Certified Professional exam. The beginning of each 
section includes a list of the exam objectives that are covered in 
that section and their corresponding chapters.

Chapters A chapter consists of the following - Exam Objectives, 
Instructional Content, and Practices. 

• Exam Objectives lists the Autodesk certification exam objectives 
that are covered in the chapter.

• Instructional Content, which begins right after Exam Objectives, 
refers to the descriptive and procedural information related to 
various topics. Each main topic introduces a product feature, 
discusses various aspects of that feature, and provides 
step-by-step procedures on how to use that feature. Where 
relevant, examples, figures, helpful hints, and notes are provided.

• Practice for a topic follows the instructional content. Practices 
enable you to use the software to perform a hands-on review of a 
topic. It is required that you download the practice files (using the 
link found on the Practice Files page) prior to starting the first 
practice.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2020, ASCENT - Center for Technical Knowledge® xvii



S

S E C T I O N

Modeling and Materials

Exam Objective Chapter(s)

1.1 Create and modify structural elements

1.1.a Work with foundations Ch. 1

1.1.b Work with structural floors Ch. 2

1.1.c Work with structural walls and wall types Ch. 1

1.1.d Work with structural columns Ch. 3

1.1.e Work with structural framing and connections See p. 4-1

1.1.f Work with stairs Ch. 5

1.1.g Understand the functions and limitations of model and detail groups Ch. 6

1.1.h Work with reinforcement tools Ch. 7

1.2 Use and modify element materials

1.2.a Associate a material with an object or a style Ch. 8

1.2.b Create and edit a basic material and its properties Ch. 8

1.2.c Load a material library See p. 8-1

1.3 Use selection sets

1.3.a Create, edit, and load selection sets Ch. 6
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C h a p t e r

Foundations

*Note: The objective 2.1.a Configure family types is also covered in Chapter 9.

Exam Objectives Covered in This Chapter

1.1.a Work with foundations

1.1.c Work with structural walls and wall types

2.1.a Configure family types*
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1.1 Modeling Walls
Walls in the Autodesk Revit software are more than just two lines 
on a plan. They are complete 3D elements that store detailed 
information, including height, thickness, and materials. This 
means they are useful in both 2D and 3D views. Structural walls 
(as shown in Figure 1–1) are bearing walls that can act as 
Exterior, Foundation, Retaining, and Shaft walls. 

Walls are not 
automatically 
reinforced. You must 
apply reinforcement as 
separate elements.

Figure 1–1

There are three broad categories of walls: 

• Basic walls: Compound walls that contain on or more layers 
(e.g., blocks, air space, bricks, etc.). 

• Curtain walls: Non-bearing walls made of glass with mullions. 

• Stacked walls: Includes one wall type above another wall 
type, such as a brick wall over a concrete wall.

These three categories’ Cross-Section can be modified to be 
Vertical or Slanted, as shown in Figure 1–2.

Figure 1–2
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While some walls are made of only one material such as poured 
concrete other walls can be made of multiple layers such as 
block, air space, and brick all in one wall type. These compound 
walls can have different justifications, as shown in Figure 1–3.

The core is typically the 
structural part of the 
wall. Figure 1–3

How To: Model a Wall

1. In the Structure tab>Structure panel, click  (Wall: 
Structural). 

• Architectural walls (which are created with the Wall: 
Architectural command) are typically non-bearing walls, 
such as curtain walls and partitions. They do not display 
when the view Discipline is set to Structural.

2. In the Type Selector, select a wall type, as shown in 
Figure 1–4. 

• You can use the Search box to quickly find specific types 
of walls.

Figure 1–4

Wall Centerline

Core Centerline

Search
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3. In the Options Bar (shown in Figure 1–5), specify the 
following information about the wall before you start drawing:

• Depth: Set the depth of a wall to either Unconnected (with 
a specified distance) or to a level. This command can also 
be set to Height.

• Location Line: Set the justification of the wall using the 
options shown in Figure 1–5.

• Chain: Enables you to draw multiple connected walls.

• Offset: Enables you to enter the distance at which a new 
wall is created from an existing element.

• Radius: Adds a curve of a specified radius to connected 
walls as you draw.

• Join Status: Select between Allow, which permits 
automatic wall joins, and Disallow, which prohibits the 
walls from cleaning up when they touch other walls.

Figure 1–5

4. In the Modify | Place Wall tab>Draw panel (shown in 
Figure 1–6), select one of the options to create the wall.

Figure 1–6

• Use alignment lines, temporary dimensions, and snaps to 
place the walls.

• When using the Chain option, press <Esc> to finish the 
string of walls and remain in the Wall command.

• As you are sketching, you can press <Spacebar> to flip 
the orientation of compound walls.am
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Modifying Walls There are several methods of modifying walls, as shown in 
Figure 1–7. These methods include the following:

• Changing the type of wall using the Type Selector.

• Using controls and shape handles to modify the length and 
wall orientation.

• Using temporary and permanent dimensions to change the 
location or length of a wall in 2D and 3D.

• Modifying the wall Properties.

Figure 1–7

Drag wall end

Temporary dimensions

Change wall’s 
orientation

Shape handle

Temporary dimensions

Drag wall end

Type Selector

Properties
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• To display the hatching in the walls in plan views, in the View 
Control Bar, set the Detail Level to Medium or Fine, as 
shown in Figure 1–8.

Figure 1–8

Wall Joins The software automatically joins walls with common materials 
when they come together at an intersection, as shown on the left 
in Figure 1–9. However, there are times when you do not want 
the walls to clean up, such as when one fire-rated wall butts into 
another, or when a wall touches a column surround, as shown on 
the right in Figure 1–9.

Figure 1–9

• While you are creating walls, change the Join Status to 
Disallow in the Options Bar.

• If a wall is already placed, right-click on the control at the end 
of the wall and select Disallow Join, as shown on the left in 
Figure 1–10. Once the end is not joined, you can drag it to 
the appropriate location, as shown on the right in 
Figure 1–10.

Figure 1–10

Wall joined Wall not joined

After: 
walls not joinedBefore: walls join automatically
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To rejoin the walls, click  (Allow Join) or right-click on the end 
control and select Allow Join. Manually drag the wall back to 
where you want it to touch the target wall.

Wall Openings You can add openings in walls that are not windows or doors by 
using the Wall Opening tool. This creates rectangular openings 
for both straight and curved walls, as shown in Figure 1–12.

Figure 1–12

Hint: Using Thin Lines

The software automatically applies line weights to views, as 
shown for a section on the left in Figure 1–11. If a line weight 
seems heavy or obscures your work on the elements, toggle off 
the line weights. In the Quick Access Toolbar or in the View 

tab>Graphics panel, click  (Thin Lines) or type TL. The 
lines display with the same weight, as shown on the right in 
Figure 1–11.

Figure 1–11

• The Thin Line setting is remembered until you change it, 
even if you shut down and restart the software.

Thin Lines Off Thin Lines On
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How To: Add Wall Openings

1. Open an elevation, section, or 3D view. 

2. In the Architecture tab>Openings panel, click  (Wall 
Opening).

3. Select the wall.
4. Pick two points on the diagonal to determine the opening 

size.

• You can use temporary dimensions to size the opening while 
in the command and both temporary dimensions and shape 
handles to modify the opening when it is selected, as shown 
in Figure 1–13.

Figure 1–13

Shape handles
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1.2 Creating Wall, Roof, Floor, 
and Ceiling Types

System families are modified in a project or template file by 
duplicating an existing element type. Some of these system 
families (such as walls, roofs, floors, and some ceilings) are 
compound or layer-based. For example, to modify a compound 
wall, you edit the type and select the Structure parameter. This 
opens the Edit Assembly dialog box (as shown in Figure 1–14) 
which enables you to specify each layer of the assembly.

Figure 1–14

• Walls are used as the primary example, but floors, roofs, and 
compound ceilings follow the same pattern.

• Structural Floors often use profiles for metal decking. 
Creating this type of floor is covered in the profile families 
topic.
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How To: Create a Compound Wall, Floor, Roof, or 
Ceiling

1. Start the wall, floor, roof or ceiling command.
2. In Properties, select a type similar to the one you want to 

create and click  (Edit Type).
3. In the Type Properties dialog box, click Duplicate....
4. In the Name dialog box, enter a name for the new type and 

click OK.
5. Next to the Structure parameter, click Edit.... 
6. In the Edit Assembly dialog box, modify the layers of the 

assembly and click OK.
7. Modify any Type Parameters in the Type Properties dialog 

box. 
8. Click OK to close the dialog box.

Editing Wall, Roof, and Floor Assemblies

In the Edit Assembly dialog box, you can define the layers that 
make up the compound structure, as shown in Figure 1–15.

Hint: Basic Ceilings

The basic ceiling system family does not include a structure 
parameter and is intended to be used for 
open framed/exposed ceiling spaces where a ceiling truly 
would not exist. Instead, modify the Type by specifying a 
Material for the entire thickness of the ceiling. 
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Figure 1–15

• To better visualize the wall, click << Preview to open a view 
of the layers in the structure. You can preview the structure in 
a plan or section view, and zoom or pan in the preview 
screen.

Assembly Information

The top of the dialog box lists the Family (such as Basic Wall or 
Floor), the Type name that you assigned to the new type, and 
the Total thickness (which is the sum of the layers defined in the 
wall), as shown in Figure 1–16. It also includes Resistance (R) 
and Thermal Mass which are automatically calculated from the 
materials assigned to the layers. You can also set a Sample 
Height for your wall design.

Figure 1–16
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Layers

When you specify the layers for the compound element, you 
assign them a Function, Material, and Thickness, as shown in 
Figure 1–17.

Figure 1–17

• Use the buttons to insert additional layers and to rearrange 
them in the layer list. You can also delete layers from the list.

• The Core Boundary function separates the core or structural 
portion of the wall, floor, roof, or ceiling from the layers above 
and below the wrapping; a heavier line displays when a plan 
or section view is cut. 

• Editing a wall assembly works from the exterior side at the 
top of the list to the interior side at the bottom. For floors and 
roofs, you work around the layers above and below the wrap 
of the Core Boundary.
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Options

Function Select from a set list of functions in the drop-down list 
with a priority of highest (1) to lowest (5). High priority 
layers connect with another elements layer of the 
same priority before lower priority layers. For 
example, a wall with a layer of Structure [1] will 
connect first with another wall that has a layer of 
Structure [1].

Structure [1] The structural support for the wall, floor, or roof.

Substrate [2] A material that acts as a foundation for another 
material, such as plywoodsheathing or gypsum 
board.

Thermal/
Air Layer [3]

An open layer for rigid insulation or air space.

Finish 1 [4] The exterior finish layer, such as brick for an exterior 
wall type, or one side of finish on an interior wall type. 
For Floors, Roofs, and Ceilings, represents the top 
finish layer of the assembly

Finish 2 [5] The interior finish layer, such as drywall on the inside 
of an exterior wall type, or the opposite side of finish 
on an interior wall type. For Floors, Roofs, and 
Ceilings, represents the bottom finish layer of the 
assembly.

Membrane 
Layer

A vapor barrier. Typically, this layer represents vapor 
or moisture barrier/retarder within a wall, floor, roof, 
or ceiling assembly. Due to the barrier actually being 
so thin, it is set to a 0'-0" thickness and, therefore, it 
does not have a priority code.

Structural 
Deck (1)

(Floors only) A structural support based on a Deck 
Profile. You can also specify the Deck Usage with a 
Bound Layer Above or a Standalone Deck.

Material Select from a list of available materials. Layers clean 
up if they share the same material and function. If 
they do not, a line displays at the join.

Thickness Set the thickness of the particular layer.

Wraps Set up individual layers to wrap when the Default 
Wrapping area has been specified - select the Wraps 
option at the end of each layer.

Structural 
Material

When selected, the physical asset of the layers 
material is used in the structural analytical model.
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Wall Only Options

• Wall wrapping can be set in the assembly or in the Type 
Properties, as shown in Figure 1–18.

 
Figure 1–18

• Roofs, floors, and structural slabs have an additional 
parameter that relates to sloping for drains. When Variable is 
not selected, the slab is set to a constant thickness and the 
entire element slopes, as shown on the top in Figure 1–19. 
When Variable is selected, only the variable layer gets thicker 
or thinner, as shown on the bottom in Figure 1–19.

Figure 1–19

Sample Height Displays the height of a wall in section when you are 
creating it. It does not impact the height of the wall in 
the project but is used when editing the vertical 
material changes and additions of sweeps or reveals.

Default Wrapping Controls how the layers within the assembly wrap at 
the end of a wall (At Ends) or an opening (At Inserts) 
within the wall.

Variable not checked

Variable checked
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Practice 1a Create a Structural Floor Type

In this practice, you will load a metal deck profile into a project, 
use it to create a new metal deck floor type, as shown in 
Figure 1–20, and test the new floor type.

Figure 1–20

Task 1 - Load the a profile and create a structural floor.

1. Start a new project based on the default Structural template. 
You should be in the Structural Plans: Level 2 view of the 
new project.

2. Save the project as Custom Floor Types.rvt in the practice 
files folder.

3. In the Insert tab>Load from Library panel, click  (Load 
Family).

4. Navigate to the practice files Families folder, select 
Custom-Metal-Deck-Profile.rfa, and click Open.

5. In the Structure tab>Structure panel, click  (Floor: 
Structural).

Practice Objectives

• Load a custom profile into a project.

• Create a new structural floor type using the profile.

Profile
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6. in the Type Selector, verify that Floor: 3"LW Concrete on 2" 
Metal Deck is selected.

7. In the Modify | Create Floor Boundary tab>Draw panel, use 
the Line or Rectangle tool to draw a slab of any shape or 
size, as shown in Figure 1–21. 

Figure 1–21

• If the span direction is not horizontal, in the Modify | Edit 

Boundary tab> Draw panel, click  (Span Direction) and 
select a horizontal sketch line.

8. Click  (Finish Edit Mode).

9. In the Quick Access Toolbar or View tab>Create panel, click   

 (Section) and place a section vertically through the slab 
from north to south.

10.Open the new section view and change the Scale to 
3/4"=1'-0" and the Detail Level to Fine. You might need to 
adjust the crop region and/or zoom in on the slab section. It 
should look similar to the one shown in Figure 1–22.

Figure 1–22

11. Save the project.

Task 2 - Create a new floor type.

1. Select the slab. 

2. In Properties, click  (Edit Type). 
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3. Duplicate the existing type. Name the duplicated type 
6" Concrete on 3" Comp Metal Deck.

4. In the Type Properties dialog box, next to the Structure 
parameter, click Edit....

5. Modify the Structure [1], Concrete, Lightweight - 4 ksi 
layer to a Thickness of 6", as shown in Figure 1–23.

Figure 1–23

6. In the Layers area, select the Structural Deck layer.

7. In the Structural Deck Properties area, in the Deck Profile 
drop-down list, select Custom-Metal- Deck-Profile: 3", as 
shown in Figure 1–24.

Figure 1–24

8. Click OK to close all of the dialog boxes. The section should 
display the metal deck profile that was previously created, as 
shown in Figure 1–25.

Figure 1–25

9. Save and close the project.
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1.3 Vertically Compound Walls
Vertically Compound walls are made of regions of different 
materials, as well as optional permanent sweeps or reveals, as 
shown in Figure 1–26. Several options help you create these 
walls: Modify, Split Region, Merge Regions, Assign Layers, 
Wall Sweeps, and Reveals.

Figure 1–26

In the Edit Assembly dialog box, you must have the preview’s 
View: set to Section: Modify type attributes to work with the 
Modify Vertical Structure tools, as shown in Figure 1–27.

Figure 1–27
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How To: Modify the Vertical Structure of a Wall Type

1. Edit the wall type you want to modify and edit the structure. 
2. Create any additional layers that might be required.
3. In the Edit Assembly dialog box, open the preview and set 

the View: to Section: Modify Type Attributes. This activates 
the Modify Vertical Structure tools, as shown in Figure 1–28.

Figure 1–28

4. Zoom in to see the various layers.
5. In the Layers list, select the layer you want to work with.
6. Use the various tools that are outlined below.
7. Click OK until all of the dialog boxes are closed to save the 

wall type.

• When making changes to the vertical structure of a wall type 
it helps to have the Sample Height set to the shortest 
expected height for the wall type so the changes display 
more clearly.

How To: Split Regions and Assign Layers

1. In the Edit Assembly dialog box, click Split Region. 
2. In the section preview, move the cursor to the edge of the 

wall, and a dimension will display. Move the cursor up the 
wall’s edge to the place where you want the region to be cut. 
Select the wall’s individual layer at the edge of that point, as 
shown in Figure 1–29.

Figure 1–29

Wall layer 
edge
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• When splitting regions, it is helpful to move the cursor along 
the outer edge of the region being split. Look for the 
horizontal line across the region before picking the point to 
split, as shown in Figure 1–30.

Figure 1–30

3. In the Layers area, highlight the layer that you want to use 
and click Assign Layers.

4. In the section view, select the wall part that you want to 

change and click  (Modify).

• You can create as many split regions as required in one layer.

• To change the dimension, click  (Modify) and select the 
border between the two regions that have been split. Then, 
select the temporary dimension you want to adjust and type a 
new distance using the temporary dimension, as shown in 
Figure 1–31.

Figure 1–31

Horizontal
split region 
line

Select split region

Temporary 
dimension
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• You can modify the width of the layer in the section view by 
clicking Modify, then selecting the outer boundary (left edge 
of the region) to display temporary dimensions (as shown in 
Figure 1–32) to change the width. Note that this will change 
the width for both regions stacked on top of one another.

Figure 1–32

• You can add additional layers and assign functions as 
required. In the example shown in Figure 1–33, two layers 
have the function Finish 1 [4], and each layer has a different 
material. When a region is split, the thickness of the original 
layer is set to Variable and cannot be modified in the Layers 
area of the Edit Assembly dialog box.

Do not select more than 
you need. There is no 
Undo option in this 
dialog box. 

Figure 1–33

Temporary 
dimension

Select outer 
edge
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Merging Regions

To link regions together, click Merge Regions and select the line 
between the layers you want to merge, as shown in Figure 1–34. 
As you move the cursor across the region boundary that is to be 
merged, watch the arrow cursor. It tells you which way the merge 
direction will take place. The tooltip also tells you names of the 
layers that are being merged. You can only merge layers that are 
next to each other.

Figure 1–34

• You can merge layers vertically or horizontally. You need to 
split the regions horizontally before merging some of the 
vertical lines.

Wall Sweeps and Reveals

When you split regions, the parts you create cannot have 
different widths. To create a protrusion or a reveal, add a wall 
sweep or reveal using a profile, as shown in Figure 1–35. You 
can also specify the material (sweeps only), orientation, offset, 
distance from top or base, if the wall profile will be on the exterior 
or interior side, and the option to flip the wall profile.

Figure 1–35

How To: Add a Sweep

1. In the Edit Assembly dialog box, click Sweeps to open the 
Wall Sweeps dialog box. 

2. In the Wall Sweeps dialog box, click Add. A default row is 
added.

Merge direction icon

Wall profile
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3. In the Profile column, select from the drop-down list of the 
existing profiles in the project. Click Load Profile to add a 
profile.

4. Continue setting up the profile by selecting a Material and 
setting the Distance from the top or bottom, interior or exterior 
Side, and the Offset from that side, as shown in Figure 1–36. 
If needed, place a check mark in the Flip column to flip the 
profile.

Figure 1–36

5. Click Apply to see the sweep in the preview before you click 
OK to finish.

• Reveals work the same way, except that you do not assign a 
material to a reveal. The whole shape of the reveal profile is 
visible in the section view, but you only see the cut in the 
project.
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Practice 1b Create a Vertically Compound 
Wall

In this practice, you will modify the vertical structure of a wall 
type using Split Region and Assign Layers.You will then add 
wall sweeps and reveals, as shown in Figure 1–37.

Figure 1–37

Task 1 - Add materials to the project.

1. Open Custom Wall Types-Vertical.rvt from the practice files 
folder.

2. In the Manage tab>Settings panel, click  (Materials).

Practice Objective

• Create a vertically compound wall.
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3. At the bottom of the Material Browser dialog box, expand the 
Material Library section as shown in Figure 1–38.

Figure 1–38

4. If you do not see the AEC Materials library at the bottom of 
the dialog box, click Shows/Hides library tree, as shown in 
Figure 1–39.

Figure 1–39

5. In the AEC Material library, select the Masonry folder. 

6. In the Name list scroll down and select Brick, Common, 

Grey and click  (Adds material to document), as shown in 
Figure 1–40.

Figure 1–40

Click to expand
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7. Repeat the process and add the CMU, Split Face material to 
the project and click OK.

8. Save the project.

Task 2 - Split regions in the wall type section.

1. Select the existing wall and in the Type Selector, verify that it 

is set to Exterior - Custom and click  (Edit Type).

2. Edit the Structure parameter.

3. Set the Sample Height to 30'-0".

4. Click << Preview and set the View: to Section: Modify type 
attributes.

5. In the Layers area, insert two additional layers with the 
Function Finish1 [4] on the exterior side of the structure. Set 
the materials as shown in Figure 1–41. Do not specify a 
thickness. Once you apply it to part of the split region, it takes 
on the appropriate thickness.

Figure 1–41

6. In the Modify Vertical Structure area, click Split Region.am
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7. In the Section view preview, move the cursor along the left 
edge of the exterior finish region (the leftmost region) to a 
point 3'-6" above the base. Zoom in to ensure that you split 
the finish layer and not the central structural layer. Add the 
three additional splits to the same layers, as shown in 
Figure 1–42.

Figure 1–42

Task 3 - Assign layers in a wall type.

1. Zoom in so you can see the areas that have been split, as 
shown in Figure 1–43.

2. In the Layers area, select the Brick, Common, Gray layer on 
the Exterior Side.

3. In the Modify Vertical Structure area, click Assign Layers. 

4'-0"

4'-0"

2'-0"

3'-6"
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4. In the preview, select the exterior edge of the 2'-0" part of the 
exterior wall where you want the finish applied. The section 
should highlight as shown in Figure 1–43.

Figure 1–43

5. Repeat with the CMU, Split face material in each of the 4'-0" 
sections. The top and bottom of the wall remain using the 
Concrete Masonry Units material.

6. Click  (Modify) to finish the process. The list of layers 
displays as shown in Figure 1–44.

Figure 1–44
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7. Click OK twice to close the dialog boxes. 

8. Set the Visual Style of the 3D view to Realistic, as shown in 
Figure 1–45, to see the layout of the materials.

Figure 1–45

9. Save the project.

Task 4 - Add sweeps and reveals to the wall type.

1. Edit the structure of the same wall type.

2. In the Edit Assembly dialog box, Modify Vertical Structure 
area, click Sweeps.

3. In the Wall Sweeps dialog box, click Add and set up two wall 
sweeps using the following information, as shown in 
Figure 1–46, and leave other options at their default settings.

Figure 1–46

4. Click OK to exit the Wall Sweeps dialog box.
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5. In the preview of the Edit Assembly dialog box, you should 
see the two sweeps when you zoom in, as shown for the sill 
in Figure 1–47 and the cap in Figure 1–48.

6. In the Edit Assembly dialog box, Modify Vertical Structure 
area, click Reveals.

7. In the Reveals dialog box click Add and set up three reveals 
as shown in Figure 1–49. Click OK.

Figure 1–49

8. Click OK twice to close the dialog boxes. The wall displays 
complete with sweeps and reveals.

9. Save and close the project.

Figure 1–47 Figure 1–48
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1.4 Stacked and Embedded 
Walls

A vertically stacked wall is a specific system family that takes two 
or more existing basic walls and stacks them on top of each 
other at specific heights, as shown in Figure 1–50. One wall 
must be variable in height. The basic wall types have to be in 
place before you create the stacked wall. These walls are 
created by copying and editing an existing Vertically Stacked 
Wall type.

Figure 1–50

How To: Create a Vertically Stacked Wall

1. Start the Wall command.
2. In Properties Type Selector, select an existing stacked wall 

type and click  (Edit Type).
3. Duplicate the wall type and give it a new name. 
4. In the Type Properties dialog box, next to the Structure 

parameter, click Edit....
5. In the Edit Assembly dialog box, set the Offset for how the 

walls should align when they are stacked, and a Sample 
Height for the preview, as shown in Figure 1–51.

Figure 1–51
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6. In the Name column, select the basic wall types you want to 
add to the stacked wall, as shown in Figure 1–52.

Figure 1–52

7. For each wall type, set the appropriate height and location 
(Up or Down) in the list. One height must be variable. Set the 
Offset of the wall as required.

8. Click << Preview to see the wall, as shown in Figure 1–53.

Figure 1–53

9. Click OK until all of the dialog boxes are closed.am
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Hint: Embedding a Wall Inside Another Wall

Another way of creating a compound wall is to embed one wall 
inside another wall, as shown in Figure 1–54. When you have 
drawn a host wall, draw another wall on top of, or parallel to it 
near the host. A warning box opens and recommends that you 
use Cut Geometry to embed the wall in the host wall.

Figure 1–54

1. Add the embedded wall to the host wall.
2. Close the warning box.

3. In the Modify tab>Geometry panel, click  (Cut).
4. Select the host wall.
5. Select the wall that cuts the host wall.

• Embedded walls work similar to windows. You can modify 
the embedded wall with controls.

• Some curtain wall types are created to be automatically 
embedded in another wall. The type Curtain Wall: 
Storefront is an example. The Type Parameter 
Automatically Embed is available for all curtain wall types.

• You can separate embedded walls. In the Modify tab> 

Geometry panel, expand  (Cut) and click  (Uncut 
Geometry).

Front view

Top view
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Practice 1c Create Stacked and Embedded 
Walls

In this practice, you will create a vertically stacked wall and use it 
in a project. You will also embed a curtain wall and another wall 
type into a host wall, as shown in Figure 1–55.

Figure 1–55

Task 1 - Create a stacked wall.

1. Start a new project based on the default architectural or 
structural template and save it as Warehouse.rvt in the 
practice files folder.

2. Start the Wall command and select the Stacked Wall: 
Exterior – Brick Over CMU w Metal Stud type.

3. Edit the type and duplicate it to create a new wall type named 
Exterior – EIFS over Brick/CMU.

4. Edit the structure of the new wall.

5. For the top wall, select Exterior – EIFS on Mtl. Stud. Leave 
the Height as Variable and set the Offset to 4".

6. For the bottom wall, select Exterior – Brick on CMU and set 
the Height to 6'-0".

7. Click OK to close all of the open dialog boxes.

8. Draw a rectangular building 50'-0" x 30'-0" using the new 
wall style.

9. Set the Detail Level to Fine.

Practice Objectives

• Create a vertically stacked wall type.

• Embed a wall into a stacked wall.
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10.Display the walls in 3D to verify that the Brick/EIFS display on 
the exterior.

11. Save the project.

Task 2 - Create an embedded wall.

1. Open the Floor Plans: Level 1 view.

2. On the south face of the building, add a wall using Curtain 
Wall: Storefront at an Unconnected Height of 8'-0". Place it 
directly on the center line of the existing wall along only a 
portion of the wall. It automatically cuts the existing wall.

3. Open the Floor Plans: Level 2 view.

4. Add another wall on the same face using Basic Wall: 
Exterior – Brick on Mtl. Stud. This time a warning box 
opens. Read and close the warning box.

5. In the Modify|Place Wall tab>Geometry panel, click 

 (Cut).

6. Select the host wall.

7. Select the wall that cuts the host wall.

8. Open the South elevation view.

9. Set the Visual Style to Realistic.

• Flip the orientation of the brick insert, if needed.

10.Change the size of the embedded wall using the controls, but 
do not move it down into the lower brick wall.

11. Save and close the project.
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1.5 Adding Wall Footings
Wall footings for bearing and retaining are hosted by the walls. 
Once a footing is in place, you can add reinforcement, as shown 
in Figure 1–56. With the advantages of having a true foundation 
in place, you can accurately tag and schedule the footings.

Figure 1–56

• You can apply two types of continuous footing systems, as 
shown in Figure 1–57. You must have walls in your model to 
add a footing system:

• Retaining footings: A footing with one side offset to 
accommodate additional lateral loads and reinforcement 

• Bearing footings: A footing with an equal distance on 
either side of the bearing wall.

Figure 1–57

How To: Place a Bearing or Retaining Footing

Wall foundations can 
also be placed in 3D, 
section, and elevation 
views.

1. Create walls or use existing ones. A wall must be in place for 
this command to work.

2. Open a foundation plan and set it up so that the walls are 
displayed and you can select them.

Retaining Footing Bearing Footingam
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3. In the Structure tab>Foundation panel, click  (Wall) to 
start the Structural Foundations: Wall command, or 
type FT.

4. In the Type Selector, select a type, as shown in Figure 1–58.

Figure 1–58

5. Select a wall, the footing is placed beneath the wall as shown 
in Figure 1–59.

Figure 1–59

• To select multiple walls, hover over one wall and then 
press <Tab> to select all connected walls. Alternatively, in 
the Modify | Place Wall Foundation tab>Multiple panel, 

click  (Select Multiple). Select the walls using any 

selection method and click  (Finish) to place the 
footings.

• You can flip retaining footings as shown in Figure 1–60.

Figure 1–60

Wall Footing

Footing

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2020, ASCENT - Center for Technical Knowledge® 1–37



Autodesk Revit 2021 Structure: Autodesk Certified Professional Exam Topics Review

S

How To: Create a Footing Type

1. Select an existing foundation wall element or start the 
Structural Foundation: Wall command.

2. In the Type Selector, select a type similar to the type that you 

want to create and in Properties, click  (Edit Type).
3. In the Type Properties dialog box, click Duplicate.
4. In the Name dialog box, type a new name for the element and 

click OK.
5. Make any changes to the type properties as needed, as 

shown in Figure 1–61.

Figure 1–61

6. Click OK to close the dialog box.
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Wall Profiles
and Footings

Footings are appended to the bottom of a wall, which means that 
any change to the base of the host wall influences the footing. 
This occurs for lateral movement and horizontal movement. For 
the example shown in Figure 1–62, when the wall profile 
changes based on a sloped site (as shown on the left), the 
footing breaks and follows the modified profile (as shown on the 
right). This is accomplished by editing the profile of the 
foundation wall.

Figure 1–62

How To: Edit the Profile of a Wall

1. Open an elevation or section view in which you can see the 
face of the wall that you want to edit.

2. Select the wall (by highlighting the wall boundary).

3. In the Modify | Walls tab>Mode panel, click  (Edit Profile). 
The wall is outlined in magenta indicating the profile of the 
wall.

Wall profile in process Completed wall with footing
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4. In the Modify | Walls>Edit Profile tab>Draw panel, use the 
tools to modify the profile sketch of the wall, as shown on the 
top in Figure 1–63. 

5. Once the profile is complete, click  (Finish Edit Mode). 
The footing now follows the new profile, as shown on the 
bottom in Figure 1–63.

The sketch must form a 
continuous loop. Verify 
that the lines are clean 
without any gaps or 
overlaps. Use any of the 
tools in the Modify panel 
to clean up the sketch.

Figure 1–63

• After you adjust the sketch you can add isolated footings to 
create the appropriate shape.

Modified sketch

Finished Wall

Dashed line is original wall shape
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Hint: Materials

When you are creating some types, such a wall footings, one 
option is to set the Structural Material. In the Type Properties 
dialog box, in the Materials and Finishes area, click in the Value 

column and then click  (Browse), shown in Figure 1–64.

Figure 1–64

In the Material Browser (shown in Figure 1–65), specify the 
material you want to use and then click OK.

Figure 1–65
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Practice 1d Model Walls and Wall Footings

In this practice, you will model the perimeter foundation walls as 
shown in Figure 1–66.

Figure 1–66

Task 1 - Add walls.

1. Open Walls-Syracuse-Suites.rvt from the practice files 
folder.

2. Open the Structural Plan: 00 GROUND FLOOR view. (The 
green lines are the outline of the building.)

3. In the Structure tab>Structure panel, click  (Wall: 
Structural).

4. In the Type Selector, select Basic Wall: Exterior - 8" 
Concrete.

Practice Objectives

• Place structural walls.

• Create and apply wall footings.
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5. In the Options Bar, set the Depth to T.O. FOOTING and 
ensure that the Location Line is Wall Centerline and Chain 
is selected. 

6. In the Modify | Place Structural Wall tab>Draw panel, click 

(Line).

7. Select the start point by snapping to the intersection at 
Grid G1 as shown in Figure 1–67.

Figure 1–67

8. Draw the wall up to the intersection of Grid E1.

9. In the Draw panel, click  (Start-End-Radius Arc). Select 
the second point at Grid C1 and then the third point 
anywhere along the green arc to specify the radius of the arc, 
as shown in Figure 1–68.

Figure 1–68
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10.Click  (Line) again and select the intersection of Grid B1.

11. Following the green outline, continue drawing walls all of the 
way around the perimeter as shown in Figure 1–69. 

Figure 1–69

12.Save the project.

Task 2 - Create and apply wall footings.

1. Open the Structural Plans: 000 FOUNDATION PLAN view.

2. In the Structure tab>Foundation panel, click  (Structural 
Foundation: Wall) or type FT.

3. Make sure you are on Wall Foundation: Bearing Footing - 

36" x 12". In the Type Selector, click  (Edit Type).

4. In the Type Properties dialog box, click Duplicate....

5. In the Name dialog box, type Bearing Footing – 24" x 12" 
and then click OK.
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6. In the Type Properties dialog box, under Dimensions, set the 
Width to 2'-0", as shown in Figure 1–70.

Figure 1–70

7. Click OK.

8. You are still in the Wall Foundation command. In the Type 
Selector, ensure that the new Wall Foundation: Bearing 
Footing - 24" x 12" is selected, as shown in Figure 1–71.

Figure 1–71

9. Hover the cursor over one of the existing walls and press 
<Tab> to highlight the entire wall system. Click to select the 
walls. The footing is placed under the entire structure.

10. If you do not see the new wall foundation elements, you 
might be in an area of the view where they are not visible. 
Open the Structural Plans: 000 FOUNDATION PLAN view.

11. End the command. 
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12. In the Quick Access Toolbar, click  (Default 3D View) to go 
to a 3D view and verify that the footing is placed correctly as 
shown in part in Figure 1–72. Change the Visual Style as 
needed.

Figure 1–72

13.Save and close the project.
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1.6 Creating Piers and Pilasters
The Autodesk Revit software does not have specific categories 
for piers and pilasters. If you need to create these elements, the 
best method is to use concrete columns as shown in 
Figure 1–73. You can then analyze them as part of the 
foundation system and independently schedule them from the 
main column schedule. A concrete column also automatically 
embeds itself into a concrete wall.

Figure 1–73

• Poured concrete columns can be created in many sizes. For 
typical rectangular, square, and round columns, it is easy to 
create custom sizes.

How To: Create a Custom Column Size

1. Open a plan view.

2. In the Structure tab>Structure panel, click  (Column).

3. In the Type Selector, select an existing column family type 
similar to the one you want to create, such as 
Concrete-Rectangular-Column.

4. In Properties, click  (Edit Type).

5. In the Type Properties dialog box, click Duplicate.

Concrete column

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2020, ASCENT - Center for Technical Knowledge® 1–47



Autodesk Revit 2021 Structure: Autodesk Certified Professional Exam Topics Review

S

6. In the Name dialog box, type a name as shown in 
Figure 1–74. Click OK.

Figure 1–74

7. Modify the dimensions as required. Enter the required values 
for b (base) and h (height), as shown in Figure 1–75.

Figure 1–75

8. Click OK.
9. The new pier column can placed at the base of the existing 

steel columns, as shown in Figure 1–76.

Figure 1–76
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Hint: Temporary Hide/Isolate

You might want to temporarily hide elements from a view, 
modify the project, and then restore the elements. Instead of 
completely toggling the elements off, you can use 

(Temporary Hide/Isolate) in the View Control Bar. The 
Temporary Hide/Isolate status is not saved with the project.

Select the elements you want to hide (make invisible) or isolate 
(keep displayed while all other elements are hidden) and click 

(Temporary Hide/Isolate). Select the method you want to 
use, as shown in Figure 1–77.

Figure 1–77

The elements or category are hidden or isolated. A cyan border 
displays around the view with a note in the upper left corner, as 
shown in Figure 1–78. It indicates that the view contains 
temporarily hidden or isolated elements. 

Figure 1–78

• Click  (Temporary Hide/Isolate) again and select Reset 
Temporary Hide/Isolate to restore the elements to the 
view.

• If you want to permanently hide the elements in the view, 
select Apply Hide/Isolate to View.

• Any elements that are temporarily hidden still print.
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Practice 1e Create Piers and Pilasters
 

In this practice, you will create a new column type and place 
piers and pilasters (types of columns). The resulting model is 
shown in Figure 1–79.

The steel columns have 
been hidden in this view 
for clarity.

Figure 1–79

Task 1 - Create a new column type.

1. Open Foundations-Syracuse-Suites.rvt from the practice 
files folder.

2. Open the Structural Plans: 000 FOUNDATION PLAN view.

3. In the Structure tab>Structure panel, click  (Column), or 
type CL.

4. In the Type Selector, select one of the Concrete-
Rectangular-Column types.

5. In Properties, click  (Edit Type).

6. In the Type Properties dialog box, click Duplicate.

Practice Objectives

• Create a new column type. 

• Add columns.

Pilasters

Piers
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7. Rename the column to 24 x 24. The family name, 
Concrete-Rectangular-Column is automatically applied to 
the name. Click OK.

8. In the Type Properties dialog box, change the dimensions for 
both b (base) and h (height) to 2'-0", as shown in 
Figure 1–80.

Figure 1–80

9. Click OK.

10.Click  (Modify).

Task 2 - Place piers and pilasters.

1. Select one of the steel columns. In the View Control Bar, 

expand  (Temporary Hide/Isolate) and click Isolate 
Category, as shown in Figure 1–81. Only the columns 
display.

This is one method that 
can help you place the 
columns. You can also 
use At Grids and delete 
the columns that you do 
not need.

Figure 1–81

2. In the Structure tab>Structure panel, click  (Column), or 
type CL.

3. Ensure that Concrete-Rectangular-Column: 24 x 24 is 
selected in the Type Selector.
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4. In the Options Bar, set Depth to T.O. Footing.

5. Place a concrete column at each existing steel column. Some 
of the columns will look odd (as shown in Figure 1–82) 
because they are connected to the concrete foundation walls 
that have been hidden in the view. 

Figure 1–82

6. When you finish placing the concrete columns, in the View 

Control Bar, expand  (Temporary Hide/Isolate) and select 
Reset Temporary Hide/Isolate.

7. In the Quick Access Toolbar, click  (Default 3D View). and 
view the new column placement.

8. Save and close the project.
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1.7 Adding Isolated Footings
Footings for columns (shown in Figure 1–83) are placed using 
the Structural Foundation: Isolated command. When you 
select a column, the footing automatically attaches to the bottom 
of the column. This is true even when the bottom of the column is 
on a lower level than the view you are working in.

Figure 1–83

How To: Place an Isolated Footing

1. Open a plan view, such as a T.O. Footing structural floor 
plan.

2. In the Structure tab>Foundation panel, click  (Isolated) to 
start the Structural Foundation: Isolated command.

3. In the Type Selector, select a footing type.
4. In the view, click to place the individual footing as shown in 

Figure 1–84.

• If needed, press <Spacebar> to rotate the isolated 
footings after they are placed.

Figure 1–84

Isolated footing
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• To add more than one footing at a time, in the Modify | Place 

Isolated Foundation tab>Multiple panel, select  (At Grids) 

or  (At Columns) and select the grids or columns.

• If needed, press <Spacebar> to rotate the isolated 
footings after they are placed.

• If the material of the wall footing and the material of the 
isolated footing are the same they automatically join, as 
shown in Figure 1–85.

Figure 1–85

Wall footing

Isolated footing

Hint: Foundation Element Properties

Some of the element properties are automatically generated 
from the location and size of the element in the model and are 
grayed out, for example Host, Elevation at Top, and Elevation 
at Bottom as shown in Figure 1–86. These can be used in tags 
and schedules.

Figure 1–86
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Working
with Custom

Families

Sometimes you need to work with a custom family that has 
parameters that you can manipulate to fit a specific situation. For 
example, to add the step footings shown in Figure 1–87, you 
need to insert an angled isolated footing and modify it to fit the 
exact size and location.

Figure 1–87

How To: Load, Insert, and Modify a Custom Footing

1. Open a plan view.

2. In the Structure tab>Foundation panel, click  (Isolated) 
and in the Modify | Place Isolated Foundation tab>Mode 

panel, click  (Load Family).
3. In the Load Family dialog box, find the structural foundation 

family that you want to use and click Open.
4. Place the footing in the plan view. It might not be in the right 

place, but you can modify it in a section or elevation view.
5. Open an elevation or section view.
6. Move the footing to the correct location. As long as it is in line 

with another footing, it automatically cleans up as shown in 
Figure 1–88.

Figure 1–88

Isolated footing 
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• Use  (Align) to align the isolated footing with the footing 
already in the model. When it is aligned, select the lock, as 
shown in Figure 1–89. This ensures that if the elevation of the 
footing wall changes, the step footing will also adjust 
appropriately.

Figure 1–89

• Some custom families have sizing options in either Properties 
(per instance) or in the Type Properties (as shown in 
Figure 1–90) so that you can create additional types in 
various sizes as needed in the project.

Figure 1–90

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–56 © 2020, ASCENT - Center for Technical Knowledge®



Foundations

S

Practice 1f Add Isolated Footings
 

In this practice, you will create a new footing type and place 
isolated footings, as shown in Figure 1–91. You will also create a 
series of stepped footings by modifying a wall profile and adding 
custom footings.

The steel columns have 
been hidden in this view 
for clarity.

Figure 1–91

Task 1 - Place isolated footings.

1. Open Footings-Syracuse-Suites.rvt from the practice files 
folder.

2. Open the Structural Plans: T.O. FOOTING view.

3. In the Structure tab>Foundation panel, click  (Isolated).

4. In Properties, click  (Edit Type).

5. Duplicate the type and name it 36"x36"x12".

Practice Objectives

• Place isolated footings.

• Modify a wall profile and add stepped footings.

Isolated 
footings

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2020, ASCENT - Center for Technical Knowledge® 1–57



Autodesk Revit 2021 Structure: Autodesk Certified Professional Exam Topics Review

S

6. In the Type Properties dialog box, set the following, as shown 
in Figure 1–92:

• Width: 3'-0"

• Length: 3'-0"

• Thickness: 1'-0"

Figure 1–92

7. Click OK.

8. Zoom into the column at grid B1 and place the isolated 
footing. The isolated footing and wall footing automatically 
join together as shown in Figure 1–93.

Figure 1–93

9. In the Modify | Place Isolated Foundation tab>Multiple panel, 

click  (At Columns). Use a pick window to select all of the 

columns and click  (Finish).

10.Reopen the Default 3D view. 

Before After
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11. There should be an isolated footing under each pier and 
pilaster, as shown in Figure 1–94.

The steel columns were 
hidden in this figure for 
clarity.

Figure 1–94

12.Save the project.

Task 2 - Modify the profile of a wall and add stepped 
footings.

1. Open the Elevations (Building Elevation): North view.

2. Zoom in on the left end of the foundation wall and select the 
wall located between grids 10 and 9, as shown in 
Figure 1–95. 

Hint: You can turn on  (Crop View) and  (Show Crop 
Region) to show less in this view and make it easier to see 
the grids.

Figure 1–95

You will create a 
stepped footing on this 
wall in the next task
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3. In the Modify | Walls tab>Mode panel, click  (Edit 
Profile).

4. Use the Draw and Modify tools to add the stepped profile 
shown in Figure 1–96. The dimensions are for information 
only.

• Make sure to remove the bottom of the walls constraint by 
clicking on the lock or moving the line and clicking 
Remove Constraints in the Error-cannot be ignored 
dialog box.

Figure 1–96

5. Click  (Finish Edit Mode).

6. The wall profile is modified along with the footings, as shown 
in Figure 1–97.

T.O. Footing level

Wall profile
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Figure 1–97

7. Open the Structural Plans: T.O. Footing view and zoom in on 
corner of grid B10. You should be able to see lines that show 
the steps of the footing below.

8. In the Structure tab>Foundation panel, click  (Isolated).

9. In the Modify | Place Isolated Foundation tab>Mode panel, 

click  (Load Family).

10. In the Load Family dialog box, navigate to the practice files 
Families folder and select Angled-Footing.rfa. Click Open.

11. In the Type Selector, select Angled-Footing: 24" x 24" x 
36".

12.Place three footings along the wall, similar to those shown in 
Figure 1–98.

The exact location does 
not matter at this time.

Figure 1–98

Wall

Footings
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13.Return to the North elevation view. The three footings are still 
on the level where they were placed, as shown in 
Figure 1–99.

 
Figure 1–99

14. In the Modify tab>Modify panel, click  (Align) or type AL.

15.Align each Angled Footing to the wall footings, as shown in 
Figure 1–100.

Figure 1–100

16.View the new footings in 3D, as shown in Figure 1–101.

Figure 1–101

In ProcessCompleted

Align to both of 
these locations
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17.(Optional) Modify the nearby wall, columns, and footings to 
match up with the new stepped footings.

18.Save and close the project.
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