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Preface

Autodesk® Inventor® 2022: Advanced Part Modeling is the second in a series of 
guides on the Autodesk® Inventor® software that is published by ASCENT. The 
goal of this guide is to build on the skills acquired in the Autodesk Inventor: 
Introduction to Solid Modeling learning guide by taking users to a higher level of 
productivity when designing part models using the Autodesk Inventor software.

In this guide, the user considers various approaches to part design. Specific 
advanced part modeling techniques covered include bending and unwrapping 
model geometry, multi-body design, advanced lofts, advanced sweeps, coils, 
generative shape design, surface modeling, and freeform modeling. Material 
aimed at increasing efficiency includes iFeatures for frequently used design 
elements, model states and iParts for similar designs, and how to work with 
imported data. The guide also covers some miscellaneous drawing tools, such as 
custom sketched symbols, working with title blocks and borders, and documenting 
iParts.

Topics Covered

• Advanced model appearance options
• 2D and 3D sketching techniques
• Multi-body part modeling
• Advanced geometry creation tools (bend part, unwrap, work features, area 

lofts, sweeps, and coils)
• Generative shape design using Shape Generator
• Creating and editing basic surfaces
• Model states
• iFeatures and iParts
• Freeform modeling
• Importing data from other CAD systems and making edits
• Working with AutoCAD DWG files
• Analysis tools
• Emboss and Decal features
• Advanced Drawing tools (iPart tables, surfaces in drawing views, and custom 

sketched symbols)
• Surface Repair Environment

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2021, ASCENT - Center for Technical Knowledge® ix



Autodesk Inventor 2022: Advanced Part Modeling

S

Prerequisites

• Access to the 2022.0 version of the software, to ensure compatibility with this 
guide. Future software updates that are released by Autodesk may include 
changes that are not reflected in this guide. The practices and files included 
with this guide are not compatible with prior versions (e.g., 2021).

• The material assumes a mastery of Autodesk Inventor basics, as taught in
Autodesk Inventor: Introduction to Solid Modeling. Users should know how to
create and edit parts, use work features, create and annotate drawing views,
etc. The use of Microsoft Excel is required for this guide.

Note on Software Setup

This guide assumes a standard installation of the software using the default 
preferences during installation. Lectures and practices use the standard software 
templates and default options for the Content Libraries.

Students and Educators Can Access Free Autodesk Software 
and Resources

Autodesk challenges you to get started with free educational licenses for 
professional software and creativity apps used by millions of architects, 
engineers, designers, and hobbyists today. Bring Autodesk software into your 
classroom, studio, or workshop to learn, teach, and explore real-world design 
challenges the way professionals do.

Get started today - register at the Autodesk Education Community and download 
one of the many Autodesk software applications available. 

Visit www.autodesk.com/education/home/

Note: Free products are subject to the terms and conditions of the end-user 
license and services agreement that accompanies the software. The software is 
for personal use for education purposes and is not intended for classroom or lab 
use.
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S

In This Guide

The following highlights the key features of this guide. 

Feature Description

Practice Files The Practice Files page includes a link to the practice files and 
instructions on how to download and install them. The practice files 
are required to complete the practices in this guide.

Chapters A chapter consists of the following - Learning Objectives, 
Instructional Content, Practices, Chapter Review Questions, and 
Command Summary. 

• Learning Objectives define the skills you can acquire by learning 
the content provided in the chapter.

• Instructional Content, which begins right after Learning 
Objectives, refers to the descriptive and procedural information 
related to various topics. Each main topic introduces a product 
feature, discusses various aspects of that feature, and provides 
step-by-step procedures on how to use that feature. Where 
relevant, examples, figures, helpful hints, and notes are provided.

• Practice for a topic follows the instructional content. Practices 
enable you to use the software to perform a hands-on review of a 
topic. It is required that you download the practice files (using the 
link found on the Practice Files page) prior to starting the first 
practice.

• Chapter Review Questions, located close to the end of a 
chapter, enable you to test your knowledge of the key concepts 
discussed in the chapter. 

• Command Summary concludes a chapter. It contains a list of the 
software commands that are used throughout the chapter and 
provides information on where the command can be found in the 
software.

Appendices Appendices provide additional information to the main course 
content. It could be in the form of instructional content, practices, 
tables, projects, or skills assessment.
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C h a p t e r

Model Appearance

Modifying the display options or assigning visual appearances can help enhance 
the model’s display for editing or presenting.

Learning Objectives in This Chapter

• Enhance the appearance of the surfaces and edges of a model by assigning visual styles, 
ray tracing, reflections, shadows, and a ground plane to the model.

• Customize and assign lighting styles to control the number, color, and intensity of light 
sources in a model. 

• Manipulate the visual appearance of a material using the in-canvas appearance and texture 
tools.

• Create, assign, and edit existing appearances in the model using the Appearance Browser.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2021, ASCENT - Center for Technical Knowledge® 1–1



Autodesk Inventor 2022: Advanced Part Modeling

S

1.1 Model Appearance: Visual 
Display Options

There are a number of options that can be used to improve a 
model’s visual display. These options are included on the View 
tab>Appearance panel, as shown in Figure 1–1.

Figure 1–1

Visual Style The Visual Style drop-down list contains options that can be 
assigned to provide model surfaces and edges with an 
enhanced appearance. The available visual styles are shown in 
Figure 1–2.

The choice of visual 
style can be dependent 
on whether you are 
working on the model’s 
design or presenting the 
design once it is 
completed. 

Figure 1–2
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Figure 1–3 shows a few of the available visual styles.

Figure 1–3

Incorporating any of the visual styles with the remaining options 
on the Appearance panel (e.g., Shadows, Reflections, etc.) can 
substantially improve the visual appearance of your models.

Ray Tracing The Ray Tracing option enables you to enhance a model’s 
visualization results when using either the Realistic or 
Monochrome visual styles. Ray tracing generates images by 
tracing the path of light through pixels in an image to simulate the 
effect. This technique produces an image that is highly realistic, 
without having to render the model in another environment.

To enable Ray tracing, in the View tab>Appearance panel, click 

 (Ray Tracing). The Ray Tracing Quality window (shown in 
Figure 1–4) opens when Ray Tracing is enabled. 

The render sample 
rates are:
Low: 4 samples/pixel
Draft: 16 samples/pixel
High: 64 samples/pixel

Figure 1–4

Shaded Shaded with 
Edges

Sketch 
Illustration

Wireframe with 
Visible Edges 
Only

Wireframe

Shaded with 
Hidden Edges
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• The Progress bar indicates the rendering percentage and 
time display. 

• Hover the cursor over the title bar of the window to expand it 
to set the quality (Low, Draft, or High) of the image 
generation.

• Click Save, Pause, or Disable at the bottom of the window, 
as required. You can also disable the render by selecting Ray 
Tracing on the ribbon.

• While Ray Tracing is enabled, the Ray Tracing Quality 
window remains open. To optimize visual space in the 
graphics window, it might fade from the display. Hover the 
cursor over the lower right-hand corner of the graphics 
window to display it again.

In the examples shown in Figure 1–5, a model has been 
assigned the Metal-AL-6061 (Polished) color, and the visual 
styles settings have been manipulated to vary the displayed 
image.

Figure 1–5

Realistic visual 
style with Ray 
Tracing disabled

Realistic visual 
style with Ray 
Tracing enabled
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Ground Plane In the Appearance panel, the  (Ground Plane) option enables 
you to toggle the display of a plane that represents the ground. 
The ground plane can be included to help represent the up 
direction of the model. It is also used in conjunction with 
shadows and reflection to set realistic visual display settings. 
Consider the following about the ground plane:

• The ground plane is parallel with the Origin’s XZ plane.

• The ground plane is tied to the model. If you rotate the model, 
the ground plane rotates with it.

• When viewing the ground plane from the top, a plane with a 
grid is displayed. When viewing the model from beneath the 
plane, only the exterior outline of the plane is displayed.

• To customize the ground plane, in the View tab>Appearance 
panel, in the Ground Plane drop-down list, select Settings. 
This option enables you to relocate the X, Y, and Z locations, 
its appearance, grid display, and reflection settings.

• All settings for the ground plane are stored with the document 
only, and do not affect other models in the current session.

An example of a model with its ground plane displayed is shown 
in Figure 1–6.

The ground plane does 
not need to be displayed 
in order for ground 
shadows and reflections 
to be used.

Figure 1–6
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Shadows The Shadows drop-down list ( ) enables you to control the 
shadows that are assigned in a model for enhanced model 
visualization. Shadows can be enabled so they display on the 
ground, on the object, or so that ambient shadows are used. 
Shadows can be enabled individually or in any combination of 
the three shadow types. Figure 1–7 displays a model with the 
various shadowing effects.

Figure 1–7

To customize shadow settings, in the Shadows ( ) drop-down 
list, select Settings to access the active Lighting Style. 
Customize the shadow values in the Shadows tab for the active 
Lighting Style.

Reflections Reflections can be cast on the ground plane by enabling 

(Reflections) in the Appearance panel on the View tab. 
Shadows reflect the visual style that is set in the model. By 
changing the Z location of the ground plane, the resulting 
reflection is varied. The Settings option in the Reflection 
drop-down list enables you to customize the Ground Plane which 
affects reflections.

Note that the ground plane does not need to be displayed in 
order for ground reflections to be assigned in the model.

Ambient 
Shadows

Ground ShadowsAll Shadows

Object Shadows
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Perspective and
Orthographic

Views

Traditional mechanical drawings show parts in orthographic 
(parallel) views, where parallel edges on the part display parallel 
in the drawing. Perspective views display the way that the eye 
sees, where parallel edges seem to converge at a vanishing 
point, as shown in Figure 1–8. To change to a perspective view, 
select the View tab. In the Appearance panel, expand 

(Orthographic) and click  (Perspective).

While in a perspective 
view, you can zoom, 
pan, and rotate, but the 
results may differ 
slightly than that in an 
Orthographic view. 
Refer to the “About 
Perspective Views” Help 
topic for more 
information on view 
manipulation for 
Perspective views.

Figure 1–8

The  (Perspective with Ortho Faces) option enables you to 
view the model in perspective view while the model is in a 3D 
orientation and in orthographic view when in a 2D view.

Perspective ViewOrthographic View
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1.2 Model Appearance: Lighting
The appearance of parts can be changed by adjusting the 
lighting style. In a lighting style, you can control the number, 
color, and intensity of light sources for a file, as well as assign 
image-based lighting and shadows. Use the Lighting Style 
drop-down list (shown in Figure 1–9) to quickly assign a lighting 
style as an alternative to the Style and Standard Editor. 

Lighting styles can be 
set in a part, assembly, 
or presentation.

For image-based 
lighting styles, use the 
Perspective orientation 
to improve realism.

Figure 1–9

Many styles assign an image, as shown in the Old Warehouse 
and Empty Lab styles shown in Figure 1–10. Models can be 
positioned relative to the image to enhance model realism.

Figure 1–10
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If a new lighting style is required, you can use either of the 
following techniques to access the Style and Standard Editor:

• In the View tab>Appearance panel, in the Lighting drop-down 
list, select Settings.

• In the Manage tab>Styles and Standards panel, click 

(Styles Editor).

The Style and Standard Editor opens as shown in Figure 1–11. 

Figure 1–11

Select a lighting style to edit or create a new style. To create a 
new style, right-click on an existing style and select New Style. 
The selected style is copied and can be used as a starting point 
for the creation of the new style. 
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The table below describes the lighting style settings.

Edits you make in the dialog box are dynamically displayed on 
the part. You must save the edits to preserve them. Edits are 
saved to the active lighting style in the file.

Tabs Description

Environment tab

Image Based 
Lighting

Set the image-based lighting effects for the active 
light style. This tab is only available if an image has 
been assigned to the lighting style. To display the 
image in the actual scene, select Display Scene 
Image. Without this option enabled, the image is 
not displayed; however, by toggling this option on 
and off, you can control the image-based lighting 
effect without losing all of the specified settings. 
You can also adjust its exposure, rotation, and 
scale.

Lighting tab

Light# tabs Select a light number tab to activate it for editing. 

Click  on each tab to toggle the specific light 
source on or off.

Standard 
Light Settings

Control the horizontal/vertical position of the active 
light source using the sliders that surround the 
image of the light. You can also select the color and 
control the brightness of the light source. Using the 
two Relative movement options, you can specify 

that the light is fixed to the view’s camera ( ) or 
that the light maintains a fixed direction relative to 

the Viewcube ( ).

All Lights Control the brightness and ambience of the light 
sources for all standard lights. Use the Brightness 
slider to control the light intensity and use the 
Ambience slider to set the contrast between lit and 
unlit areas in the scene.

Shadows tab

Shadow 
Settings

Set the lighting style’s shadow setting by selecting 
from a predefined list of shadow directions. You can 
also specify the shadow’s density, softness, and 
ambient shadow intensity.am
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1.3 Model Appearance: Color 
and Texture

Colors and textures can be added to a model to further enhance 
its visualization. Color and texture are combined within the 
appearance definition of a material. When a material is assigned, 
the visual appearance specified for that material is assigned to 
the model. The Materials and Appearance Override drop-down 
lists in the Quick Access Toolbar display the current material and 
its appearance, as shown in Figure 1–12.

Figure 1–12

To assign a different appearance to the model while maintaining 
the material setting and therefore its iProperty data, select an 
alternate material in the Appearance Override drop-down list, as 
shown in Figure 1–13.

Figure 1–13

Materials
Appearance Override 

Appearance Override
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The predefined list of appearances provided in the Appearance 
Override drop-down list are pulled from provided libraries. By 
default, the Inventor Material Library is set as the active library. 
To switch between libraries in the drop-down list, select an 
alternate library name, as shown in Figure 1–14.

The default library can 
be set in the Project 
File.

Figure 1–14

To quickly manipulate the assigned appearance, you can use 
the in-canvas tools.

In-Canvas Appearance and Texture Tools

The in-canvas appearance and texture tools provide you with a 
convenient way to change the color of an appearance or the 
texture mapping on the model. The tools are provided in a 
mini-toolbar and the icons can be used directly on the model.

How To: Edit the Existing Appearance Using the 
In-Canvas Tools

1. In the Tools tab>Material and Appearance panel, click 

(Adjust). The Appearance mini-toolbar opens as shown 
in Figure 1–15.

Figure 1–15

2. Using the model, select the appearance that is to be edited. 
You can select directly on the model when the cursor 

displays as the eyedropper ( ), or you can select the 
appearance from the Appearances drop-down list in the 
mini-toolbar. 
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• When using the cursor, if you want to edit the color of the 
entire model, ensure that you select the entire model.

• To change only selected faces, surfaces, bodies, or 
features, select them individually. Use the Select Other 
drop-down list to select the required option. 

• Selecting the appearance in the Appearances drop-down 
list enables you to first edit the Appearance and then 
apply it to the model.

3. Select the method for defining the color. 

• Defining the color as a red, green, and blue value (RGB 
Values) is the default option. 

• Select the RGB Values drop-down list and select HSL 
Values to define the color with a hue, saturation, and 
lightness value.

4. For either the RGB or HSL Values options, use the color 
wheel to define its values. 

• Drag the line around its perimeter to change the value. 

• To refine the color, activate and drag the square node on 
the internal diamond shape at the center of the color 
wheel. 

• If the appearance was selected directly from the model, it 
will update as you are changing the color. 

5. If you selected the appearance from the drop-down list, you 
are required to assign it to the model. Using the cursor, now 

displayed as a paint can ( ), select the model or individual 
faces, surfaces, bodies, or features, to assign the edited 
appearance.

6. If the Appearance has a texture assigned to it, you can scale 

and rotate the texture using the  and  icons that 
display once the model or individual faces, surfaces, bodies, 
or features are selected. 

The scale and rotate 
icons are displayed for 
non-textured 
appearances. 
Manipulating these 
icons will not affect the 
overall appearance.

• Hover the cursor over the icons until they are active 
(yellow) and then press and hold the mouse button to 
scale and rotate. 

7. If the Appearance has a texture assigned to it, you can vary 
how it is mapped to the surface of the model. Expand the 

 drop-down list and select a mapping option. 

• By default, Automatic is used and generally provides a 
good representation of the texture on the model. 

• Hovering the cursor over the other mapping options 
displays them in the model.

8. Click  to complete the edit and close the mini-toolbar.
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Once an appearance is adjusted using the in-canvas tools, a 
new appearance is created that has (1) appended to the end of 
the name. For example, if you were adjusting the Red 
appearance, the adjusted appearance would be called Red(1).

Appearance Browser

The Appearance Browser (shown in Figure 1–16) is used as 
an alternative to the Appearance Override drop-down list to 
assign appearances. It can also be used to create new 

appearances. The  (Change Your View) drop-down list can 
be used to customize the display of the Appearance Browser 
areas. For example, it can show whether the appearances 
display as detailed lists or as thumbnail images.

Figure 1–16

The Appearance Browser is divided into the following three 
areas:

Document 
Appearances area

Library list

Appearance 
area
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• Document Appearances area - This area includes all 
appearances that have been assigned to the model. 

• Library list - The library list enables you to select the libraries 
where you want to look for different appearances. The 
Favorites node enables you to quickly access any of the 
appearances from the three libraries that you have marked 
as Favorites.

• Appearance area - Once a library is expanded and a group 
type selected, its appearances are displayed in the 
Appearance area. Using this area, appearances can be 
added to the Document Appearances area for use.

Create a New
Appearance

How To: Use the Appearance Browser to Create a 
New Appearance 

1. In the Tools tab>Material and Appearance panel, click 

(Appearance). The Appearance Browser opens as 
shown in Figure 1–17. The current file only has one 
appearance that was assigned to it (Default), as shown in the 
Document Appearances area, and the Inventor Material 
Library is selected. If an appearance override was assigned, 
it would also be displayed here. 

Figure 1–17
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2. Right-click on an existing appearance in the Document 
Appearances area and select Duplicate to create its copy. 
The selected appearance should be one that closely 
resembles the settings that you want as a new appearance. 

Alternatively, click  at the bottom of the Appearance 
Browser and select a type to start a new appearance.

3. Select the default name, right-click on it, and select Rename. 
Enter a new name for the appearance. 

4. Right-click on the new appearance and select Edit to open 
the Appearance Editor, similar to that shown in Figure 1–18. 
Depending on the material type, the options and settings 
vary.

Figure 1–18

5. Define the appearance, as required.

• Select in the Color field to access the Color dialog box to 
select or customize a new color. 

• Select in the Image field to import a texture for the 
appearance. 
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• Change the settings of the Image Fade, Glossiness, and 
Highlights to customize the appearance of the texture.

• Use other options in the Appearance Editor to further 
customize the new appearance by adding reflectivity, 
transparency, bump maps, self illumination, etc.

6. Click OK to complete the creation of the new appearance. 
The thumbnail image in the Document Appearances area 
updates to reflect the changes that were made in the 
Appearance Editor.

To edit an existing appearance, right-click on the appearance 
name in the Document Appearances area of the Appearance 
Browser and select Edit. Edit the options, as required, to reflect 
the required change.

Textures Textures are files that can be added to any appearance. Bump 
maps enable you to further control the display of an image by 
assigning a bumpiness value. Texture images are assigned in 
the Generic node while bump maps are assigned in the Bump 
node. Similarly, maps can be assigned to other nodes. 

To assign an image, select in the Image field for the node and 
use the Material Editor Open File to browse to and select an 
image.

To modify the placement of the image, right-click on the Image 
field and select Edit Image. The Texture Editor opens and you 
can refine the image’s position, rotation, scale, and repeat and 
(in the case of a bump map) vary the amount of bumpiness.

Assign an
Appearance

How To: Use the Appearance Browser to Assign an 
Appearance to the Model 

Alternatively, you can 
assign the new 
appearance using the 
Material Override 
drop-down list in the 
Quick Access Toolbar. 
Once assigned, the 
appearance is 
automatically added to 
the Document 
Appearances area.

1. In the Tools tab>Material and Appearance panel, click 

(Appearance).
2. To assign a new appearance, select the entire model or 

individual surfaces on the model, right-click on the 
appearance thumbnail in the Document Appearances area 
and select Assign to Selection. 

• To help identify what is being selected in the model, 
before selecting, hover the cursor over the model so that 
the preview displays the entire model (dashed lines) or 
individual surfaces (solid lines).

3. Click  to close the Appearance Browser.
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Adding
Appearances to

the Document

How To: Use the Appearance Browser to Add a 
Material from a Library to the Document 
Appearances Area

1. In the Tools tab>Material and Appearance panel, click 

(Appearance). 
2. Expand the appropriate library in the Library list. 
3. Select an appearance type. The list of appearances 

associated with the selected type display in the Appearance 
area on the right side of the Appearance Browser.

4. Right-click an appearance and select Add To>Document 
Materials to add it to the Document Appearances area for 
use in the model.

To display the model so that any of the image’s texturing settings 
are consistently displayed, set the Visual Style to Realistic. If 
not, only the color of the appearance might display on the model.
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Practice 1a Create a Lighting Style

In this practice, you will create a new lighting style and assign it 
for use with a part file. The part is shown in Figure 1–19.

Figure 1–19

Task 1 - Open a part file and create a new lighting style.

1. In the Get Started tab>Launch panel, click (Projects) to 
open the Projects dialog box. Project files identify folders that 
contain the required models.

This project file is used 
for the entire learning 
guide.

2. Click Browse. In the practice files folder, select Advanced 
Part.ipj. Click Open. The Projects dialog box updates and a 
checkmark displays next to the new project name, indicating 
that it is the active project. The project file tells Autodesk 
Inventor where your files are stored. Click Done.

3. Open handle.ipt.

4. In the Manage tab>Styles and Standards panel, click 

(Styles Editor). The Style and Standard Editor dialog box 
opens.

5. Expand the Lighting branch and select Two Lights.

Practice Objectives

• Create a new lighting style based on an existing style.

• Edit a lighting style to change its ambiance setting and include multiple 
colored lights.

• Change the lighting style that is applied to the model using the Styles 
and Standards Editor and the options in the Appearance panel.
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6. Click New. The New Local Style dialog box opens.

7. Enter handle in the Name field and click OK. The handle 
style is now listed in the Lighting branch.

8. Double-click on handle in the list to activate it. The active 
style is bold in the list and is applied to the model.

9. Move the Ambience slider to increase the amount of ambient 
light on the screen for all lights. Note how the model updates 
as you move the slider.

10.Return the Ambience slider to approximately the middle of 
the scale.

11. In the Standard Lights area of the Lighting tab, ensure that 

the Light 1 tab is selected and that the  (yellow light bulb) 
icon is active. This represents the first direct light.

12.Move the vertical slider on the right side of the image to the 
top and the slider on the bottom to the left side to place the 
light.

13.Click the Color icon located above the Brightness slider. 
Select one of the blue colors from the color palette. Click OK. 
Note the effect on the part.

14.Select the Light 2 tab to activate it. Ensure that the  icon is 
enabled (yellow). Select it, if not. The blue light you created in 
the last step will now have less influence on the part. Change 
the color of the second light to red, and move the sliders to 
the bottom and right positions to place this light.

15.Click Save and Close. Note the effect on the part.

16.Rotate the part. You will see different shades and colors on 
the part, depending on where you placed the lights. 

Task 2 - Manipulate the appearance of the model.

1. Select the View tab.

2. In the Appearance panel, note that the handle light style is 
currently active. In the Lighting Style drop-down list, select 
Two Lights. Note how the model updates to reflect the 
settings in this style.

3. Select some of the various options in the Visual Style 
drop-down list to manipulate the model’s appearance. Leave 
the style set to Shaded with Edges.
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4. In the Lighting Style drop-down list, select Empty Lab.

5. The default scale of the model relative to the image is 
incorrect. In the Lighting Style drop-down list, select 
Settings. In the Image Based Lighting area in the 
Environment tab, reduce the Scale to approximately 15%. 
Click Save and Close.

6. In the Orthographic drop-down list, select Perspective to 
obtain a more realistic image.

7. Zoom in and orient the model. The Shaded with Edges 
visual style is not very realistic for product presentation. 
Change the visual style to Realistic.

8. Select a darker color in the Appearance Override drop-down 
list in the Quick Access Toolbar, shown in Figure 1–20.

Figure 1–20

9. The model should display similar to that shown in 
Figure 1–21.

Figure 1–21

10.Save the part and close the window.

Appearance Override list
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Practice 1b Working with Appearances

In this practice, you will assign a material to a model and then 
override its visual appearance. You will apply appearances to the 
entire model as well as individual surfaces. The final model is 
shown in Figure 1–22. 

Figure 1–22

Task 1 - Open a model and assign a material. 

1. Open bearing_journal.ipt. The part is currently assigned the 
Generic material and visual appearance, as shown in the 
Material and Appearance Override drop-down lists in the 
Quick Access Toolbar in Figure 1–23.

Figure 1–23

Practice Objectives

• Override the visual appearance of a material.

• Create, edit, and assign appearances to a model using the Appearance 
Browser and the Appearance Override drop-down list.

Appearance Override list

Material list
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2. In the Quick Access Toolbar, in the Material drop-down list, 
set the material to Stainless Steel. The visual appearance is 
set as Semi-Polished which is the default setting for the 
Stainless Steel material. The model displays as shown in 
Figure 1–24.

Figure 1–24

Task 2 - Assign and new visual appearance and edit it. 

1. In the Quick Access Toolbar, in the Appearance Override 
drop-down list, set the color to Yellow. The visual 
appearance of the model changes to yellow, as shown in 
Figure 1–25, but the material remains Stainless Steel.

Figure 1–25

2. In the Tools tab>Material and Appearance panel, click 

(Adjust) to open the appearance mini-toolbar.

The model’s color is 
now Semi-Polished

The model’s color is 
now Yellow
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3. Hold <Ctrl> and select the two surfaces shown in 
Figure 1–26.

Figure 1–26

4. Maintain the RGB Values setting and use the color wheel to 
define the values. Drag the line around its perimeter to 
change the value to red. Because the surfaces were 
preselected, the surfaces update as you change the RGB 
value.

5. Click  to complete the change and close the mini-toolbar. 
The model should display similar to that shown in 
Figure 1–27.

Figure 1–27

Select these two 
cylindrical surfaces to 
assign new colors

The model’s color is 
now Yellow and the 
cylindrical surfaces 
are red
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6. In the Appearance Override drop-down list, select Rust. 
The model should display similar to that shown in 
Figure 1–28. Note that the surface overrides on the internal 
surfaces that were changed to red are maintained and the 
Rust appearance is applied to the rest of the model. The Rust 
appearance was created using a texture image.

Figure 1–28

7. In the Tools tab>Material and Appearance panel, click 

(Adjust) to open the appearance mini-toolbar.

8. Hover the cursor over the model so that its entire boundary is 
highlighted in dashed red lines and click to select the model. 
If required, use the Select Other drop-down list to select the 
solid in order to highlight all the geometry. This enables you 
to edit the Rust appearance on the entire model.

9. Try and change the color of the appearance. Note how it 
does not change because this appearance is using a texture 
image.

10.Click  to open the drop-down list and roll the cursor 
over each of the mapping options. By default, Automatic is 
used and it provides a good representation of the rust texture 
on the model. Depending on the surface and model shapes 
being assigned a textured appearance the other options 
might provide better representations.

11. Hover the mouse over the  icon until the cursor changes to 

the  icon. This indicates that you can now scale the 
texture. Drag the cursor to scale the texture.

The model is now 
displayed as Rust and 
the cylindrical surfaces 
are still red
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12.Hover the cursor over the  icon until the cursor 

changes to the  icon indicating that you can now 
rotate the texture. Drag the cursor to rotate the texture.

13.Click  to cancel the edit and close the mini-toolbar. The 
original texture scale and rotation is maintained.

Task 3 - Create a new appearance and assign it to the 
model. 

1. In the Tools tab>Material and Appearance panel, click 

(Appearance) to open the Appearance Browser. 

Alternatively, you can also click  in the Quick Access 
Toolbar. The Appearance Browser displays as shown in 
Figure 1–29.

The  (Change Your 
View) drop-down list can 
be used to customize 
the display of the 
Appearance Browser. 
For example, it can 
show whether the 
appearances display as 
a detailed list or as 
thumbnail images. 

Figure 1–29
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Note that there are currently five appearances listed in the 
Document Appearances area. These correspond to all of the 
appearances that you have assigned to the model. Generic 
was the appearance that was set when the file was opened, 
Semi-Polished was used when the material was set to 
Stainless Steel, Yellow was used to override the visual 
appearance of the Stainless Steel Material, and Yellow(1) 
represents the edits that were made using the mini-toolbar to 
create the red color. Finally, Rust was the final override 
material that was used. Only appearances that have been 
used in the model are shown here.

2. Right-click on Yellow(1) and select Rename. Enter MyRed 
as the new name.

3. Right-click on Generic and select Duplicate. This creates a 
copy of the Generic appearance that you can use it as the 
base for a new appearance.

4. Right-click on Generic(1) and select Rename. Enter 
MyColor as the new name for the duplicated appearance.

5. Double-click on MyColor to open the Appearance Editor.

6. Select in the Color field and assign a new color to the 
appearance using the Color dialog box. Increase the 
Glossiness value and change the Highlights to Metallic. 
Additional settings can be made using other nodes in the 
Appearance Editor to further customize the appearance.

7. Click OK to complete the edit and close the Appearance 
Editor.

8. Hover the cursor over the model so that its entire boundary is 
highlighted in dashed lines and click to select the model.

9. In the Appearance Browser, right-click on MyColor and 
select Assign to Selection to assign the new appearance to 
the model. Note that the red surface overrides are still 
maintained.

10.Click  to close the Appearance Browser.am
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Task 4 - Clear appearance overrides. 

1. In the Tools tab>Material and Appearance panel, click 

(Clear) to open the mini-toolbar.

2. Press and hold <Ctrl> and select the two surfaces that were 
assigned the MyRed appearance.

3. Click  to clear the appearance override on these 
surfaces. Note that the entire model now has the MyColor 
appearance assigned.

4. In the Tools tab>Material and Appearance panel, click 

(Clear) to open the mini-toolbar again.

5. Click Select All in mini-toolbar and click  to clear all 
overrides in the model. This returns the visual appearance 
back to Semi-Polished, which was assigned with the 
Stainless Steel material.

Task 5 - Add an appearance from the Inventor Material 
Library to the model. 

1. In the Tools tab>Material and Appearance panel, click 

(Appearance) to open the Appearance Browser.

2. In the lower portion of the Appearance Browser, select the 

 (Home) drop-down list and select Inventor 
Material Library to display a list of materials in this library. 
You can also expand the Home node and select Inventor 
Material Library.

3. Further expand the Inventor Material Library folder, as 
shown in Figure 1–30. 
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Figure 1–30

4. Select Metal/Steel to display the list of appearances in the 
Metal/Steel category. 

5. Right-click the Machined 02 appearance and select Add 
to>Document Materials.

6. Select the model and assign the Machined 02 appearance to 
the selection. The model updates as shown in Figure 1–31.

Figure 1–31

7. Close the Appearance Browser.

The model is now 
displayed with the 
Machined 02 material

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2021, ASCENT - Center for Technical Knowledge® 1–29



Autodesk Inventor 2022: Advanced Part Modeling

S

The additional material 
libraries can also be 
expanded and used to 
access other 
appearances. By 
default, their 
appearances are not 
listed in the appearance 
override drop-down list 
so they must be added 
through the Appearance 
Browser.

The appearance could also have been assigned by selecting 
it and using the Appearance Override drop-down list to select 
the Machined 02 appearance. In this case, once selected it 
would have been assigned and added to the Document 
Appearances area. This is an alternative method to adding 
materials using the Appearance Browser. The benefit of the 
Appearance Browser is that you can review the thumbnail 
images and copy existing materials to use as a base for new 
appearances.

8. Save the part and close the window.
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Chapter Review Questions

1. Which of the following Appearance tools are available when 
the Visual Style for the model is set as Shaded? (Select all 
that apply.)

a. Shadows

b. Reflections

c. Lights

d. Ground Plane

e. Ray Tracing

2. The ground plane must be enabled (displayed) for the 
shadows and ground reflections to be visible in the model.

a. True

b. False

3. Which of the following statements are true regarding lighting 
styles. (Select all that apply.)

a. An Image-based lighting style enables you to use a 
predefined background image in the style.

b. Multiple standard lights can be combined in a single 
lighting style.

c. Multiple lighting styles can be applied at one time.

d. Shadow settings are controlled in a lighting style.

4. The following icons display when working with the in-canvas 
appearance and texture tool. Which icon enables you to 
scale a texture in a material?

a.

b.

c.

d.
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5. Which of the following statements are true regarding the 
Appearance Browser dialog box shown in Figure 1–32? 
(Select all that apply.)

Figure 1–32

a. Four appearances have been applied to the model.

b. The Favorites list is currently being displayed in the 
Appearance area.

c. The Metal category in the Inventor Material Library is 
currently active.

d. The Copper - Polished material is the currently assigned 
material to the model.
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Command Summary

Button Command Location
Adjust (color) • Ribbon: Tools tab>Appearance panel

Appearance 
(Browser)

• Ribbon: Tools tab>Appearance panel

N/A Appearance 
Override

• Quick Access Toolbar

• Appearance Browser

Clear (color) • Ribbon: Tools tab>Appearance panel

Constraint 
Inference Scope

• Ribbon: Sketch tab>expanded 
Constrain panel

Constraint 
Settings

• Ribbon: Sketch tab>expanded 
Constrain panel

Construction • Ribbon: Sketch tab>Format panel

Ground Plane • Ribbon: View tab>Appearance panel

Hide All 
Constraints

• Sketch Status Bar

• Keyboard: Toggle with <F8> and <F9>

N/A Lighting Styles • Ribbon: View tab>Appearance panel

Orthographic • Ribbon: View tab>Appearance panel

Perspective • Ribbon: View tab>Appearance panel

Perspective with 
Ortho Faces

• Ribbon: View tab>Appearance panel

Precise Input • Ribbon: Sketch tab>expanded Create 
panel

Ray Tracing • Ribbon: View tab>Appearance panel

Reflections • Ribbon: View tab>Appearance panel

Shadows • Ribbon: View tab>Appearance panel

N/A Share Sketch • Context Menu: in Model browser with 
sketch name selected

Show All Degrees 
of Freedom

• Sketch Status Bar

Show Constraints • Ribbon: Sketch tab>Constrain panel

Styles Editor 
(lighting)

• Ribbon: Manage tab>Styles and 
Standards panel

Visual Style • Ribbon: View tab>Appearance panel
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