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Preface

Autodesk® Vault Professional 2022: Data Management for Autodesk® Inventor®
Users introduces the Autodesk Vault Professional 2022 software to Autodesk
Inventor users. This guide is intended for Autodesk Inventor users who need to
access their design files from the Autodesk Vault software. It provides an
introduction to the Autodesk Vault Professional software and focuses on Autodesk
Vault’s features for managing design projects with the Autodesk Inventor software
from a user’s perspective.

You can use the Autodesk Vault Professional 2022 software and should use the
Autodesk Inventor 2022 software to complete the exercises in this guide. Note
that this guide does not cover administrative functionality. Hands-on exercises are
included to reinforce how to manage the design workflow process using the
Autodesk Vault Professional software. Included with this guide is a training Vault
that can be used alongside a production Vault, to ensure that both Vaults can be
accessed from the Autodesk Vault software.

Topics Covered

* Introduction to Autodesk Vault features

* Using the Autodesk Vault client

« Searching the Vault

* Working with non-CAD files in the Vault

«  Working with Inventor files in the Vault

» Customizing the user interface

« Data management and reusing design data
» ltems and bills of materials

+ Change management

© 2021, ASCENT - Center for Technical Knowledge® vii
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Prerequisites

* Access to the 2022.0 version of the software, to ensure compatibility with this
guide. Future software updates that are released by Autodesk may include
changes that are not reflected in this guide. The practices and files included
with this guide might not be compatible with prior versions (e.g., 2021).

* Good working knowledge of the Autodesk Inventor software.
Note on Software Setup

This guide assumes a standard installation of the software using the default
preferences during installation. Lectures and practices use the standard software
templates and default options for the Content Libraries.

Students and Educators Can Access Free Autodesk Software
and Resources

Autodesk challenges you to get started with free educational licenses for
professional software and creativity apps used by millions of architects,
engineers, designers, and hobbyists today. Bring Autodesk software into your
classroom, studio, or workshop to learn, teach, and explore real-world design
challenges the way professionals do.

Get started today - register at the Autodesk Education Community and download
one of the many Autodesk software applications available.

Visit www.autodesk.com/education/home/

Note: Free products are subject to the terms and conditions of the end-user
license and services agreement that accompanies the software. The software is
for personal use for education purposes and is not intended for classroom or lab
use.

viii
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Preface

Lead Contributor: Barb Nash

With extensive experience in project management and eLearning development,
Barb's primary responsibilities include the design, development, and project
management of courseware for Product Lifecycle Management (PLM) products
such as Autodesk Vault and Autodesk Fusion 360 Manage. Her work also
involves the development of custom training that is designed and configured to a
company’s specific environment, processes, and roles.

Prior to joining ASCENT in 2005, Barb managed a technical support team for
10 years supporting CAD and PDM/PLM software.

Barb is a Professional Engineer and holds a degree in Aerospace Engineering.
She is also a certified Project Management Professional (PMP) and trained in
Instructional Design.

Barb Nash has been the Lead Contributor for Autodesk Vault Professional: Data
Management for Autodesk Inventor Users since its initial release in 2013.
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The following highlights the key features of this guide.

Feature

Description

Practice Files

The Practice Files page includes a link to the practice files and
instructions on how to download and install them. The practice files
are required to complete the practices in this guide.

Chapters

A chapter consists of the following - Learning Objectives,
Instructional Content, Practices, Chapter Review Questions, and
Command Summary.

Learning Objectives define the skills you can acquire by learning
the content provided in the chapter.

Instructional Content, which begins right after Learning
Objectives, refers to the descriptive and procedural information
related to various topics. Each main topic introduces a product
feature, discusses various aspects of that feature, and provides
step-by-step procedures on how to use that feature. Where
relevant, examples, figures, helpful hints, and notes are provided.

Practice for a topic follows the instructional content. Practices
enable you to use the software to perform a hands-on review of a
topic. It is required that you download the practice files (using the
link found on the Practice Files page) prior to starting the first
practice.

Chapter Review Questions, located close to the end of a
chapter, enable you to test your knowledge of the key concepts
discussed in the chapter.

Command Summary concludes a chapter. It contains a list of the
software commands that are used throughout the chapter and
provides information on where the command can be found in the
software.

In This Guide

© 2021, ASCENT - Center for Technical Knowledge®
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Software Setup

Attach the Database

1. From the Start menu, select Autodesk>Autodesk Data Management>
Autodesk Data Management Server Console 2022.

2. Log in as Administrator without a password.

3. Select Vaults, as shown below:

= @ ASCENT-JMAC-PC

= B3
[i] Vault

7] Libraries

4. Select Actions>Attach>Advanced tab to attach the Vault. Fill in the following
details, as follows:

- Data File: C:\Program Files(86)\Microsoft SQL Server\MSSQL14.
AUTODESKVAULT\MSSQL\DATA\Vault_Training.mdf
or
C:\Program Files\Microsoft SQL Server\lMSSQL14.AUTODESKVAULT\
MSSQL\DATA\Vault_Training.mdf

* Log File: Filled in automatically
* File Store: C:\Vault Data Management Practice Files\Vault_Training
* Vault Name: Filled in automatically

5. Click OK. The Attach Progress dialog box opens.

6. Inthe Autodesk Data Management Server Console dialog box, click OK when
prompted that the vault was attached successfully.

7. Select the Vault_Training vault.
8. Select Actions>Content Indexing Service.

9. In the Content Indexing Service dialog box, select Yes, enable the Content
Indexing Service.

© 2021, ASCENT - Center for Technical Knowledge® XV
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10.Click OK.

11. Remain in the Autodesk Data Management Server Console to create users.

Set Up Users

1.

2

If the Autodesk Data Management Server Console is not open, from the Start
menu, select Autodesk>Autodesk Data Management>Autodesk Data
Management Server Console 2022 and log in as Administrator. No password
is required. Select Tools>Administration and select the Security tab.

Click Manage Access....

Ensure the Users tab is active and select New.
Set the Display Name to user1.

Set the First Name to user1.

Click Accounts... and select the Vault Account option. Leave the password
blank and click OK.

Click Roles... and select Administrator, Document Editor (Level 2),
Change Order Editor (Level 2), and Item Editor (Level 2). Click OK.

Click Vaults... and select Vault_Training. Click OK. The New User dialog box
should display as shown below.

¢ New User Profile ht

£ user]

Display Name user]

Email Alias

Profile Attributes

First Name user]

Last Name

Accounts... Vault Account

Roles... Administrator,Change Order Editor (Level 2),Document Editor (Lt

| Vaults... Vault_Training

Groups...

Enable user

OK Cancel Help

9. Click OK.

XVi
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Software Setup

10. Create another user with a Display Name and First Name of user2 using the
same roles and vault as defined for user1.

11. Click OK. Close the dialog boxes.
12.Close the Autodesk Data Management Server Console.

13.Log in to Autodesk Vault client, Vault_Training vault as Administrator, no
password.

14.For Vault Revision Table. click Tools>Administration>Vault Settings. In the
Vault Settings dialog box, select the Behaviors tab and click Revision Table.

15.In the Revision Table Settings dialog box, select the Enable Revision Table
Control checkbox to enable the Vault Revision Table Functionality, and select
Yes to load the suggested settings. Click OK to close the Revision Table
Settings dialog box, then click Close to close the Vault Settings dialog box.

16.Select Tools>Administration>Global Settings.

17.Select the Change Orders tab and then click Define. In the Routing window,
click Edit to edit the Default Routing. Select user1 and add all of the available
roles to user1, as shown below.

¥ Edit Roles - user1 X

Available Roles:

Selected Roles:

Rele Name | Role Name
s Approver  EE

Change Administrator Change Administrator

| Change Requestor Change Requestor

| Notification User Notification User
Responsible Engineer Responsible Engineer

= | <- Remove ;

Reviewer Reviewer

18.Close the dialog boxes.

© 2021, ASCENT - Center for Technical Knowledge® Xvii
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Set Up Duplicate Search

1. Select Tools>Administration>Global Settings. In the Integrations tab, select
the Enable Job Server option and click Close.

2. Select Tools>Administration>Vault Settings.

3. Inthe Files tab, click Configure... in the Duplicate Search Settings section, as
shown below.

¥ Vault Settings >

Files Visualization Behaviors Iterns  Change Orders Collaborate Custom Objects

File Names Duplicates Options

o [] Enforce Unique File Names Find Duplicate Names

o—

Disable Check In of Design Files

Working Folder

E Define Working Folder Options Define

Duplicate Search Settings

[ Specify folders for duplicate parts search. | Configure... |

4. Ensure that the Enable Duplicate Search option is selected.

5. Click iﬂi and select the $ folder, then click OK to start indexing.

6. Close the Vault Settings dialog box.
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Chapter

Introduction to Autodesk
Vault

Autodesk® Vault is Product Lifecycle Management (PLM) software that enables
you to secure, consolidate, and organize all product information for easy
reference, sharing, and reuse. Autodesk Vault users can store and search both
non-CAD data (such as Microsoft® Word and Microsoft® Excel® files) and CAD
data (such as Autodesk® Inventor®, AutoCAD®, and DWF files). In this chapter,
you learn about the features in the Autodesk Vault software to manage your
Autodesk Inventor designs.

Learning Objectives in This Chapter

Describe the key features and benefits of the Autodesk Vault software.
Differentiate between terms used in the Autodesk Vault software.
 Identify the ways that Autodesk Vault functions can be accessed.
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1.1 Autodesk Vault Features

Autodesk Vault is Product Lifecycle Management (PLM) software
that manages the life of a design from conception to retirement.
The files associated with the design are tracked and managed.
The software also manages who is permitted to work with files at
specific times.

The Autodesk Vault software’s capabilities include:

Central repository for data.

Security access control to data.

Protection against accidentally overwriting design data.
Object relationship management.

Tracks revision history.

Search and view tools to easily find and view design data.
Manages CAD and non-CAD data.

Direct CAD Integration with Autodesk CAD products:
Autodesk Inventor, AutoCAD, AutoCAD Mechanical,
Autodesk® Civil 3D®, and many more.

Copy Design tool for copying an entire design, including all
related files, and maintaining their relationships to each other
in the new design.

Change Management functionality.

Items/Bill of Materials Management.

This learning guide focuses on the core functionality of the
Autodesk Vault Professional software from a user’s perspective.

1-2
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Object

File

1.2 Terms and Definitions

Before working with the software, it is recommended to become
familiar with the fundamental terminology of the Autodesk Vault
software. This section describes some of the commonly used
Autodesk Vault terminology.

Object is a generic term used to describe anything stored in the
Autodesk Vault database, such as files and items.

File is the term used to describe files stored in the Autodesk
Vault database. The vault can store any type of file, including
Autodesk Inventor, Project files, AutoCAD, AutoCAD
Mechanical, Autodesk Civil 3D, Microsoft Excel, Microsoft Word,
etc.

By default, files stored in the Autodesk Vault database do not
require unique filenames. Select Tools>Administration>Vault
Settings and select Enforce Unique File Names to ensure that
the filenames are unique in the Autodesk Vault software, as
shown in Figure 1-1.

W Vault Settings >

Files Visualization Behaviors Items  Change Orders Collaborate Custom Objects

File Mames Duplicates Options

[ Enforce Unique File Names Find Duplicate Names

Disable Check In of Design Files

Working Folder

E Define Working Folder Options Tt

Duplicate Search Settings

= Specify folders for duplicate parts search. Configure...

PDF Options

Configure PDF Publish Options Options...
Specify PDF Publish Location Define...

Enable Manual PDF Creation

Figure 1-1
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Item

Change Order

Properties/
Metadata

File
Management
Terminology

Best Practice: Using Unique Filenames

Enforcing unique filenames is a recommended best practice. If
not previously enforced, you can search for duplicates by
clicking Find Duplicates.

An item is an object type that represents all information related to
the end item part. It is a container for data that can include
Autodesk Inventor files (and other associated reference files),
ECOs, and BOMs. Items refer to what a company manages,
assembles, sells, and manufactures. An item is identified by its
item number or part number. Not only can items represent parts
and assemblies, they can also represent paint, lubricants, etc.

A Change Order, also referred to as an ECO, is an object that
describes why, how, and when changes are made to an ltem
and/or Inventor file. The result and purpose of a Change Order is
to release these objects.

Object properties refer to the information or metadata associated
with a specific object in the Autodesk Vault database. Every
object in the database has properties that include the object
name, state, revision, version, and other attributes. Since the
Autodesk Vault software stores these properties in the database,
they can be searched for to locate an object.

Autodesk Vault’'s operations include recording the process of
change in a file. The terminology related to these processes is
described as follows:

Term Description

Get Downloads a copy of a file from the vault into a client’s
working folder. This option enables you to either get a
read-only copy of the files, or mark the file as being
worked on (checked out) so that you can make
modifications. The Autodesk Vault software always
contains the master copy of the file.

Check Out Marks the file as being worked on (checked out) but
does not download a copy to your working folder.

Undo Check Checks the selected files back in, unmodified, without

Out creating a new version and without uploading the files

back to the vault.

© 2021, ASCENT - Center for Technical Knowledge®
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Check In

Uploads a file from the client’s working folder to the
Autodesk Vault database. You are prompted to save a
file before check in if you have not already done so.

Open

Opens the latest version of a file in the associated
application. It downloads a copy of the file from the
vault into a client’'s working folder.

Version

Defines the state of the file in the change process. It is
an incremental numeric attribute that changes every
time a file is changed and submitted (checked in) to the
database.

Working Copy

A local copy of the file that has been downloaded from
the vault and is located in a local directory or
workspace on your machine. The downloading takes
place during Get and Open operations.

File Status in
Vault (Vault
Status)

Defined by both the state of the file (checked in,
checked out, etc.) and the state of the file in the vault
compared to the local copy on the client’s file system
(newer, older, etc.).

Refresh

Updates the current state of the files in the vault.

Revision

Category

Defines a collection of versions with a single character
typically, such as A or B. A revision is created with the
Revise command. Revisions can also be automatically
generated through a Lifecycle State change.

Best Practice: Delete Working Copies

The vault contains all of the master files, which means you are
working on a copy of the master file each time you check it out.
When you check a file back into the Vault, it becomes the
latest version of the master file. Consider your workspace or
local working folders as a temporary location for your design
files as they are being modified. A recommended best practice
is to delete the working copies when you check them in.

Categories are used to group objects and help to assign
behaviors and rules to each group of objects. A category can
automatically assign user-defined properties to objects in the
Vault. Categories can also be used to automatically assign
lifecycle definitions or revision values to files.

© 2021, ASCENT - Center for Technical Knowledge®
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Lifecycle

Create ’

Lifecycles are used to manage the stages of maturity of an
object. Objects such as files, items and change orders move
from state to state (e.g., Work in Progress > For Review >
Released, etc.), as managed by the lifecycle definition. At each
lifecycle state, an individual is responsible for performing some
type of work. An example of a file or item lifecycle is shown in
Figure 1-2. An example of a change order object or ECO
lifecycle is shown in Figure 1-3.

File or Item Lifecycle Example

Work In . For . T

Progress Review

States
Figure 1-2
ECO (Change Order) Lifecycle Example

(3 Work . Review [ M Approved I

States

Figure 1-3
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Autodesk
Vault Client

i File Edit View[Ge Tools Actions Help

1.3 Accessing Autodesk Vault
There are two ways of accessing Autodesk Vault functions:
* Logging in to the Autodesk Vault client.

* Logging in from Autodesk Inventor to use the Autodesk
Inventor Vault Add-in.

The Autodesk Vault client (also referred to as Autodesk Vault
Explorer), provides the user interface for accessing data in the
vault. Tasks performed in the Autodesk Vault client software
include searching the vault, viewing file status and history, and
checking files in and out. The Autodesk Vault software can also
be launched and accessed from the Autodesk Inventor software.

The Autodesk Vault client software displays a complete view of
the data in the vault. The main window includes the Navigation
pane, Main table, Preview pane, and Properties grid, as shown
in Figure 1-4.

Navigation pane Properties grid

Main table

8 Find... | 1g [ | 53 Share View

= @ Vault_Training - userl
[A] Duplicates Dashboard
Change Order List
Itern Master

a [& Change Category... | [ Change State...
(Ch\WVault [ata oo

Managem ent Pra...
- | .ﬁ.| 2~

=l System ' -
Category Ma... |Engineering

Revision

7 | PISTON_RING.ipt Work in Progress

C L
My Worklist e () B piston_assem.iam Work in Progress C @ Category Na... | Engineering
(@] Ly piston_assem.dwg Work in Progress  C @ Change Orde...
© (@ PISTON.ipt Workin Progress  C @ Checkedin _ |4/22/2020 313 PM
Checked Out | 4/22/2020 5:13 PM
Checked Out...
My shortcuts Checked Out..
HJ Vise.iam History  Uses Where Used Change Order  Preview Checked Out...
Number of versions: 6 (Local = Version #6) Classification | None
Number of revisions: 4 Show all versions Comment Available for edi...
Controlled B... |False
Thumbnail File Mame Revision State (Historical) Created By userl
Addnew group ~ Current Owner| W10-BNASH2\A...
Date Modified |4/17/2020 10:30 ...
@ H“"f A > O PISTON_RING.ipt C Work in Progress Date Version ... | 4/22/2020 5:13 PM
[w] Duplicates Dashboard File Extension |ipt
—_ File Name PISTOMN_RING.ipt
EF, Project Explorer File Name (H... | PISTON_RING.ipt
I(:m — O . File Replicated | True
PISTON_RING.ipt B Released File Size 78336
Change Order List Folder Path §/Designs/Piston
»] | 5 e Has Drawing | False "
4 Object(s) (1 selected) * localhost  Vault_Training g user]
\ Preview pane
Figure 1-4
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Autodesk | The Autodesk Inventor software has a direct integration with
Autodesk Vault using the Autodesk Inventor Vault Add-in. This

Inventor | means that the Autodesk Inventor software has a Vault menu or

o tab in its interface, providing quick access to the Autodesk Vault

Vault Add-in options. File operations, such as Check In and Check Out, can
be performed from within the Autodesk Inventor interface to
maintain file relationship integrity. The integration interface
showing the Vault menu is shown in Figure 1-5.

I w» Viseiam b Search Help & Commands... - Y 32 - - O X
Assemble  Design 3D Model  Sketch  Annotate  Inspect  Toocls  Manage  View » D~
[ [ [ = =
l @ L L EJ' @ D r|'—_||'_‘|
k _!I—P _!I_’ O %I _'0 b
Autodesk Log Out Open Place Check Qut Data Control Find
Vault Mapping
Access = File Status - -

Model vault X <+ Q
CERYMHE

O @ Designs.ipj
O |:b Vise.iam
- (O @ 1_4-0.75-UNC.ipt
- () [ Base.ipt
- () [ Collar.ipt
- () [ Jaw_Plate.ipt
- () M5 Screw_Sub.iam
O |J Set_Screw.ipt
- () [ Slide_Key.ipt
- () @ sliding_Jaw.ipt

- () [ Spedal_Key.ipt

Viseiam X

For Help, press F1 21 14

Figure 1-5
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Chapter Review Questions

1. What are some of the key features and benefits of the
Autodesk Vault software?

a. Central repository for data.
b. Protection against accidentally overwriting design data.

c. Search and display tools to easily find and view design
data.

d. All of the above.

2. What term is used to describe the stages of maturity of an
object?

a. ltem

b. Change Order
c. Lifecycle

d. Revision

3. The Check Out command downloads a copy of a file from
the vault into a client’s working folder.

a. True
b. False

4. Which of the following provides a complete view of all of the
data files in the vault?

a. Autodesk Vault Client (also known as Autodesk Vault
Explorer)

b. Autodesk Data Management Console
c. Autodesk Inventor
d. Vault Add-in

5. What term relates to the incremental numeric attribute that
changes every time a file is changed, submitted, and
checked in to the database?

a. State

b. Revision
c. Version
d. File Status

© 2021, ASCENT - Center for Technical Knowledge® 1-9
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6. In Figure 1-6, what is the name of the highlighted area?

. Navigation Pane

. Main Table
. Properties Grid

! File Edit View Go Tools Actions Help i

a
b. Preview Pane
c
d

Home # Piston I[‘I.]aI::zgn-lD::ta PSS Search Piston g ~ Qle)| Properties X
=] @ Vault_Training - userl ~ T+ O State PISTOM_RIMG.ipt e t g -
[i] Duplicates Dashboard
Change Order List £ File = System - ~
Itern Master vll 1§ PISTON _RING.ipt Work in Progress | |Category Na... |Engineering
_m - (O [ piston_asserm.iam Work in Progre C (] Categary Na... |Engineering
O i piston_assem.dwg Work in Proc 7 Change Orde..
© @ PISTON.pt W in Proc ] B Checked In 4/22/2020 5:13 PM
Checked Out | 4/22/2020 513 PM
Checked Out...
Checked Out...

&Vise.iam History  Uses Where Used Chang*lder Preview Checked Out...

Classification | MNone

Number of versions: 6 (Local = Version #6) . .
. Comment Available for edi...
Mumber of revisions: 4 [ Show all versions
Controlled B... |False
Thumbnail File Name Revision State (Historical) Created By userl
Add new group ANl | current Owner| W1d-BNASHR\A...
Date Modified |4/17/2020 10:50 ...
El Home » O PISTOM_RING.ipt C Work in Progres: Date Version ... | 4/22/2020 513 PM
[7] Duplicates Dashboard File Extension |ipt

File Name PISTOM_RING.ipt
File Mame (H...| PISTOMN_RING.ipt

File Replicated | True
O PISTON_RING.ipt B Released File Size 78336

Folder Path $/Designs/Piston

v Has Drawing | False
= K > v
- =
4 Object(s) (1 selected) localhost  Vault_Training g user]

Figure 1-6
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