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Preface

The Autodesk® Advance Steel software is a powerful 3D modeling application that 
streamlines the fabrication process through the use of a 3D model, which is used 
to create fabrication drawings, Bill of Materials (BOM) lists, and files for Numerical 
Control (NC) machines.

Since structural steel projects are extremely complex, the Autodesk Advance 

Steel software is also complex. The objective of the Autodesk® Advance Steel 
2020: Fundamentals guide is to enable you to create full 3D project models at a 
high level of detail and set them up in fabrication drawings. This guide focuses on 
the basic tools that the majority of users need. You begin by learning the user 

interface, basic 3D viewing tools, and the standard AutoCAD® tools that are 
routinely used. Specific Autodesk Advance Steel objects, including structural 
columns, beams, bracing, plates, bolts, anchors, welds, and additional 3D objects 
are also covered. You will also learn about the powerful model verification tools. 
To complete the guide, you will learn to edit and generate all of the required 
documentation files that enable your design to accurately and effectively 
communicate the final design.

Topics Covered

• Understand the process of 3D modeling and extracting 2D documentation 
from a model in the Autodesk Advance Steel software.

• Navigate the Autodesk Advance Steel interface.

• Work with 3D viewing tools.

• Review helpful AutoCAD tools.

• Work with the User Coordinate System (UCS).

• Use the Autodesk Advance Steel Modify commands.

• Add structural grids.

• Create levels.

• Model columns and beams and add bracing.

• Create connections using the Connection Vault.

• Create special parts.

• Verify models using Clash Checking tools.
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• Modify a drawing prototype.

• Work within the Drawing Style Manager.

• Create custom connections.

• Create plates and add bolts, anchors, and welds.

• Add grating and cladding.

• Model ladders, stairs, and railings.

• Create concrete objects such as footings.

• Number objects.

• Extract 2D drawings from the model using Drawing Styles and Drawing 
Processes.

• Review and modify 2D drawings using the Document Manager.

• Modify 2D details with parametric dimensions.

• Revise models and drawings.

• Create BOM lists.

• Export data to .NC and .DXF files.

Prerequisites

• Access to the 2020.0 version of the software, to ensure compatibility with this 
guide. Future software updates that are released by Autodesk may include 
changes that are not reflected in this guide. The practices and files included 
with this guide might not be compatible with prior versions (i.e., 2019). 

Note on Software Setup

This guide assumes a standard installation of the software using the default 
preferences during installation. Lectures and practices use the standard software 
templates and default options for the Content Libraries.
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Students and Educators can Access Free Autodesk Software and 
Resources

Autodesk challenges you to get started with free educational licenses for 
professional software and creativity apps used by millions of architects, 
engineers, designers, and hobbyists today. Bring Autodesk software into your 
classroom, studio, or workshop to learn, teach, and explore real-world design 
challenges the way professionals do.

Get started today - register at the Autodesk Education Community and download 
one of the many Autodesk software applications available. 

Visit www.autodesk.com/education/home/

Note: Free products are subject to the terms and conditions of the end-user 
license and services agreement that accompanies the software. The software is 
for personal use for education purposes and is not intended for classroom or lab 
use.

Lead Contributor: Cherisse Biddulph

Cherisse is an Autodesk Certified Professional for Revit as well as an Autodesk 
Certified Instructor. She brings 15 years of industry, teaching and technical 
support experience to her role as a Learning Content Developer with ASCENT. 
With a passion for design and architecture, she received her Associate of Applied 
Science in Drafting and Design and worked in the industry assisting several firms 
with CAD Manager needs and getting others up to speed on the latest software. In 
2004 she joined IMAGINiT as an Application Engineer (AE), where she developed 
custom training and provided support for customers. She transitioned from her 
work as an AE to the IMAGINIT Solution Center as a Senior Technical Support 
Specialist where she became proficient in AutoCAD, BIM 360, Navisworks, and 
Revit. Today, Cherisse continues to expand her knowledge in the ever-evolving 
AEC industry and the software used to support it.

Cherisse Biddulph has been the Lead Contributor for Autodesk Advance Steel: 
Fundamentals since 2019.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2020, ASCENT - Center for Technical Knowledge® ix



S

In this Guide

The following images highlight some of the features that can be found in this 
guide. 

Link to the practice files

Practice Files

The Practice Files page tells 
you how to download and install 
the practice files that are 
provided with this guide. 

Learning Objectives for 
the chapter

Chapters

Each chapter begins with a brief 
introduction and a list of the 
chapter’s Learning Objectives.
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Side notes

Side notes are hints or 
additional information for 
the current topic.

Instructional Content

Each chapter is split into a 
series of sections of 
instructional content on specific 
topics. These lectures include 
the descriptions, step-by-step 
procedures, figures, hints, and 
information you need to achieve 
the chapter’s Learning 
Objectives.

Practice Objectives

Practices

Practices enable you to use the 
software to perform a hands-on 
review of a topic. 

Some practices require you to 
use prepared practice files, 
which can be downloaded from 
the link found on the Practice 
Files page.

Chapter Review Questions

Chapter review questions, 
located at the end of each 
chapter, enable you to review 
the key concepts and learning 
objectives of the chapter. 
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Command Summary

The Command Summary is 
located at the end of each 
chapter. It contains a list of the 
software commands that are 
used throughout the chapter, 
and provides information on 
where the command is found in 
the software.
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C h a p t e r

Introduction to the Autodesk 
Advance Steel Software

The Autodesk® Advance Steel software is a program designed for steel 
fabricators that enables you to create a 3D model of steel parts and connections, 
and then extract 2D shop drawings and database files for Bills of Materials 
(BOMs) and Numerical Control (NC) machines. The software is based on the 
AutoCAD® software, but includes many additional tools and palettes designed 
specifically for steel fabrication.

Learning Objectives in this Chapter

• Describe the concepts and workflow of Autodesk Advance Steel.

• Navigate the user interface.

• Use navigation commands to display the model in 2D and 3D views.

• Review the AutoCAD tools that are helpful in the Autodesk Advance Steel software.

• Understand and modify the User Coordinate System (UCS).

• Move, copy, and mirror objects using Advance Copy.

• Trim and extend objects using the Autodesk Advance Steel commands.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2020, ASCENT - Center for Technical Knowledge® 1–1



Autodesk Advance Steel 2020: Fundamentals

S

1.1 Introduction to Autodesk 
Advance Steel

The Autodesk Advance Steel software expands on the features 
and functionality of the AutoCAD software to create 3D models 
of detail-heavy steel structures, as shown in Figure 1–1. It 
includes beams, columns, plates, and bolts, along with 
miscellaneous steel objects, such as stairs, railings, and ladders. 
The documentation for fabrication shop drawings is created 
automatically from the 3D model, as shown in Figure 1–1.

Figure 1–1

A lot of the work that you do in the Autodesk Advance Steel 
software is done using macros that are a series of standard 
AutoCAD commands, in addition to specific Autodesk Advance 
Steel commands and components to create the model and 
documentation. Therefore, most of the work done in Autodesk 
Advance Steel uses specific tools and tool palettes, rather than 
the standard AutoCAD commands.
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• Autodesk Advance Steel projects are created from one of the 
specific Autodesk Advance Steel templates (i.e., 
ASTemplate.dwt or mm_ASTemplate.dwg) or a customized 
template created from one of these. 

• The main drawing file contains the 3D model. Additional 
folders and files are created automatically for details and 
databases (e.g., for BOMs and NC files) as they are added, 
as shown in Figure 1–2.

Figure 1–2
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1.2 Overview of the Interface

Note: The Drawing 
Window color has been 
changed to white for 
printing clarity.

The Autodesk Advance Steel interface is designed for intuitive 
and efficient access to commands and special macros built 
specifically for Autodesk Advance Steel modeling. The interface 
includes the ribbon, Quick Access Toolbar, and Status Bar, which 
are common to most Autodesk® software. Similar to the 
AutoCAD software, Autodesk Advance Steel includes the 
Command Line, drawing windows, and layout tabs. It also 
includes tools that are specific to the Autodesk Advance Steel 
software, including the Advance Tool Palette, the Connection 
Vault, and the Project Explorer. The interface is shown in 
Figure 1–3. Shortcut menus and Autodesk Advance Steel dialog 
boxes are also an important part of using the software.

Figure 1–3

6

3

5

4

2 7

1

8

1. Quick Access Toolbar 5. Status Bar

2. Ribbon 6. Project Explorer

3. Advance Tool Palette 7. Drawing Window

4. Command Line 8. UCS Icon
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1. Quick Access Toolbar

The Quick Access Toolbar (shown in Figure 1–4) includes 
several frequently used commands, including New, Open, Save, 
Print, Undo, and Redo. These commands are also available in 

the Application Menu ( ).

Figure 1–4

• Note that Undo and Redo often do not work as expected in 
the Autodesk Advance Steel software because many of the 
commands are actually macros that run multiple commands. 
This means that you might have to undo several processes to 
fully undo a single command.

2. Ribbon

Instead of the standard AutoCAD tools, the Autodesk Advance 
Steel ribbon includes specific tools used by the program, as 
shown in part of the Home tab in Figure 1–5.

Figure 1–5

• Hover the cursor over a button to display the name of the 
tool.
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3. Advance Tool Palette

The Advance Tool Palette is unique to the Autodesk Advance 
Steel software and holds many important tools, including some 
of the standard AutoCAD modify tools (shown in Figure 1–6) and 
Advance Steel modify tools (shown in Figure 1–7).

• Note that AutoCAD modification tools are not included on any 
of the ribbon tabs.

• To open the tool palette, in the Home tab>Extended Modeling 

panel, click  (Advance Steel Tool Palette).

• Click on the buttons in the left column (called Categories) to 
access the different tools on the right. 

• The Tool Palette can float or be pinned into place. You can 
also minimize it (as shown in Figure 1–8), hide it, and modify 
the Theme Settings.

Figure 1–8

Figure 1–6 Figure 1–7

Categories

Theme Settings

Pin/Unpin

Minimize/ 
Maximize

Close
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Advance Tool Palette Categories

• Commands found in this palette are referenced like this:

In the Advance Tool Palette> (Tools) category, click 

(Advance Copy)

• Note that many of these tools are actually macros of multiple 
commands.

• Other tool palettes (including the Connection Vault) are 
similar and can be docked on top of each other.

Modify Includes standard AutoCAD modification 
commands, such as Move, Trim, and Fillet. 
These tools are most often used with standard 
AutoCAD objects (such as lines and polylines) or 
individual Autodesk Advance Steel objects that 
are not connected to other objects.

Tools Includes tools specifically created to use with 
Autodesk Advance Steel objects and objects that 
are connected together. It includes modification 
tools and ways to create groups.

Custom 
connections

Includes tools to create individual custom 
connectors, including plates and bolts. Tools can 
also group and reuse custom connections.

UCS Includes tools that define the location and 
orientation of the User Coordinate System (UCS). 
Having a defined UCS is critical for many 
Autodesk Advance Steel commands.

Selection Includes tools that enable you to search, display, 
and mark objects by certain criteria.

Selection 
filters

Includes tools that enable you to select specific 
types of elements, including all beams, or just 
curved or concrete beams, among other objects 
including slabs and bolts.

Quick views Includes tools that enable you to create views 
based on certain objects to help you modify the 
view by toggling all objects on, or selected 
objects off, etc.

Features Includes tools for modifying plates and beams 
(including miters, corner cuts, and copes), as well 
as cutting holes in objects.
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4. Command Line

The command line is the same in the Autodesk Advance Steel 
software as it is in the AutoCAD software. Autodesk Advance 
Steel commands are much more complex (as seen in 
Figure 1–9), so they are rarely typed.

Figure 1–9

• The prompts for Autodesk Advance Steel commands can be 
complex. If you are having trouble following a process, 
expand the command line to display multiple lines of prompts.

5. Status Bar

The Status Bar (shown in Figure 1–10) is essentially the same as 
in the AutoCAD software. Important tools found here include 
Ortho, Object Snaps, and Isolate Objects.

Figure 1–10

6. Project Explorer

The Project Explorer (also known as the Structures palette) 
enables you to create Levels and Model views, and access other 
tools. This palette can remain floating on the screen (as shown in 
Figure 1–11) or be docked.
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Figure 1–11

• To display the Project Explorer, in the Home tab>Project 

panel, click  (Project Explorer).

• If you have toggled off objects, you can toggle them all back 

on by clicking  (Show All Elements).

7. Drawing Window

The drawing window is the area of the screen in which the 
drawing displays. Several drawing windows can be open at the 
same time. They can be resized, minimized, and maximized. 

The drawing’s File tabs (shown in Figure 1–12) are located near 
the top of the drawing window. They provide a quick way of 
switching between open drawings, creating new drawings, or 
closing drawings. The Start tab is always the first tab and 
persists in the File tabs bar. Clicking the start tab displays the 
Start window.

Figure 1–12
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• The Model and Layout tabs display at the bottom of the 
drawing window. Most of your work in the Autodesk Advance 
Steel software is done in the Model tab. Layouts are 
automatically created when you run the documentation tools.

8. UCS Icon

In the drawing window, the UCS icon indicates the current 
drawing planes. This is an important part of the Autodesk 
Advance Steel software as it controls the orientation of elements, 
such as plates and stairs. The style of the UCS icon changes 
with the visual style, as shown in Figure 1–13.

Figure 1–13

• To toggle the UCS icon on and off, in the View tab>Viewport 

Tools panel, click  (UCS Icon).

• If you change the UCS and want to return to the base 
location, in the command line, type UCS, press <Enter>, then 
type W (for World) and press <Enter>. Alternatively, in the 

Advance Tool Palette>UCS category, click  (UCS 
World).

Shortcut Menus

When you right-click, a shortcut menu usually displays next to 
the cursor. The menu that displays depends on what you are 
doing in the software and where you right-click. For example, 
when no objects are selected and you right-click in the drawing 
window, the menu in Figure 1–14 displays. When you have an 
Autodesk Advance Steel object selected, the menu in 
Figure 1–15 displays.

2D Wireframe Conceptual
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Autodesk Advance Steel Dialog Boxes

Two dialog boxes are critical parts of using the Autodesk 
Advance Steel software: Advance Properties (as shown for a 
beam in Figure 1–16) and Advance Joint Properties. These 
dialog boxes are accessed through the shortcut menu when you 
have certain objects selected. The critical part of understanding 
these dialog boxes is that they are live (i.e., any changes that 
you make in the dialog box are instantly and automatically 
applied to the model).

Figure 1–16

Figure 1–14 Figure 1–15
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• Advance Properties: Displays the options for selected 
objects, such as beams, columns, or individual bolts.

• Advance Joint Properties: Displays the options for a full 
connection, such as the Base plate shown in Figure 1–17. 
This includes options for the plate, stiffeners, holes, and bolts 
as a group.

Figure 1–17

• Select the tabs on the left to display information on the right.
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1.3 Viewing the Model
In Autodesk Advance Steel you are primarily working in 3D, and 
so you need to be able to view objects from all directions. There 
are several basic tools that enable you to do so: preset 3D views, 
the ViewCube, and Visual Styles, as shown in Figure 1–18.

Figure 1–18

Accessing
Preset 3D

Views

There are several preset 3D views (shown in Figure 1–19) that 
enable you to quickly change the viewing angle. These presets 
include both orthographic and isometric views, and can be 
accessed in the top left corner of the drawing window, as shown 
in Figure 1–20. 

Preset 3D Views

Visual Styles

ViewCube

Figure 1–19 Figure 1–20
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• Orthographic views display as if you are facing one side of a 
part. Isometric views typically display three sides, as if you 
are facing a corner. 

• Orthographic views change the active drawing plane (UCS) 
of the view, while isometric views do not. To return to the flat 
drawing plane, select the Top view before continuing with a 
non-orthographic 3D view.

Using the
ViewCube

The ViewCube provides visual clues as to where you are in a 3D 
drawing and makes it easier to navigate to standard views, such 
as Top, Front, Right, Left, Corner, and directional views. Move 
the cursor over one of the highlighted options and select it. You 
can also click and drag on the ViewCube to rotate the box, which 
rotates the model. The ViewCube is shown in Figure 1–21.

To change the default 
Home view, set the view 
you want, right-click on 
the ViewCube, and 
select Set Current View 
as Home.

Figure 1–21

•  (Home) displays when you hover the cursor over the 
ViewCube. Click it to return to the view defined as Home.

• To toggle the ViewCube on and off, in the View tab>Viewport 

Tools panel, click  (ViewCube).

Orbiting in 3D The best tools for navigating a model in 3D are the mouse and 
keyboard. You can zoom in and out using the mouse wheel, and 
can pan by holding the mouse wheel and moving the mouse. 
Both methods are useful in 2D and 3D. However, in 3D you also 
need to view the model from all sides. Hold <Shift> and the 
mouse wheel to orbit the objects in your drawing, as shown in 
Figure 1–22.

Home
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Figure 1–22

• When you orbit, the target (what you are viewing) stays 
stationary while the camera (your viewpoint) moves. 

• You can also hold <Ctrl> and the mouse wheel to swivel. This 
is similar to panning the camera as you drag the mouse. The 
target of the view changes.

• If you select objects before you start orbiting, only those 
objects display as you move around the drawing. This can be 
useful in complex drawings, because limiting the number of 
objects results in a smoother rotation of the view.

Using Visual
Styles

While viewing a model, setting a visual style can help you gain a 
clearer understanding of the model. Visual styles control how 
elements display in a view. You can add and modify objects and 
orbit in any of the visual styles. Three useful visual styles include 
the 2D Wireframe, Conceptual, and X-ray styles, as shown in 
Figure 1–23.

Figure 1–23

• The visual styles list is available in the upper left corner of the 
drawing window, next to the 3D view presets.
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Practice 1a Open a Project and View the 
Model

In this practice, you will review the folder structure of a typical 
Autodesk Advance Steel project. You will open a drawing and 
review the user interface. You will then use the 3D viewing tools 
to display the model you will be creating in the practices, shown 
in Figure 1–24.

Figure 1–24

Task 1 - Review files and open an Autodesk Advance Steel 
model.

1. In the Quick Access Toolbar, click  (Open).

2. In the Open dialog box, navigate to the practice files folder.

Practice Objectives

• Review typical Autodesk Advance Steel project layouts.

• Open an Autodesk Advance Steel drawing.

• Review the user interface.

• View the 3D model.
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3. Click once on Platform-Introduction.dwg to display the 
preview as shown in Figure 1–25. This is the primary model 
you will be working on.

Figure 1–25

4. Scroll up the list and double-click on the Platform-Introduction 
folder. It contains two folders: Databases and Details. These 
folders were automatically created when the documentation 
files were processed.

5. Open the Details folder. Note that there are a number of detail 
drawings, but that they do not preview, as shown in 
Figure 1–26. These files are not typically opened directly, but 
rather are accessed through the Document Manager when 
you are in a model.

Figure 1–26

6. Return to the main folder and open 
Platform-Introduction.dwg.
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Task 2 - Review the user interface.

1. Review the different tabs of the ribbon. Note that many tools 
on the Home tab>Objects panel are also found on the 
Objects tab, as shown in Figure 1–27.

Figure 1–27

2. In the Home tab>Extended Modeling panel, click 

(Advance Steel Tool Palette) to toggle it on.

3. In the Advance Tool Palette, click through the various 
categories to review the available tools.

4. In the Quick views category, click  (All Visible). 
Additional elements display in the view, as shown in 
Figure 1–28.

Objects tab

Home tab>Objects panel
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Figure 1–28

5. Select the object labeled Level 0. Hover the cursor over the 
object to display information about the layer it is on, as shown 
in Figure 1–29. Objects are automatically placed on the 
appropriate layer in the Autodesk Advance Steel software.

Figure 1–29

6. Right-click in the drawing window and select Select Similar. 

7. In the Advance Steel Tool Palette>  Quick Views 

category, click  (Selected Objects off).
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8. In the model, double-click on a column. The Advance 
Properties command displays, as shown in Figure 1–30. 
Click through the tabs on the left and note the different 
options.

Columns are made from 
beams, but they have 
the Model Role of 
Column, and are 
typically placed on the 
Column layer when 
created with the 
appropriate Advance 
Steel command.

Figure 1–30

9. Close the dialog box.

10.Zoom in on the base of column A2. Note that there is a box 
around the base plate on the Connection boxes layer, as 
shown in Figure 1–31. 

Figure 1–31
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11. Double-click on the box to open the Advance Joint Properties 
dialog box, shown in Figure 1–32. The information in this 
dialog box controls the connection elements for the column.

Figure 1–32

12.Close the dialog box.

13.Select the connection boxes (also called joint boxes) and 
toggle them off using the same process as you did for the 
layer symbols in Steps 5 to 7.

14.Double-click on the base plate. Note that the Advance 
Properties dialog box for the plate displays, but now you 
cannot make many changes to the plate because it is part of 
a connection object.

15.Close the dialog box.

16.Select the base plate again. Right-click (ensuring that you do 
not touch the UCS gizmo) and select Advance Properties, 
as shown in Figure 1–33. The same dialog box displays as 
when you double-clicked on the plate.

Figure 1–33
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17.Right-click on the base plate again and select Advance Joint 
Properties. This opens the full connection dialog box. It also 
turns the joint box on for this connection only.

18.Close the dialog box.

19.Use the cursor to pan around the drawing and select one of 
the smaller blue connection boxes (these are custom 
connections) and toggle them off.

20. In the command line, type Z <Enter> A<Enter> to return to 
the full model view.

21.Save the drawing.

Task 3 - View the 3D model.

1. Locate the UCS icon in the lower left of the model at column 
A1, as shown in Figure 1–34. Note the direction of the X, Y, 
and Z-axes.

Figure 1–34

2. Click on various parts of the ViewCube to rotate the model. 
Note that the UCS does not change.

3. In the upper left of the drawing window, test the four preset 
isometric views. Note that the UCS still does not change.

UCS
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4. Set the view to the Left preset. Note that the UCS now 
changes, as shown in Figure 1–35. The Top, Bottom, Left, 
Right, Front, and Back views change the UCS to that 
orientation.

Figure 1–35

5. Hold <Shift> and the mouse wheel and rotate the model in 
the view. Even though you were in what looked like an 
elevation view, note that you are still in a 3D view.

6. In the Advance Steel Tool Palette>  UCS category, click 

(UCS World), or in the command line, type UCS 
<Enter>, W <Enter>.

7. Zoom in on the UCS icon.am
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8. In the upper left corner of the view window, change the Visual 
Style to 2D Wireframe, as shown in Figure 1–36. Note that 
the UCS icon changes with the rest of the model.

Figure 1–36

9. Test out other Visual Styles. Which one gives you the best 
view of the j-bolts in the footing? 

10.Set the Visual Style set to Conceptual.

11. Zoom out to display the entire model.
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1.4 Helpful AutoCAD Tools
Most of the tools that you use in the Autodesk Advance Steel 
software are customized macros that create complex objects 
and connections. Since the software is based on the AutoCAD 
software, there are some useful tools that you can use as you 
are drawing and modifying the Autodesk Advance Steel objects, 
including object snaps, Ortho, Polar Tracking (shown in 
Figure 1–37), basic modify tools such as Move and Copy, grips 
on objects, and the 3D Gizmo.

Figure 1–37

• Warning: One tool that does not work as expected in the 
Autodesk Advance Steel software is the Undo command. As 
many Autodesk Advance Steel commands are actually 
macros of many commands, pressing Undo once often does 
not do much. You might need to use the Undo drop-down list 
(shown in Figure 1–38) to undo numerous steps.

Figure 1–38

Object Snaps

Polar Tracking
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Status Bar
Tools

Several tools on the Status Bar (shown in part in Figure 1–39) 
can help you as you are drawing and modifying objects, 
including the Ortho, Polar Tracking, and Object Snap Tracking 
tools. You can also toggle on the drawing view grid to help you 
visualize the space better. Object Snaps are probably the most 
critical of the tools.

Figure 1–39

Object Snaps

There are a lot of objects that you can snap to in Autodesk 
Advance Steel models, so it is important to use only the ones you 
need. For example, there are a lot of endpoints on an I-beam, 
but only one node at the end of each beam. It is safer to use 
object snap overrides (as shown in Figure 1–40) more frequently 
than setting the objects snaps (as shown in Figure 1–41).

• The Node object snap and GRID Intersection Points object 
snap can be preset. Toggle off object snaps if they get in the 
way of what you are trying to do.

Figure 1–40 Figure 1–41
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Basic Modify
Tools

Basic AutoCAD modification tools (such as Move, Copy, and 

Rotate) are accessed in the Advance Tool Palette> (Modify) 
category, as shown in Figure 1–42. These tools can be used if 
you are working with standard AutoCAD objects (such as lines) 
or when you are manipulating individual Autodesk Advance Steel 
objects (such as columns or beams). 

These AutoCAD tools 
can be used as long as 
there are no joints 
connecting objects.

Figure 1–42

• Once you start making connections so that columns and 
beams work together with plates and bolts, you need to start 
using the Autodesk Advance Steel modify tools.
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Using Grips
and the

3D Gizmo

You can use grips to modify objects, such as the length of 
beams or size of plates. They work in 2D and in 3D with 
added power when you use the 3D Gizmo, as shown in 
Figure 1–44.

Figure 1–44

Hint: AutoCAD Break vs. Autodesk Advance Steel Split 
Beam

Not all of the standard AutoCAD tools will work with Autodesk 
Advance Steel objects. For example, the Break command 
does not work on beams. Instead, use the Autodesk Advance 
Steel command Split Beam to break a beam into separate 
parts, as shown in Figure 1–43.

Figure 1–43

1. In the Objects tab>Beams panel, click  (Split Beam).
2. Select the beam you want to split and press <Enter>.
3. Select the point or points along the beam where you want it 

to split. 
4. Press <Enter>.
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• 3D Gizmos can be used with both 2D and 3D objects. The 
Gizmo is primarily used to move and rotate, but can also 
scale objects, as shown in Figure 1–45.

Figure 1–45

• When you select objects in a 3D view, the UCS icon turns into 
the Gizmo tool. This tool enables you to limit the movement 
of objects along an axis or plane and to rotate in 3D space. 
When you hover the cursor over a Gizmo, it automatically 
jumps to a location or vertex grip. It can also be used as a 
grip without being moved to another grip.

• The color-coded icon displays in the current UCS. Red 
indicates the X-axis, green the Y-axis, and blue the Z-axis.

• As you move the cursor over one of the axes on the Gizmo 
tool, the active axis highlights in gold and displays a guideline 
in the axis color. If you move the cursor over a plane, the 
plane highlights in gold, as shown in Figure 1–46.

Figure 1–46

Move Gizmo Rotate Gizmo Scale Gizmo

Highlighted

Gizmo Icon Y-axis selected YZ plane selected
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How To: Use the 3D Gizmo

1. In a 3D view, select the objects you want to modify.
2. Move the Gizmo tool to a base point, if required.
3. Select an axis or plane on the Gizmo tool.
4. You can right-click on the Gizmo to display a menu and pick 

move, rotate, or scale.
5. When a Gizmo operation is in progress and you need to 

switch to a different Gizmo, press <Spacebar> or <Enter> to 
cycle through the options.

• To move an object, move the cursor along the axis or in 
the plane. You can type coordinates or select a point to 
end the command.

• To rotate an object, move the cursor along the axis. Type 
an angle value or select a point to finish the command.

• To scale an object, select the center triangular plane 
between the three axes in the Gizmo tool, and move the 
cursor towards or away from the center of the Gizmo.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–30 © 2020, ASCENT - Center for Technical Knowledge®



Introduction to the Autodesk Advance Steel Software

S

Practice 1b Helpful AutoCAD Tools

In this practice, you will use grips and Ortho to shorten grid lines 
and lengthen beams. You will use the AutoCAD Copy command 
and Node object snap to copy columns and beams. You will then 
test the difference between the AutoCAD Break command and 
the Autodesk Advance Steel Split Beam command. Finally, you 
will use the 3D gizmo to copy beams in 3D and then use grips 
and node snaps to change the height on one end of the beams. 
The final model is shown in Figure 1–47.

Figure 1–47

Task 1 - Use grips and object snaps to modify and copy 
objects.

1. In the practice files folder, open Platform-Simple.dwg.

Practice Objectives

• Use Object Snap, Ortho, and other AutoCAD drawing aids.

• Use grips and the 3D Gizmo to copy, move, and modify objects.

• Understand the difference between the AutoCAD Break command and 
the Autodesk Advance Steel Split Beam command.
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2. In the Status Bar, ensure that  (Ortho) is toggled on and 

(Object Snaps) are toggled off.

3. Select the AB Grid object. Click on the grip for Grid A and 
move it in 30'-0", as shown in Figure 1–48.

Figure 1–48

4. Repeat the process with Grid B.

5. Move Grids 1-4 in 20'-0", as shown in Figure 1–49.

Figure 1–49

6. Toggle on Object Snaps and set the Object Snaps to Node 
and GRID Intersection Points. Ensure that no other object 
snaps are on.
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7. In the Advance Tool Palette> (Modify) category, click 

 (Copy). Select the columns on Grid 2 and copy them to 
Grids 3 and 4 using the node object snap at the end of the 
grid lines. 

8. Use grips to extend the beams along Grid A and B to Grid 4, 
as shown in Figure 1–50.

• You can use the Node object snap for the beam on Grid A 
with the short columns, but you need to use the 
Perpendicular object snap override with the taller column 
on Grid B.

Figure 1–50

9. Copy the rest of the beams into place.

10.Save the drawing.

Task 2 - Test Break vs. Split Beam.

1. Extend the Command Line so that at least 3 historical 
prompts display. 

2. Zoom in on the top of Column A2 and select the beam. Note 
that the beam is all one piece. 
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3. In the Advance Tool Palette>  Modify category, click 

(Break).

4. Select the beam. In the Command Line, note that the object 
cannot be broken, as shown in Figure 1–51. Press <Esc>.

Figure 1–51

5. In the Objects tab>Beams panel, click  (Split Beams).

6. Select the beam and press <Enter>.

7. Select the Node object snap at the top of the beam, then pan 
over to Column A3 and select the Node there as well, and 
then press <Enter>. The beams are now separated, as 
shown in Figure 1–52. 

Figure 1–52

8. Repeat the process for the beam on Grid B.

9. Save the drawing.
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Task 3 - Copy objects in 3D.

1. Select one of the beams. Right-click and select Select 
Similar. Note that all of the beams and braces are selected.

2. Hold <Shift> and clear the selection of the two diagonal 
braces.

3. Move the cursor over the Z-axis (blue) of the 3D Gizmo and 
select it.

4. In the Command Line, type CO (for Copy). 

Note that Ortho should 
still be on for this step.

5. Move the cursor up, enter 12', and press <Esc> to finish the 
command, as shown in Figure 1–53.

Figure 1–53

6. Use grips to extend the shorter columns up 12'-0". 

7. Use the AutoCAD Move command to move the back beams 
3'-5 1/4" up to the top of the columns (for a total of 16'-0").

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2020, ASCENT - Center for Technical Knowledge® 1–35



Autodesk Advance Steel 2020: Fundamentals

S

8. Use grips and the Node object snap to angle the columns as 
shown in Figure 1–54.

Figure 1–54

9. Zoom out to display the entire model.

10.Save the drawing.
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1.5 Working with the User 
Coordinate System (UCS)

In the AutoCAD software, 2D objects are created on a single flat 
plane, which is usually the XY plane. In Autodesk Advance Steel 
most of your work occurs in 3D and you need to be able to 
specify the XY plane (as shown in Figure 1–55) for a number of 
commands, such as when you draw plates or bracing members.

Figure 1–55

• There are three axes: the X-axis, Y-axis, and Z-axis. Three 
planes are also automatically created by the intersections of 
these axes. They are the XY plane, the YZ plane, and the XZ 
plane. Together these three axes and their planes form a user 
coordinate system, or UCS.

• The UCS is a user-defined working plane with X,Y 
coordinates that can be positioned at any location or 
orientation in space.

• Do not confuse the UCS position with the viewing direction. 
The position from which you view your drawing, known as the 
viewpoint, determines how you see your drawing. The UCS 
determines where you are drawing. It sets the position of the 
working plane. 

• The POLAR, OTRACK, and ORTHO commands work with 
dynamic input in the Z-axis direction.
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UCS
Commands

UCS commands are found in the Advance Tool Palette> 

(UCS) category, as shown in Figure 1–56. Some of these 
are the same tools as found in AutoCAD, and a few are specific 
to the Autodesk Advance Steel software.

Figure 1–56

• Most of these tools can also be accessed using commands 
typed into the command line, as shown in Figure 1–57. Type 
UCS and then the method you want to use. World is the 
default for the UCS command.

Figure 1–57
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Commonly Used UCS Commands

UCS World Returns the UCS to the Home 
position at 0,0,0 in the drawing.

Move UCS Specify a new origin point. The axes 
are not modified

Rotate UCS 
around X, Y, Z

Frequently used after moving the 
UCS. Click on these tools to rotate 
the other axes around the X, Y, or Z 
axis.

UCS at object Identify an object and then click on 
the line which you want to specify 
as the Z-axis (Autodesk Advance 
Steel only).

UCS 3 points Specify the new origin point, the 
positive direction of the X-axis, and 
the positive portion of the Y axis.

UCS View Orients the UCS to the current view.
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1.6 Using the Autodesk Advance 
Steel Modify Commands

While you can use the standard AutoCAD modify commands for 
individual objects in the Autodesk Advance Steel software, there 
are times when these tools are not going to work, as shown in 
Figure 1–58. This is especially true once you start working with 
connections or if you want to copy features that have been cut 
into columns. In these cases, it is best to use the Advance Copy 

command found in the Advance Tool Palette> (Tools) 
category, as shown in Figure 1–59. There is also a specific tool 
to Trim or Extend Autodesk Advance Steel objects, such as 
beams and columns. 

• The Advance Copy command includes options for Copy, 
Move, Array, Polar array, Mirror, Rotate, Align, and Adapt. 
You can also access some of these options directly using the 
other buttons in the Tools category.

How To: Transform Elements Using Advance Copy

1. In the Advance Tool Palette> (Tools) category, click 

(Advance Copy).
2. In the Transform elements dialog box (shown in 

Figure 1–60), click  (Select objects).

Figure 1–58 Figure 1–59

Original AutoCAD Copy Advance Copy 
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3. In the drawing window, select the base objects (such as 
columns or beams) you want to use, and press <Enter> to 
return to the dialog box.

• If you want to include the relationships between 
connected objects (such as a base plate on the bottom of 
a column), select Include additional connections, as 
shown in Figure 1–60.

Figure 1–60

4. Select the type of command you want to use, as shown in the 
red box in Figure 1–60, above.

5. Depending on the type of command you select, various parts 

of the dialog box are available. Click  to specify distances 
or other points.

6. Click Preview.
7. Review the model to ensure that everything is placed as 

expected. When you are finished, in the Preview dialog box 
(shown in Figure 1–61), click OK. If you need to make 
changes, click Modify to return to the dialog box or Cancel to 
exit the command.

Figure 1–61
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• It is safer to preview the function, rather than just hoping that 
it works. Remember that commands in the Autodesk 
Advance Steel software are often macros of many 
commands, and trying to undo an operation might take many 
steps.

Using Advance
Trim/Extend

The standard AutoCAD Trim and Extend commands do not work 
with Autodesk Advance Steel objects, but you can use the 
Advance Trim/Extend command, as shown in Figure 1–62.

Figure 1–62

How To: Trim or Extend Autodesk Advance Steel 
Objects

1. In the Advance Tool Palette> (Tools) category, scroll down 

and select  (Advance Trim/Extend).
2. Select the Trim, Extend, or Auto operation mode (the default 

is Auto).
3. Select one of the following Select options: 

• System: The system line of a beam. This is the default.

• Center: The center line of a beam.

• Face: The face of a beam.

• Line: An AutoCAD object. 

4. Select the boundary object and press <Enter>
5. Select the object to be trimmed or extended. 
6. Continue selecting other objects, or press <Enter> to finish 

the command.

Before After

Advance Trim/Extend command
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Practice 1c Use the Autodesk Advance Steel 
Modify Commands

In this practice, you will use the Advance Copy command to copy 
and mirror columns, beams, and braces, with their connections. 
You will copy beams in 3D space and then extend columns to 
meet the new beam locations. Finally, you will move beams to a 
new location and use grips to modify the connecting beams. The 
final model is shown in Figure 1–63.

Figure 1–63

Task 1 - Use Advance Copy to copy and mirror objects and 
their connections.

1. In the practice files folder, open Platform-Modify.dwg.

Practice Objective

• Use Advance Copy to copy, move, and mirror Autodesk Advance Steel 
objects.
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2. Investigate the existing objects in the model. Note that they 
all have connections where they intersect, as shown in 
Figure 1–64.

Figure 1–64

3. In the Advance Tool Palette> (Tools) category, click 

(Advance Copy).

4. In the Transform elements dialog box, click  (Select 
objects).

5. In the drawing window, select the two columns on Grid 2 and 
the three connecting beams, as shown in Figure 1–65, and 
press <Enter>.

Figure 1–65

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–44 © 2020, ASCENT - Center for Technical Knowledge®



Introduction to the Autodesk Advance Steel Software

S

6. In the Transform elements dialog box, select Include 
additional connections.

7. Ensure that the Copy option is selected.

8. In the Distance area, set the X distance to 15' and the 
Number of copies to 2, as shown in Figure 1–66.

Figure 1–66

9. Click Preview. The copies and appropriate connections 
display as shown in Figure 1–67.

Figure 1–67
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10. In the Preview dialog box, click OK.

11. Start the Advance Copy command again.

12. In the dialog box, click  (Select objects) and select the 
columns, beams, and braces that are highlighted in 
Figure 1–68.

13. In the dialog box, select the Mirror option. In the Mirror area, 

ensure that 2D is selected, and then click  (Select mirror 
points).

14.Select the two end node points of Grid 3. 

15. In the dialog box, click Preview. The mirrored objects should 
display as shown in Figure 1–68. Click OK.

Figure 1–68

16.Save the drawing.

Task 2 - Copy and extend objects in 3D space.

1. Start the Advance Copy command.

2. Select all of the beams in the model, but not the braces and 
columns.

New Mirrored 
Objects

Objects to be 
mirrored
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3. Set the Z distance to 12'-0" (as shown in Figure 1–69) and 
click Preview.

Figure 1–69

4. Select the highlighted columns (corresponding entities) or 
press <Enter> to accept the highlighted column, as prompted 
and shown for the first column in Figure 1–70. The 
connectors are added even though the columns do not yet 
reach that location. Click OK.

Figure 1–70

5. In the Advance Tool Palette> (Tools) category, scroll down 

and click  (Advance Trim/Extend).

6. At the Please select operation mode prompt, select Auto.

7. At the Please select option prompt, select System.
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8. Select the beams along Grid A on the second level. Press 
<Enter>, select the corresponding columns, and then press 
<Enter>. The columns are extended, as shown in 
Figure 1–71. 

Figure 1–71

9. Press <Esc> to finish the command.

10.Use Advance Copy to move the beams along Grid B to the 
top of the 16'-0" columns, and then use grips to modify the 
crossing beams so that they are at an angle, as shown in 
Figure 1–72.

Figure 1–72

11. Save the drawing.
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Chapter Review Questions 

1. Which of the following describes the Autodesk Advance Steel 
workflow?

a. Start from an existing project and draw in 2D and 3D.

b. Start from a template, draw the objects in 3D, and 
automatically create 2D drawings from the model.

c. Start from an existing 2D drawing and extrude 3D 
elements.

d. Start from a template and create 2D working documents.

2. When you are working in a 3D view, you need to change to a 
2D view before you can add any objects.

a. True

b. False

3. Where do you find Autodesk Advance Steel specific tools in 
the User Interface? (Select all that apply.)

a. Ribbon

b. Advance Tool Palette

c. Quick Access Toolbar

d. Shortcut menu

4. In AutoCAD you can use many different object snaps as 
drawing aids. Which one of the following object snaps do you 
typically leave active in the Autodesk Advance Steel 
software?

a. Endpoint

b. Midpoint

c. Node

d. Center

5. Which of the following commands duplicates both the 
selected objects and any connections (such as clip angles).

a. Copy

b. Advance Copy

c. Array

d. Advance Trim/Extend

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2020, ASCENT - Center for Technical Knowledge® 1–49



Autodesk Advance Steel 2020: Fundamentals

S

Command Summary

Button Command Location
General Commands

Advance Copy • Advance Steel Tool Palette: Tools 
category

Advance Steel 
Properties

• Advance Steel Tool Palette: Tools 
category

• Double-click: On an Advance Steel 
object

• Shortcut Menu: Select objects, 
Advance Properties

Advance Steel 
Tool Palette

• Ribbon: Home tab>Extend Modeling 
panel

Advance 
Trim/Extend

• Advance Steel Tool Palette: Tools 
category

All Visible • Advance Steel Tool Palette: Quick 
Views category

Break • Advance Steel Tool Palette: Modify 
category

Copy • Advance Steel Tool Palette: Modify 
category

Open • Quick Access Toolbar

• Application Menu: Open>Drawing

Project 
Explorer

• Ribbon: Home tab>Project panel 

Selected 
Objects off

• Advance Steel Tool Palette: Quick 
Views category

Split Beam • Ribbon: Objects tab>Beam Tools panel 

ViewCube • Ribbon: View tab>Viewport Tools panel 

UCS Commands

UCS Icon • Ribbon: View tab>Viewport Tools panel 

UCS World • Advance Steel Tool Palette: UCS 
category

Move UCS • Advance Steel Tool Palette: UCS 
category
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Rotate UCS 
around X, Y, Z

• Advance Steel Tool Palette: UCS 
category

UCS at object • Advance Steel Tool Palette: UCS 
category

UCS 3 points • Advance Steel Tool Palette: UCS 
category

UCS View • Advance Steel Tool Palette: UCS 
category
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