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S

Preface

Building Information Modeling (BIM) is an approach to the entire building life 
cycle. Autodesk® Revit® for Architecture, MEP, and Structure is a powerful BIM 
program that supports the ability to coordinate, update, and share design data 
with team members throughout the design construction and management phases 
of a building’s life. A key component in managing the BIM process is to establish a 
company foundation for different types of projects by creating standard templates 
and custom family elements. Having this in place makes the process of any new 
project flow smoothly and efficiently.

The objective of the Autodesk® Revit® 2019 BIM Management: Template and 
Family Creation learning guide is to enable users who have worked with the 
software to expand their knowledge in setting up office standards with templates 
that include annotation styles, preset views, sheets, and schedules, as well as 
creating custom system, in-place, and component families. 

This learning guide contains practices that are specific to each discipline.

Topics Covered

• Create custom templates with annotation styles, title blocks, and custom 
element types.

• Create schedules, including material takeoff schedules with formulas.

• Create custom wall, roof, and floor types as well as MEP system families.

• Set up a component family file with a parametric framework.

• Create family geometry.

• Create family types.

• Modify the visibility of components and incorporate additional family items 
such as controls, MEP connectors, and nested components.

• Create specific families, including in-place families, profiles, annotations, and 
parameters.

This learning guide also contains discipline-specific practices for families, 
including: doors, windows, railings, pipe fittings, light fixtures, gusset plates, and 
built-up columns.
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Prerequisites

• Access to the 2019 version of the software. The practices and files included 
with this guide might not be compatible with prior versions.

• Students should be comfortable with the fundamentals of the Autodesk Revit 
software, as found in the Autodesk Revit 2019 Architecture Fundamentals, 
Autodesk Revit 2019 Structure Fundamentals, or Autodesk Revit 2019 MEP 
Fundamentals learning guides. Knowledge of basic techniques is assumed, 
such as creating standard element, copying and moving elements, and 
creating and working with views, etc. Information on Collaboration Tools, 
Conceptual Design, and Site and Structural Design are covered in additional 
learning guides.

Note on Software Setup

This guide assumes a standard installation of the software using the default 
preferences during installation. Lectures and practices use the standard software 
templates and default options for the Content Libraries.

Students and Educators can Access Free Autodesk Software and 
Resources

Autodesk challenges you to get started with free educational licenses for 
professional software and creativity apps used by millions of architects, 
engineers, designers, and hobbyists today. Bring Autodesk software into your 
classroom, studio, or workshop to learn, teach, and explore real-world design 
challenges the way professionals do.

Get started today - register at the Autodesk Education Community and download 
one of the many Autodesk software applications available. 

Visit www.autodesk.com/education/home/

Note: Free products are subject to the terms and conditions of the end-user 
license and services agreement that accompanies the software. The software is 
for personal use for education purposes and is not intended for classroom or lab 
use.
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Martha incorporates her passion for building design and education into all her 
projects, including the learning guides she creates on Autodesk Revit for 
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Autodesk Revit as they came along. 

After receiving a B.Sc. in Architecture from the University of Virginia, she worked 
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S

In this Guide

The following images highlight some of the features that can be found in this 
guide. 

Link to the practice files

Practice Files

The Practice Files page tells 
you how to download and install 
the practice files that are 
provided with this guide. 

Learning Objectives for 
the chapter

Chapters

Each chapter begins with a brief 
introduction and a list of the 
chapter’s Learning Objectives.
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Side notes

Side notes are hints or 
additional information for 
the current topic.

Instructional Content

Each chapter is split into a 
series of sections of 
instructional content on specific 
topics. These lectures include 
the descriptions, step-by-step 
procedures, figures, hints, and 
information you need to achieve 
the chapter's Learning 
Objectives.

Practice Objectives

Practices

Practices enable you to use the 
software to perform a hands-on 
review of a topic. 

Some practices require you to 
use prepared practice files, 
which can be downloaded from 
the link found on the Practice 
Files page.

Chapter Review Questions

Chapter review questions, 
located at the end of each 
chapter, enable you to review 
the key concepts and learning 
objectives of the chapter. 
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S

Command Summary

The Command Summary is 
located at the end of each 
chapter. It contains a list of the 
software commands that are 
used throughout the chapter, 
and provides information on 
where the command is found in 
the software.

Autodesk Certification Exam 
Appendix

This appendix includes a list of 
the topics and objectives for the 
Autodesk Certification exams, 
and the chapter and section in 
which the relevant content can 
be found.
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C h a p t e r

Creating Custom Templates

Custom templates can save you time and provide consistency in applying office 
standards when creating similar projects. Templates can include items such as 
levels, views, sheets, schedules, and annotation types for text, dimensions, and 
tags. A typical family that is added to templates is a custom title block, which helps 
you to ensure that sheets are created with the appropriate information. You may 
also want to add rule-based view filters and view templates to project template 
files. 

Learning Objectives in this Chapter

• Create project templates.

• Use resource projects to store additional system families, details, schedules, and other data.

• Create standard text and dimension types for use in your projects.

• Modify callout, elevation, and section tags and specify which tags are loaded in a template.

• Create title blocks including detail lines, text, labels, symbols, regions, and revision 
schedules.

• Set up Visibility/Graphic override filters for various categories of elements.

• Create and apply view templates.
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1.1 Preparing Project Templates
A project template is a file that contains information that can be 
used over and over to create new projects. The goal is to save 
time by using company standards, enabling you to concentrate 
on the design. For example, predefined levels (as shown in 
Figure 1–1 for a residential project) and the associated plan 
views and elevations provides a starting point for a model.

Figure 1–1

• Some items in a project template include: 

• Levels

• Project-based settings (e.g., Project Units, Object Styles 
and discipline-specific settings, etc.)

• System Families

• Component Families 

• Annotation Types

• Sheets with associated title blocks

• Views 

• View Templates

• Schedules and Legends

• You can have several project templates for different types of 
projects or building types, such as residential, commercial, 
and industrial. 

• If you provide constant work to a specific client (e.g., a school 
system), you can create a template specific to their projects 
with associated title blocks and other information. 

• You can also store items such as sheets, schedules, families, 
and drafting views (details) in a separate resource file and 
add the elements to the current project, as required.
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How To: Create a Project Template File

1. In the File tab, expand  (New) and click (Project).
2. In the New Project dialog box, in the Template File area, 

select a template file to build from or select None to use a 
blank project file.

3. In the Create new area, select Project template, as shown in 
Figure 1–2.

Project template files 
have the extension 
.RTE.

Figure 1–2

4. Click OK.
5. Add settings, families, views, etc., as required to the new file.
6. Save the project template file.

• To save time, use an existing project or template that includes 
some of the basics you need rather than starting from 
scratch.

• If you select <None> in the Template file list, you are 
prompted to specify the initial unit system for the project: 
Imperial or Metric, as shown in Figure 1–3.

Figure 1–3
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Managing
Settings

Most of the settings stored in a template file are found in the 
Manage tab>Settings panel, as shown in Figure 1–4. These 
settings include Units, Snaps, Temporary Dimensions, Object 
Styles (Lineweights, Line color, and Line patterns), Line Styles, 
Materials, Fill Patterns, etc.

• Specific Structural Settings, MEP Settings, and Panel 
Schedule Templates are also included in this panel.

Figure 1–4

For more information on managing settings see: 

• A.1 General Settings

• A.2 Creating Object Styles

• A.3 Creating Fill Patterns

• A.4 Creating Materials

• A.5 Settings for Mechanical Projects

• A.6 Settings for Electrical Projects

• A.7 Settings for Structural Projectsam
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 Families in
Templates

There are two types of families that can be setup in template 
files: system families, such as the Duct shown in Figure 1–5, and 
component families, such as the Air Terminal shown in 
Figure 1–5.

Figure 1–5

System Families are created by duplicating an existing type and 
modifying the Type Properties, as shown in Figure 1–6. This 
must be done within a project and it helps to have the company 
standard for these families setup in a template file. System 
families include Walls, Wall Foundations, Floors, Slabs, Ceilings, 
and Roofs. They also include Duct, Pipe, Cable Tray and 
Conduit types and annotation elements such as text and 
dimensions.

For more information on 
setting up system 
families see Chapter 3 
Custom System 
Families.

Figure 1–6
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Component Families are created outside of a project and can 
be loaded directly in a template file if there are types and sizes 
that are used frequently. Component families include elements 
such as furniture, trees, beams, columns, mechanical 
equipment, and electrical fixtures, as shown in the Type Selector 
in Figure 1–7. 

For more information on 
creating component 
families see Chapter 4 
Component Family 
Concepts.

Figure 1–7

Using Resource
Projects

Although you can use a template file to start a project, you might 
also want to have resource projects that include additional 
system and component families, pre-drawn details (as shown in 
Figure 1–8), schedules, and sheets. You can then copy these 
elements into a new template or the current project, as required.

Figure 1–8
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• To copy drafting views (details), sheets, schedules, or reports 
into the current project, use Insert Views from File.

• To copy system families (e.g., wall, floor, duct, pipe, wire 
types, etc) or annotations (e.g., text and dimension styles, 
materials, etc.), use Transfer Project Standards.

• To copy component families from a resource project, use 
Copy to the Clipboard and either Paste Aligned to 
Selected Levels or Paste Aligned to Selected Views.

How To: Insert Views from an Existing Project

1. In the Insert tab>Import panel, expand  (Insert from File) 

and click  (Insert Views from File).
2. In the Open dialog box, select the project file you want to 

copy from.
3. In the Insert Views dialog box, select the views you want to 

insert into the current project, as shown in Figure 1–9. 

Figure 1–9

4. Click OK. The views are added to the file.

• Schedules are completed with the information in the current 
project. Sheets are added, but do not include any views.am
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How To: Transfer Project Standards

1. Open the project from which you want to transfer information.
2. Switch to the current project you are copying to.

3. In the Manage tab>Settings panel, click  (Transfer Project 
Standards).

4. In the Select Items To Copy dialog box, expand the Copy 
from drop-down list and select the file to copy from.

Click Check None or 
Check All, as required.

5. Select the items you want to copy into the current project, as 
shown in Figure 1–10. Then, click OK.

Figure 1–10

• If the Duplicate Types dialog box displays (shown in 
Figure 1–11), choose Overwrite or New Only to update the 
existing project.

Figure 1–11
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Setting Default
Template Files

If your company uses several different templates, you can create 
a list that displays in the New Project dialog box, as shown in 
Figure 1–12. The top five templates also display on the Recent 
Files page.

Figure 1–12

How To: Set the Default Template Files List

1. In the File tab, click Options. 
2. In the Options dialog box, in the left pane, select File 

Locations, as shown in Figure 1–13. 

Figure 1–13

• Use  (Add Value) to list additional templates.

• Use  (Move Rows Up) and  (Move Rows Down) to 
order the templates. Move the templates that are used 
most often to the top

•  Use  (Remove Value) if you do not require a template 
anymore.

3. Type in a Name.
4. Click on the Path column and select the browse button. In the 

Browse for Template File dialog box, navigate to the correct 
folder, select the template file, and click Open.
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Practice 1a Prepare Project Templates 
 

In this practice, you will create a new template file based on an 
existing template and add several levels to the project. You will 
review the existing system and component families and load a 
component family. You will then insert views and transfer project 
standards from a resource project, as shown for Text Types 
before in Figure 1–14 and after in Figure 1–15.

Practice Objectives

• Create a new project template file.

• Add levels with plan views.

• Review existing system and component families

• Load a component family

• Insert views and transfer project standards from a resource project.

Figure 1–14 Figure 1–15

Before After
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Task 1 - Establish a project template file.

1. In the File tab, expand  (New) and click (Project).

2. In the New Project dialog box, select an existing template file 
similar to your primary discipline. Do not select the 
Construction Template. 

• For electrical, click Browse... and select 
Systems-Default.rte or Electrical Default.rte

3. In the Create New area, select Project template and 
click OK.

4. In the Quick Access Toolbar, click  (Save) and save the 
template in the practice files folder as Midrise-Template.rte. 

Task 2 - Add Default Levels (Architectural and Structural 
only).

• MEP templates typically do not have additional levels. They 
are created using Copy/Monitor with a linked file. Skip to the 
next task.

1. Open an elevation view. 

2. Click on the level head and rename Level 1 to Floor 1 and 
Level 2 to Floor 2. Click Yes to rename the corresponding 
views. 

3. Change the Floor 2 height as shown in Figure 1–16.

Figure 1–16

4. In the Architecture or Structure tab>Datum panel, click 

 (Level).
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5. In the Options Bar, verify that the Make Plan View option is 
selected and click Plan View Types....

6. In the Plan View Types dialog box, select the view types that 
you want to create:

• Architectural template: Select Ceiling Plan and Floor 
Plan, as shown in Figure 1–17. 

• Structural template: Select only Structural Plan, as 
shown in Figure 1–18. 

7. Add three more levels above the current levels and two levels 
below Floor 1. Rename them as shown in Figure 1–19. Click 
Yes to rename the corresponding views as needed.

Scale change and 
dimensions are added 
for clarity.

Figure 1–19

Figure 1–17 Figure 1–18
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8. Return to the plan view.

9. Save the template.

Task 3 - Review Existing Family Elements in the Template.

1. In the Annotate tab> Text panel click  (Text).

2. Expand the list in the Type Selector. Only a few text types are 
available, as shown in Figure 1–20.

Figure 1–20

3. Select a command that uses a system family such as Wall, 
Duct, Pipe, or Conduit and review the list in the Type 
Selector.

4. Select a command that uses a component family such as 
Component, Structural Column, Mechanical Equipment, 
or Electrical Equipment and review the list in the Type 
Selector.

5. In the ribbon in the Select panel, click Modify.

6. In the Insert tab>Load from Library panel, click  (Load 
Family).

• By using the Load Family command you can load any 
type of component. If you use a specific command such 
as Column or Mechanical Equipment you can only load 
that type of family.

7. In the Load Family dialog box, navigate to an appropriate 
folder and select a family to load and click Open.

8. Review the list in the Type Selector again to see the new 
component added.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2018, ASCENT - Center for Technical Knowledge® 1–13



Autodesk Revit 2019 BIM Management: Template and Family Creation

S

9. Click Modify.

10.Save the template.

Task 4 - Copy Information from a Resource Project.

1. Close any open projects other than the template file.

2. In the Insert tab> Import panel, expand  (Insert from File) 

and click  (Insert Views from File).

3. In the Open dialog box, navigate to the practice 
files>Reference folder, select Construction Resource 
Project.rvt, and click Open.

4. In the Insert Views dialog box, scroll through the list of 
options.

5. Select one or two drafting views and one or two schedules 
from the list as shown in Figure 1–21. 

Figure 1–21
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6. Click OK.

7. If the Duplicate Types warning displays, click OK.

8. In the Project Browser of your template file, review the new 
Drafting Views and Schedules that are added. 

9. Return to the original plan view.

10. In the Manage tab> Settings panel, click  (Transfer 
Project Standards.

11. In the Select Items to Copy dialog box, note that Copy from: 
is set to Construction Resource Project.rvt, the one that 
was just used for inserting a view from a file.

12.Click Check None, select Text Types (as shown in 
Figure 1–22), and click OK.

Figure 1–22

13. In the Duplicate Types dialog box, select New Only, if 
required.
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14.Start the Text command and look at the expanded list of text 
types that are now available, as shown in Figure 1–23.

Figure 1–23

15.Click Modify.

16.Save the template file.
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1.2 Customizing Annotation 
Types

You can customize Annotation types in your project template file 
including dimensions, text types, and tags, as shown in 
Figure 1–24.

Figure 1–24

Text, Dimensions, and Arrowheads are all system families. This 
means they have a standard set of parameters, which you can 
modify and save as a type. Callout, Section, and Elevation tags 
can be modified in the Autodesk Revit software. Most other tags 
are created using component families.

Creating Text
Types

Text types are used to standardize text formatting (such as the 
font, text height, etc.), as shown in Figure 1–25. They can be 
created for both annotative text and Model Text.

Figure 1–25

• The Text command places text at the height you need for the 
final plot. The view scale controls the height of the standard 
text in the views.

• The Text Size parameter represents the height of a capital 
letter. (Verify that the text in projects created in earlier 
versions of the software displays as expected.)

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2018, ASCENT - Center for Technical Knowledge® 1–17



Autodesk Revit 2019 BIM Management: Template and Family Creation

S

• The Model Text command places text that is typically used 
on the building, such as the signage shown in Figure 1–26. 
Text types for Model Text should be the full height of the final 
element and are not affected by the view scale.

Figure 1–26

How To: Create a Text Type

1. Start the Text command. In Properties, click  (Edit Type) 
or in the Annotate tab>Text panel title, click  (Text Types). 

• For Model Text you first have to place an instance, select 
it, and modify the type properties.

2. In the Type Properties dialog box, click Duplicate....
3. Type a new name and click OK.The new type is activated.
4. Modify the parameters as required for the new type, as 

shown for annotation text in Figure 1–27.

Figure 1–27

5. Click OK to finish.
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Creating
Dimension

Types

Dimensions are one of the more complex system families in 
terms of the number of parameters you can modify. They include 
options for the Dimension Text, Dimension Line, Tick Marks, and 
Witness Lines. You can specify information such as the units, 
color, and all of the gap sizes between elements, as shown in 
Figure 1–28.

Figure 1–28

How To: Create Dimension Types

You create separate 
types for each 
dimension method. 

1. In the Annotate tab>Dimension panel, expand the Dimension 

panel title (as shown in Figure 1–29), and click  next to 
the dimension type you want to create.

Figure 1–29

2. In the Type Properties dialog box, click Duplicate....

Witness Line

Set gap between witness 
line and reference

Tick Mark

Dimension Text

Dimension Line
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3. Type a new name and click OK. The new type is activated.
Values for parameters 
(such as text size, 
witness line extension, 
etc.) are the actual plot 
size for these elements. 
The view scale controls 
how large they are in 
the specific view.

4. Modify the parameters as required for the new type, as 
shown in Figure 1–30. 

Figure 1–30

5. Click OK when you are finished.

• For Linear dimensions, you can specify a Leader Type, 
Shoulder Length, Leader Tick Mark, and Show Leader When 
Text Moves that is used when the text is pulled away from the 
dimension string. You can also specify the text inserted for 
Equality Text (the default is EQ).

• You can specify a Text Background option. If you set the 
value to opaque, it automatically masks any elements behind 
the text. If it is set to transparent, anything the text overlaps 
is still visible.

• If you are dimensioning doors and windows by their widths 
rather than their centers, you can also have the opening 
height displayed with the dimension. Select Show Opening 
Height.

Loading Tags
and Symbols

Tags and symbols are 2D component families that must be 
loaded into a project. Not all types of tags need to be in each 
project, so you can choose which ones you want to include in 
your templates. For example, if you are working in an 
architectural project, you can load tags such as the door, 
window, and wall shown in Figure 1–31. 
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Figure 1–31

How To: Specify Loaded Tags and Symbols

1. In the Annotate tab>Tag panel, expand the panel title and 

click  (Loaded Tags and Symbols).

Some elements, such 
as Floors and Structural 
Fabric Reinforcement, 
have both tags and 
symbols. They can both 
be specified in this 
dialog box.

2. In the Loaded Tags and Symbols dialog box, use the Filter 
field to limit the types of tags you are looking for by discipline, 
as shown in Figure 1–32.

Figure 1–32
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3. Click Load Family....
4. In the Load Family dialog box, navigate to the appropriate 

library and folder. 
5. Select the required tags and click Open. Hold <Ctrl> or 

<Shift> to select multiple tags.
6. When you have loaded all of the tags that you typically need 

for a project, click OK.

Specifying
View Tags

Callout, Elevation, and Section tags can be modified to suit an 
office standard. The tag is actually part of a view type. For 
example, you can create a new Elevation view type containing a 
tag that displays the view name, as shown in Figure 1–33.

Figure 1–33

How To: Create Tags for View Types: Callout, 
Elevation, and Section

1. Click  (Callout),  (Elevation), or  (Section), as 

required, and in Properties, click  (Edit Type). Or, in the 

Manage tab>Settings panel, expand (Additional Settings) 

and click  (Callout Tags), (Elevation Tags), or 

(Section Tags). 
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2. In the Type Properties dialog box, select an existing type, 
then duplicate and name the new view type, as shown for an 
elevation view in Figure 1–34.

Each view type has 
different parameters.

Figure 1–34

3. Beside the Tag parameter, click in the Value column and then 

click  (Browse). 
4. In the Type Properties dialog box for the tag, select from an 

existing type or duplicate a type, and specify a new mark 
element from a list of families that have been inserted into the 
project, as shown in Figure 1–35.

Figure 1–35
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5. Click OK to apply the tag type.
6. Modify the other parameters as required and click OK to 

close the Type Properties dialog box.

• Levels (shown in Figure 1–36) and Grids (shown in 
Figure 1–37) are also system families that are setup in Type 
Properties and include component families such as the 
Symbol Level Head-Circle and Grid Head-Circle.

Figure 1–36 Figure 1–37
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Practice 1b Customize Annotation Types
 

In this practice, you will create text types, duplicate and modify 
dimension styles (as shown in Figure 1–38), and load typical 
tags into the project template file. You will also create a new 
elevation tag that includes the view name information.

Figure 1–38

Task 1 - Create Text Types.

1. Open the project template Midrise-Template.rte that you 
created in the previous practice. If you did not complete the 
previous practice, open the template found in the practice 
files folder:

• Architectural>Midrise-Template-Architectural-1.rte 

• MEP>Midrise-Template-MEP-1.rte

• Structural>Midrise-Template-Structural-1.rte 

2. Start the Text command. 

3. In Properties, click  (Edit Type)

4. In the Type Properties dialog box, click Duplicate....

Practice Objectives

• Set up text and dimension types.

• Load tags.

• Create a new view tag.
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5. Type the Name Title Small and click OK.The new type is 
activated.

6. In the Text area, select a font and other options, as required. 
Set the Text Size to 1/4", as shown in Figure 1–39.

Figure 1–39

7. Click OK and type in some text using the new text type.

8. Create a duplicate of the new text type named Title Large. 
Change the Text Size to 1/2" and add some text using the 
new type, as shown in Figure 1–40.

Figure 1–40

9. Save the template file.
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Task 2 - Create Dimension Styles

1. Model a few linear elements (such as walls, beams, or duct) 
and add two linear and two angular dimensions shown in 
Figure 1–41.

Figure 1–41

2. Click Modify.

3. Select the outer most linear dimension.

4. In the Properties, click Edit Type. 

5. In the Type Properties dialog box, duplicate the type and 
name it Linear - Standard.

6. In the Text area, change the Text Size to 1/8".
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7. Click on Units Format. In the Format dialog box, clear the 
checkmark for Use project settings and change the 
Rounding to the nearest 1/8", as shown in Figure 1–42.

Figure 1–42

8. Click OK twice to finish. The linear dimension updates to the 
new style.

9. Select the outermost angular dimension. Duplicate the type 
and name it Angular - Standard.

10. In the Type Properties dialog box, in the Graphics area, 
change the Tick Mark to Arrow Filled 30 Degree.

11. In the Text area, change the Text Size to 1/8" and the Units 
Format to 0 decimal places. 
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12.Click OK twice to finish. The angular dimension updates as 
shown in Figure 1–43.

Figure 1–43

13.Select and delete the sample text, elements, and dimensions.

14.Save the template.

Task 3 - Load Tags

1. In the Annotate tab, expand the Tag panel title, and click

 (Loaded Tags and Symbols).

2. In the Loaded Tags and Symbols dialog box, set the Filter List 
to match your discipline(s).

3. Click Load Family... and load the following tags from the 
Revit Library>Annotations folder subfolders into the 
discipline-specific project template:

Architecture:

Folder Tag Name

Architectural Casework Tag.rfa, Furniture Tag.rfa, and Furniture 
System Tag.rfa
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MEP:

Structure:

4. The tags are automatically assigned to the correct Category, 
as shown for the Architectural tags in Figure 1–44. 

Figure 1–44

5. Click OK.

6. Save the template file.

Folder Tag Name

Mechanical> 
Duct

Duct Fitting Tag.rfa

Electrical Lighting Fixture Tag.rfa

Piping Pipe Fitting Size Tag.rfa

Folder Tag Name

Architectural Wall and Floor

Structural Select any different Structural tags you might want to 
use in place of those already loaded.
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Task 4 - Modify a Elevation Tag

1. In the plan view, zoom to where you can see one of the 
existing building elevation view markers.

2. Select the pointed end of the marker.

3. In the Type Selector, verify that Elevation> Building 
Elevation is selected. 

4. In Properties, click Edit Type.

5. In the Type Parameters, select the Value beside Elevation 
Tag and then click the ... (Browse) button.

6. A second Type Properties dialog box displays for the 
Elevation Mark. Duplicate this type and add ...with Name to 
the end.

7. In the Elevation Mark drop-down list, select Elevation Mark 
Body_Square: Detail Number and View Name, as shown 
in Figure 1–45.

Figure 1–45am
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8. Click OK twice. The Elevation Tag updates as shown in 
Figure 1–46.

Figure 1–46

9. Zoom to fit the view.

10.Save the template.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–32 © 2018, ASCENT - Center for Technical Knowledge®



Creating Custom Templates

S

1.3 Creating Title Blocks
Title blocks (as shown in Figure 1–47) contain information about 
the company and consultants designing the project, project 
information (such as project name and number), and 
sheet-specific information (such as sheet numbers and drawn 
by). They are created by sketching detail lines and adding text, 
symbols, and regions, as well as image files for company logos. 
The variable information is stored in labels.

Some of these 
parameters never 
change, some are 
project-specific, and 
some are sheet-specific.

Figure 1–47

• Once you have title blocks customized you can add them to 
templates and setup views and sheets in the template.

How To: Create a Title Block

1. In the File tab, expand  (New) and click  (Title Block).
You can select from 
several preset sizes or 
create a custom size.

2. In the New Title Block - Select Template File dialog box, 
select a template file size from the list and click Open. A new 
family file opens and the Family tools display in the ribbon, as 
shown in part in Figure 1–48. 

Figure 1–48
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3. Add lines, filled regions, symbols, text, labels, etc., as 
required.

4. Save and close the file.

• If you select a template with a standard size, a rectangle of 
that size displays in the view.

• If you select New Size, a rectangle with dimensions displays. 
Edit the dimensions to modify the size.

• You can use reference lines and dimensions to help place the 
elements in the title block family, they are not displayed when 
the title block is inserted.

Adding Labels Labels are not just text but elements that are assigned to specific 
parameters and can be added to title blocks or tags. They can 
change without modifying the rest of the elements. For example, 
you would use annotation text for the words Drawn By: and a 
label for the initials of the person who did the work (by default 
displaying DRW in Figure 1–49), because that varies from sheet 
to sheet.

Figure 1–49

• The title block template comes with one text type and one 
label type already defined. You can create additional types in 
Properties by duplicating types. The Text and Label 
parameters are similar, but you must create separate types 
for each of them.

• Labels use Rich Text Format so that they match text notes.

How To: Create a Label

1. In the Family Editor, in the Create tab>Text panel, click 

 (Label).am
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2. In the Modify | Place Label tab>Format panel, specify the 
alignments: Left, Center, Right, Top, Center Middle, or 
Bottom, as shown in Figure 1–50.

Figure 1–50

3. Click in the view window to place the label, as shown in 
Figure 1–51. 

Figure 1–51

4. In the Edit Label dialog box (shown in Figure 1–52), select a 
label in the Category Parameters list and double-click or click 

 (Add parameter(s) to label). You can select more than 
one by holding <Ctrl> or <Shift>. 

Figure 1–52
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5. Enter the Sample Value and specify any other options, as 
required.

• If you are using several parameters in one label, select 
Wrap between parameters only and Break (in column) 
options to separate them while still permitting a word 
wrap, as shown in Figure 1–53.

Figure 1–53

• Click  (Move parameter up) and  (Move 
parameter down) to reorder multiple parameters.

• If you select a numerical parameter, click  (Edit 
parameter’s units format) to change, if required.

For more information on 
creating parameters and 
calculated parameters, 
see 2.6 Working with 
Project Parameters.

• Click  (Add calculated parameter to label) to use a 
formula based on other parameters.

• Click  (Add Parameter) to create a new parameter for 
the project.

6. Click OK when you have finished editing the label.

• While placing the label, you can rotate or stretch it (as shown 
in Figure 1–54), or select a point for an additional label.

Figure 1–54

• You can also rotate or stretch a label once it has been placed 
in the title block.

Two labels without break

Two labels with break
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Adding
Revision

Schedules

A table of revisions included in a project and/or sheet is typically 
added to a company title block, as shown in Figure 1–55. In the 
Autodesk Revit software, you can create a Revision Schedule 
that is then linked to the Revision Table in the project. 

Figure 1–55

How To: Add Revision Schedules to Title Blocks

1. In the Family Editor, in the View tab>Create panel, click

 (Revision Schedule). 
2. In the Revision Properties dialog box, select the fields you 

want to use. Several are already selected for you, as shown 
in Figure 1–56. 

Figure 1–56

3. Modify the options in the Sorting/Grouping and Formatting 
tabs, as required. am
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4. In the Appearance tab, select how you want to build the 
schedule: from the Top-down or Bottom-up. You can also 
set the Height to Variable or User-Defined, as shown in 
Figure 1–57.

Figure 1–57

5. Click OK. The schedule view displays, as shown in 
Figure 1–58.

6. Click on the sheet view tab (it has no name) to reopen it as 
shown in Figure 1–59.

7. Drag and drop the schedule onto the sheet and modify the 
controls, as shown in Figure 1–60.

If the height is set to 
User-Defined, an 
additional control 
displays at the bottom of 
the schedule. Use it to 
set the height of the 
schedule.

Figure 1–60

• In the Options Bar, you can change the Rotation on the Sheet 
to None, 90° Clockwise, or 90° Counterclockwise.

Figure 1–58 Figure 1–59

User Defined controlam
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Adding Sheets
to Project
Templates

You can create sheets that are typically used in projects in the 
template and even place views on them, as shown in 
Figure 1–61. Note that the view is empty in the template, but as 
you draw elements in the project they automatically display in the 
view and on the sheet.

Figure 1–61

• You can create as many sheets as are typically used in a 
project or you can create a Sheet List and populate it with 
sheet names that can be used as placeholder sheets.

• You can also copy sheets from a resource project.

• For more information on creating Sheet Lists, see A.8 
Additional Schedule Types.
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Presetting a Starting View

When you create a project template or project, it can help to 
specify a starting view. This can be any of the standard views, 
such as plan, elevation, 3D view, or one that is specifically 
created. This is often a Drafting View (as shown in Figure 1–62), 
or a Legend View with information about the project or the cover 
sheet for the project.

Figure 1–62

How To: Set a Starting View

1. Set up the view or sheet that you want to use as the starting 
view.

2. In the Manage tab>Manage Project panel, click  (Starting 
View).

3. In the Starting View dialog box, select the view or sheet that 
you want to use as shown in Figure 1–63.

The Default starting 
view is <Last Viewed>.

Figure 1–63

4. Click OK.
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Practice 1c Create Title Blocks

In this practice, you will create a new title block by adding lines, 
text, labels, logo, and a Revision Schedule similar to 
Figure 1–64. You will then load it into a project template file and 
create several standard sheets.

Figure 1–64

Practice Objectives

• Draw a custom title block including detail lines, text, labels, and a 
revision table.

• Set up sheets in the template using the new title block.
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Task 1 - Create a title block.

1. In the File tab, expand  (New) and click 

 (Title Block). 

2. In the New Title Block - Select Template File dialog box, 
select D - 36 x24.rft and click Open.

3. In the Create tab>Detail panel, click  (Line) and create 
lines on the inside of the existing rectangle 1/4" away from 
the top, bottom, and right sides. Draw a line 1" away on the 
left margin. Trim the lines as required.

4. Draw lines in the lower right corner of the title block, as 
shown in Figure 1–65.

Figure 1–65

5. In the Create tab>Detail panel, click  (Symbol).

6. In the Modify | Place Symbol tab>Mode panel, click 

(Load Family).

7. Navigate to the practice files>Reference folder, select 
Company Logo.rfa, and click Open.

8. Add the symbol to the lower left corner of the new title block. 
It is designed to fit within the square.

9. In the Create tab>Text panel, click  (Text). 
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10. In Properties, click  (Edit Type) and create the following 
Text type:

11. In the Create tab>Text panel, click  (Label).

12. In Properties, click  (Edit Type) and create the following 
Label types:

13.Using the following steps, add text and labels to the title 
block, as shown in Figure 1–66.

Figure 1–66

Type Name Font Size Bold Background

Arial 1/16" Arial 1/16" No Transparent

Type Name Font Size Bold Background

Arial 1/8” Arial 1/8” No Transparent

Arial 1/4” Arial 1/4" No Transparent
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You can use Reference 
Lines to place the text 
and labels exactly.

• Use  (Text) with the text type Arial 1/16" to add text in 
the lower right spaces for the Date, Project Number, 
Drawn By, and Sheet Number.

• Use  (Label) with the label type Arial 1/4" and

 (Align Center) justification to add the Sheet Name, 
Project Name, and Sheet Number. Move and stretch the 
labels to fit in the title block.

• Using the label type Arial 1/8" and  (Align Center) 
justification, add the Project Address below the Project 
Name.

• Using the label type Arial 1/8" and  (Align Right) 
justification, add the Project Issue Date, Project Number, 
and Drawn By. Save the title block in the practice files 
folder as Company TBLK.rfa.

Task 2 - Add a Revision Schedule to the title block.

1. In the title block Family Editor, in the View tab>Create panel, 

click  (Revision Schedule).

2. In the Revision Properties dialog box, Fields tab, set up the 
fields as shown in Figure 1–67. 

Figure 1–67

3. Accept the defaults for the Sorting/Grouping and Formatting 
tabs. 

4. Select the Appearance tab and change the Height to User 
defined.

5. Click OK.
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6. Return to the Sheet view.

7. In the Project Browser, expand Views (all) to display the 
Schedules and Sheets (all) areas, as shown in Figure 1–68.

Figure 1–68

8. Drag and drop the Revision Schedule onto the sheet.

9. Move it above the sheet name and resize it to display several 
lines, as shown in Figure 1–69. Align it to the edge of the title 
block.

Figure 1–69

10.Save and close the title block.

Task 3 - Set up sheets in a project template using the new 
title block.

1. Open the template found in the practice files folder that 
relates to your discipline:

• Architectural>Midrise-Template-Architectural-2.rte 

• MEP>Midrise-Template-MEP-2.rte 

• Structural>Midrise-Template-Structural-2.rte 
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2. In the View tab>Sheet Composition panel, click  (Sheet).

3. In the New Sheet dialog box, click Load.... 

4. In the Load Family dialog box, navigate to the practice files 
folder, select Company TBLK.rfa (that you just created), and 
click Open. 

• If you did not complete the previous tasks, open Sample 
TBLK.rfa from the practice files>Reference folder.

5. Select the title block that you just loaded and click OK.

6. In the Project Browser, select the sheet and rename it as 
CS000 – Cover Sheet.

7. Using the Title Large text type, add placeholder text for the 
project name and address, as shown in Figure 1–70.

Figure 1–70

8. In the Manage tab>Manage Project panel, click  (Starting 
View).
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9. In the Starting View dialog box, select Sheet: CS000 - Cover 
Sheet as shown in Figure 1–71. 

Figure 1–71

10.Create another sheet with the new title block and name it 
according to your discipline:

• A201 – First Floor Plan

• M201 - First Floor Plan Mechanical

• E201 - First Floor Plan Electrical

• P201 - First Floor Plan Plumbing

• S201 - First Floor Plan Structural

11. Open this sheet view. Drag the associated Level 1 floor plan 
view onto the sheet, as shown in Figure 1–72.

No elements are on the 
view, but it acts as a 
placeholder on the 
sheet. Elements display 
as they are drawn.

Figure 1–72

12.Save and close the template file.
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1.4 Setting Up View Filters
Rule-based view filters used in conjunction with Visibility/Graphic 
Overrides are a powerful tool that can be saved in template files. 
They can be used to test conditions in a project or modify the 
information that display in a view. For example, a fire evacuation 
plan might have walls with different fire ratings that display with 
thicker lineweights, as shown in Figure 1–73. MEP projects 
frequently use view filters to control which systems display in a 
view.

Figure 1–73

• Rule-based Filters are used in Visibility/Graphic Overrides 
and Selection Filters are used by Selection Sets.

How To: Create Filters

1. In the View tab>Graphics panel, click  (Filters). The Filters 
dialog box opens as shown in Figure 1–74.

Figure 1–74

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–48 © 2018, ASCENT - Center for Technical Knowledge®



Creating Custom Templates

S

2. In the Filters area, select the Rule-based Filters node or an 

existing filter and click  (New) or  (Duplicate), as shown 
in Figure 1–75. Name the new filter and click OK.

3. In the Categories area, filter the list by discipline and then 
select the categories to include in the filter, as shown in 
Figure 1–75. Use Check All and Check None to help select 
the categories.

Figure 1–75

• Although you can select multiple categories, you can only 
filter by the parameters the categories have in common.

4. In the Filter Rules area, select the Condition (type of filter) 
you want to create (AND or OR) as shown in Figure 1–76.

Figure 1–76
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5. Then, for each filter, specify the Parameter, Operator, and 
Value, as shown in Figure 1–77. 

Figure 1–77

• Click Add Rule to add a rule to the existing Condition.

• Click Add Set to add a nested Condition and filters.

6. Click Apply to save the changes and remain in the dialog 
box, or click OK to finish.

• If you create more than one filter rule, they are applied in 
order.

• Building nested filters is complex. It is recommended to start 
with an AND condition and then add OR conditions to further 
identify the elements.

• Test your filters thoroughly before applying them in a 
template.

How To: Apply Visibility/Graphic Overrides Filters

1. Type VG or VV or in the View tab>Graphics panel, click

 (Visibility/Graphics) to open the Visibility/Graphic 
Overrides dialog box. Select the Filters tab, as shown in 
Figure 1–78.

Figure 1–78

Parameter Operator Value
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2. Click Add to add a filter to the list.
3. In the Add Filters dialog box, select the filter(s) you want to 

add, as shown in Figure 1–79. Then, click OK.

Figure 1–79

• If the filter you want is not defined, click Edit/New... to 
open the Filters dialog box, where you can define a new 
filter or edit an existing one.

4. In the Visibility/Graphic Overrides dialog box, assign the 
overrides you want for the filter, as shown in Figure 1–80.

Figure 1–80

5. Click OK.

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
© 2018, ASCENT - Center for Technical Knowledge® 1–51



Autodesk Revit 2019 BIM Management: Template and Family Creation

S

Practice 1d Set up View Filters - Architecture

In this practice, you will create rule-based filters. You will 
duplicate a view and add the filters with overrides setup in 
Visibility/Graphic Overrides. The original view and modified view 
are shown in Figure 1–81. 

Figure 1–81

Note: This practice uses view filters in an existing project so you 
can see the impact of what they do. They should be setup 
originally in a template.

Task 1 - Create filters.

1. In the practice files Architectural folder, open Office-Fire 
Ratings.rvt.

2. In the View tab>Graphics panel, click  (Filters).

3. In the Filters dialog box, click  (New), name the new filter 
Fire Rating - 1 Hour, and click OK.

4. In the Categories area, set the Filter list to Architecture. 
Select Walls.

Practice Objectives

• Create rule-based filters.

• Add view filters to a view and setup overrides.

Original View Duplicated View with Filters and Overrides
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5. In the Filter Rules area, set the AND condition to Fire Rating 
- equals - 1 Hour, as shown in Figure 1–82.

Figure 1–82

6. Click Apply and remain in the Filters dialog box.

7. Select the new Fire Rating - 1 Hour filter and click

 (Duplicate).

8. Right-click on the duplicated filter and click  (Rename). In 
the Rename dialog box, type Fire Rating - 2 Hours and 
click OK.

9. Modify the Filter Rule to Fire Rating - equals - 2 Hours, as 
shown in Figure 1–83.

Figure 1–83

• Note: You will need to type in 2 Hours because this fire 
rating does not yet display in the project. 

10.Click OK to close the Filters dialog box.

Task 2 - Test the View Filters

1. Duplicate the Floor Plans>Level 1 view and name it Level 1 - 
Fire Ratings.

2. Open only the Level 1 and Level 1 - Fire Ratings views and 
type WT to tile them side by side. 

3. Zoom in on the core of the building in both views. 

4. In the Level 1 - Fire Ratings view, open the Visibility/Graphic 
Overrides dialog box. 
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5. In the Filters tab, click Add.

6. In the Add Filters dialog box, select the fire rating filters, as 
shown in Figure 1–84. Then, click OK.

Figure 1–84

7. For the Fire Rating - 1 Hour filter, in the Cut>Patterns 
column, select Override.

8. In the Fill Pattern Graphics dialog box, change the 
Foreground Pattern to Solid Fill and Color to an orange, as 
shown in Figure 1–85. Click OK.

Figure 1–85
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9. Repeat the process for the 2-hour fire wall using a different 
color, as shown in Figure 1–86.

Figure 1–86

10.Click OK. The Filter overrides display in the Fire Ratings view 
but not in the original view.

11. Select one of the exterior walls (Basic Wall (WT-04)) and in 
Properties, click Edit Type.

This is an example. 
Typically, exterior walls 
are not setup with this 
type of fire rating unless 
they are part of a fire 
wall.

12.Scroll down to the Identity Data section and beside Fire 
Rating, type in 2 Hours, as shown in Figure 1–87. Then, 
click OK.

Figure 1–87

• The value of the Fire Rating parameter must match the 
name of the filter exactly. Edit the filter if the walls do not 
change color.

13.Save and close the project. 
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Practice 1e Set up View Filters - Structure

In this practice, you will create rule-based filters. You will 
duplicate a view and apply the filters with overrides setup in 
Visibility/Graphic Overrides. The modified view is shown in 
Figure 1–88. 

Figure 1–88

Note: This practice uses view filters in an existing project so you 
can see the impact of what they do. They should be setup 
originally in a template.

Task 1 - Create filters.

1. In the practice files Structural folder, open 
Office-Materials.rvt.

2. In the View tab>Graphics panel, click  (Filters).

Practice Objectives

• Create rule-based filters.

• Add view filters to a view and setup overrides.
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3. In the Filters dialog box, click  (New), name the new filter 
Concrete and click OK.

4. In the Categories area, set the Filter list to Structure. Select 
Structural Columns, Structural Foundations, Structural 
Framing and Walls.

An alternate way to 
make these filters is to 
do one for each 
material.

5. In the Filter Rules area, set the OR condition to Structural 
Material - equals - Concrete - Cast-in-place Concrete, as 
shown in Figure 1–89.

Figure 1–89

6. Click Add Rule and add another rule: Structural Material - 
equals - Concrete Mason Units. 

7. Click Apply and remain in the Filters dialog box.

8. Select the new Concrete filter and click  (Duplicate).

9. Right-click on the duplicated filter and click  (Rename). In 
the Rename dialog box, type Steel and click OK.

10.Modify the Filter Rules to Structural Material - equals - 
Metal - Steel - ASTM A500 - Grade B - Rectangular and 
Square and Metal - Steel - ASTM A992, as shown in 
Figure 1–90.

Figure 1–90

11. Click OK to close the Filters dialog box.
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Task 2 - Test the View Filters

1. In the Project Browser, duplicate 3D Views>{3D} view and 
rename it to Structural Materials - 3D.

2. Open the Visibility/Graphic Overrides dialog box. 

3. In the Filters tab, click Add.

4. In the Add Filters dialog box, select both of the filters, as 
shown in Figure 1–91. Then, click OK.

Figure 1–91

5. For the Concrete Filter in the Projection/Surface>Patterns 
column, select Override.

6. In the Fill Pattern Graphics dialog box, change the 
Foreground Pattern to Solid Fill and Color to an orange, as 
shown in Figure 1–92. Click OK.

Figure 1–92
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7. Repeat the process for the Steel using a different color, as 
shown in Figure 1–93.

Figure 1–93

8. Click OK. The Filter overrides display in the view.

9. Save and close the project.
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Practice 1f Set up View Filters - MEP

In this practice, you will create rule-based filters. You will 
duplicate a view and add the filters with overrides setup in 
Visibility/Graphic Overrides. The original view and modified view 
are shown in Figure 1–94. 

Figure 1–94

Note: This practice uses view filters in an existing project so you 
can see the impact of what they do. They should be setup 
originally in a project template.

Task 1 - Create filters.

1. In the practice files MEP folder, open Office-Velocity.rvt.

2. In the View tab>Graphics panel, click  (Filters).

3. In the Filters dialog box, click  (New), name the new filter 
Mechanical - Low Velocity, and click OK.

4. In the Categories area, set the Filter list to Mechanical. 
Select Ducts and Flex Ducts.

Practice Objectives

• Create rule-based filters.

• Add view filters to a view and setup overrides.

Original View Duplicated View with Filters and Overrides
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5. In the Filter Rules area, set the AND condition to Velocity - is 
less than or equal to - 900 FPM, as shown in Figure 1–95.

Figure 1–95

6. Click Apply and remain in the Filters dialog box.

7. Select the new Mechanical - Low Velocity filter and click

 (Duplicate).

8. Right-click on the duplicated filter and click  (Rename). In 
the Rename dialog box, type Mechanical - Medium Velocity 
and click OK.

9. Click Add Rule to create a second rule and set the rules up 
as shown in Figure 1–96.

Figure 1–96

10.Create an additional filter named Mechanical-High Velocity 
set up as shown in Figure 1–97.

Figure 1–97

11. Click OK to close the Filters dialog box.
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Task 2 - Test the View Filters

1. Duplicate the Mechanical>Floor Plans>1 - Mech view and 
name it 1 - Mech - Velocity

2. Open only the 1 - Mech and 1 - Mech - Velocity views and 
type WT to tile them side by side. 

3. Zoom in on the central core of the building in both views. Both 
views display the duct colors setup in the Duct System 
properties for Supply, Return, and Exhaust.

4. In the 1 - Mech - Velocity view, open the Visibility/Graphic 
Overrides dialog box and open the Filters tab. Three existing 
filters are available for the Mechanical duct systems.

5. In the Filters tab, click Add.

6. In the Add Filters dialog box, select the new filters as shown 
in Figure 1–98. Click OK.

Figure 1–98

7. If required, move the Velocity based filters to the top of the list 
using the Up and Down buttons.

8. For the Mechanical-Low Velocity filter, in the 
Projection/Surface>Patterns column, select Override.

9. In the Fill Pattern Graphics dialog box, change the Pattern to 
Solid Fill and the Color to an orange, as shown in 
Figure 1–99. Click OK.
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Figure 1–99

10.For the other velocity filters, create a similar overrides using 
other colors. 

11. For the Supply and Return filters, set the Lines override Color 
to Black with no additional Weight. Then, clear the Visibility 
check on the Exhaust filter, as shown in Figure 1–100.

Figure 1–100

12.Click OK. The Filter overrides display in the velocity view, but 
not in the original view.

13.Save and close the project.am
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1.5 Adding View Templates
View templates, consisting of specific view properties and 
visibility options, ensure that company standards are applied to 
views. For example, you can create a view template that displays 
spaces, but hides the MEP systems in a view (as shown in 
Figure 1–101), while another view template displays duct 
systems but not plumbing fixtures (as shown in Figure 1–102).

Figure 1–101

Figure 1–102

• Many companies lock in view templates for their views to be 
placed on sheets. This prevents anyone from making 
changes, as shown for the detail level in Figure 1–103. 

Figure 1–103
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How To: Create a View Template from an Existing 
View

1. Set up a view the way you want it with Scale, Detail Level, 
Visibility Graphic Overrides, and other View Settings. For 
example, you can create a view template for furniture plans, 
such as that shown in Figure 1–104. 

Figure 1–104

2. In the Project Browser, right-click on the view and select 
Create View Template from View or, on the View tab> 

Graphics panel, expand  (View Template), and click 

(Create Template from Current View).
3. In the New View Template dialog box, type a name for the 

view template.
4. Click OK.
5. In the View Template dialog box, make adjustments as 

required and then click OK.

How To: Set up a View Template

1. In the View tab>Graphics panel, expand  (View Template) 

and then click  (Manage View Templates). 
2. In the Apply View Template dialog box, in the Names list, 

select a view similar to the one you want to create and click 

 (Duplicate).
3. In the New View Template dialog box, type a new name for 

the view template and click OK.
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4. Select the new view template (as shown in Figure 1–105), 
and modify the parameter values in the View Properties area, 
as required.

Figure 1–105

5. Click OK to finish.

• To limit the number of view templates that display, filter the 
list by selecting an option in the Discipline filter and View type 
filter drop-down lists, as shown in Figure 1–106.

Figure 1–106
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• If you do not want specific view properties to be part of the 
view template that is applied to views, clear the checkmark in 
the Include column for the parameters you do not want to 
include. You can also create overrides to the view template 
by changing parameter values.

• Note that the different view types have different view 
parameters. For example, 3D views have options for 
Rendering and Perspectives that plan views do not have. 

How To: Create a New View Type with a View 
Template

1. Open a view of the type you want to create. For example, if 
you want to create a new plan view type, select an existing 
Floor Plan view, or if you want to create a new elevation view 
type, select an existing Elevation view.

2. In Properties, click Edit Type.
3. Duplicate the existing type and give it a new name.

Hint: Setting the View Scale-to-Detail Level 
Correspondence

One view parameter is the Detail Level. There are three 
options: Coarse, Medium, and Fine. You can modify the table 
of scales that are related to the levels. In the Manage tab> 

Settings panel, expand  (Additional Settings) and select 

(Detail Level). The View scale-to-detail level 
correspondence dialog box displays, as shown in 
Figure 1–107.

Figure 1–107
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4. Specify the Callout Tag and Reference Label, set the View 
Template is applied to new view option, and select New 
views dependent on template, if required, as shown in 
Figure 1–108.

Figure 1–108

5. Click OK.

• When you create a new view, you can select the view type 
from the drop-down list, as shown for a new floor plan in 
Figure 1–109. The view is also placed in its own group in the 
Project Browser, as shown in Figure 1–110.

How To: Set the Default View Template for a View

1. In the Project Browser, select one or more views. 
2. In Properties, in the Identity Data section, click the button 

next to View Template, as shown in Figure 1–111. The name 
on the button varies according to the template that has 
already been assigned.

Figure 1–109 Figure 1–110
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Figure 1–111

3. In the Apply View Template dialog box, select the appropriate 
template and click OK.

• You can apply view templates to any view as many times as 
required, unless it is set as the default template in the view 
properties.

• If you want to start a new view template based on an existing 
view, select Show Views. The Names list expands to include 
all of the related views in the project.

Hint: Temporary View Properties

As you are working, it can be helpful to temporarily override 
the view. You can do this by selecting a view template from 
the View Control Bar, as shown in Figure 1–112.

Figure 1–112

1. In the View Control Panel, expand (Temporary View 
Properties) and select Enable Temporary View 
Properties.

2. Expand (Temporary View Properties) again and select 
Temporarily Apply Template Properties. Alternatively, if 
you have already used the process, you can select from a 
list of view templates, as shown in Figure 1–112.

3. In the dialog box, select the view template you want to 
apply and click OK.

4. When you are finished, expand (Temporary View 
Properties) and select Restore View Properties.

• Some companies create a “working view” template to be 
used as a temporary override, rather than having separate 
working views. 
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Practice 1g Add View Templates - 
Architecture

In this practice, you will create view templates from an existing 
view and modify the view template using Manage View 
Templates. You will then duplicate views and apply the view 
templates to other views, as shown in Figure 1–113.

Figure 1–113

Note: This practice uses view templates in an existing project so 
you can see the impact of what they do. They should be setup 
originally in a project template.

Task 1 - Create a View Template from an existing view.

1. In the practice files Architectural folder, open 
Office-Rooms.rvt.

2. In the Level 1 - Fire Ratings view hide the grids, elevations, 
sections, furniture, plumbing fixtures, and similar elements. 
(Hint: Select one element of each category and type VH).

3. In the Project Browser, in the Floor Plans area, right-click on 
the Level 1 - Fire Ratings view and select Create View 
Template From View.

Practice Objectives

• Create a view template from an existing view.

• Create a view template from within Manage View Templates.

• Duplicate views and apply the view templates.
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4. Name the new view template Fire Ratings and click OK.

5. In the View Templates dialog box, next to V/G Override 
Filters, click Edit....

6. In the Visibility/Graphic Overrides dialog box, Filters tab, 
review the Filters and overrides.

7. In the View properties area, in the Include column, clear the 
checkmarks from all of the options except Detail Level, V/G 
Overrides Model, V/G Overrides Annotation, V/G Overrides 
Filters, and Model Display, as shown in Figure 1–114.

Figure 1–114

8. Click OK.

Task 2 - Apply View Templates to views.

1. Duplicate the Level 2 view and rename it as Level 2 - Fire 
Ratings.

2. In Properties, in the Identity Data group, select the button 
beside View Template.

3. In the Assign View Template dialog box, select Fire Rating 
and click OK.
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4. Review the View Control Bar options. Note that you can’t 
make any changes to the view controls of this view, as shown 
in Figure 1–115.

Figure 1–115

5. Switch to the Level 1 - Fire Ratings view. Note that you can 
still make changes to the View Controls of this view because 
the view template is not linked to the view. 

6. Return to the Level 2 - Fire Ratings view. The floor is 
showing in Level 2 but you do not want this to display.

7. In the View tab>Graphics panel, expand  (View Template) 

and click  (Manage View Templates)

8. In the View Templates dialog box, select Fire Ratings. 

9. In the View properties area, next to V/G Overrides Model, 
click Edit. 

10. In the Visibility/Graphics Overrides dialog box, toggle off 
Floors.

11. Click OK to close each of the dialog boxes. The floor in the 
Level 2 - Fire Ratings view automatically toggles off.

12.Save the project.am
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Task 3 - Create a View Template through Manage View 
Templates.

1. In the View tab>Graphics panel, expand  (View Template) 

and click  (Manage View Templates). 

2. In the Apply View Template dialog box, set the View type filter 
to Floor, Structural, Area Plans.

3. in the Names list, select Architectural Plan and click 

 (Duplicate).

4. Name the new view Room Plan.

5. Next to V/G Overrides Model, click Edit....

6. In the Visibility/Graphic Overrides dialog box, set the Filter 
List to Architecture.

7. Select All and clear the checkamrks from all of the model 
elements.

8. Select None.

9. Toggle on Doors, Stairs, Walls, and Windows.

10.Select and expand Rooms and select Interior Fill, as shown 
in Figure 1–116.

Figure 1–116
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11. Click OK.

12. In the View Templates dialog box, clear the checkmarks in 
the Include column beside View Scale and View Range. 

13.Click OK.

14.Use the Duplicate with Detailing command on the 
Level 1 and Level 2 views and rename them as Level 1 - 
Rooms and Level 2 Rooms.

15. In the Project Browser, select both rooms views.

16. In Properties, in the Identity Data group, select the button 
beside View Template. and apply the Room Plan view 
template to the views.

17.Open Level 1, Level 1 - Fire Ratings, and Level 1 - Rooms 
views and compare them.

18.Save and close the project.
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Practice 1h Add View Templates - Structure

In this practice, you will create a view template from an existing 
view and modify the view template using Manage View 
Templates. You will then duplicate views and apply the view 
template to other views, as shown in Figure 1–117.

Figure 1–117

Note: This practice uses view templates in an existing project so 
you can see the impact of what they do. They should be setup 
originally in a project template.

Task 1 - Create a View Template from an existing view.

1. In the practice files Structural folder, open Office-View 
Template.rvt.

2. In the Project Browser, in the 3D Views area, right-click on 
the Structural Materials - 3D view and select Create View 
Template From View.

3. Name the new view template Structural Materials and 
click OK.

4. Next to V/G Override Filters, click Edit.... The 
Visibility/Graphic Overrides dialog box opens with the Filter 
tab selected. You can see that the Filters and overrides setup 
in the view are included in the view template.

Practice Objectives

• Create a view template from an existing view.

• Create a view template from within Manage View Templates.

• Duplicate views and apply the view templates.
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5. Click OK.

6. In the Include column, clear the checkmarks from everything 
except the Detail Level, V/G Overrides Filters, V/G Overrides 
Model, and Model Display categories.

7. Click OK.

8. Save the project.

Task 2 - Apply the View Template to Views.

1. Duplicate the Structural Plans>Level 1 view and rename it 
Level 1 - Materials.

2. Right-click on the new view and select Apply Template 
Properties.

3. In the Apply View Template dialog box, set the View type filter 
to <all> and select Structural Materials, as shown in 
Figure 1–118. Click OK. 

Figure 1–118
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4. The plan displays with the most of the design in the concrete 
color. Compare the new floor plan view with the existing 
Level 1 view, as shown in Figure 1–119.

Figure 1–119

5. Duplicate the Level 2 view and rename it as Level 2 - 
Materials.

6. In Properties, in the Identity Data group, select the button 
beside View Template.

7. In the Assign View Template dialog box, set the View type 
filter to <all> and select Structural Materials. Click OK.

8. Review the View Control Bar options. Note that you cannot 
make any changes to the view controls of this view, as shown 
in Figure 1–120 and that the colors are not displaying as 
expected.

Figure 1–120

9. Switch to the Level 1 - Materials view. Note that you can still 
make changes to the View Controls of this view. 
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Task 3 - Modify a View Template through Manage View 
Templates

1. Switch to the Level 2 - Materials view.

2. In the View tab>Graphics panel, expand  (View Template) 

and click  (Manage View Templates). 

3. in the Names list, select Structural Materials.

4. Next to V/G Overrides Model, click Edit....

5. In the Visibility/Graphic Overrides dialog box, toggle off 
Floors.

6. Click OK twice to close the dialog boxes. The Steel color now 
displays because the floor has been removed, but the 
concrete walls do not display as expected, as shown in 
Figure 1–121.

Figure 1–121

7. Open the Manage View Templates dialog box again and 
select Structural Materials.

8. Edit the V/G Overrides Filters. 

No Color

am
ple

 pr
ov

ide
d b

y A
SCENT fo

r r
ev

iew
 on

ly 

All c
op

yin
g a

nd
 re

us
e s

tric
tly

 fo
rbi

dd
en

. 
1–78 © 2018, ASCENT - Center for Technical Knowledge®



Creating Custom Templates

S

9. In the Visibility/ Graphic Overrides dialog box, add overrides 
to the Cut Patterns to match the Projection/Surface Pattern 
overrides, as shown in Figure 1–122.

Figure 1–122

10.Click OK to close the dialog boxes and the information is 
updated in the view as shown in Figure 1–123.

Figure 1–123

11. Save and close the project.

Color Added
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Practice 1i Add View Templates - MEP

In this practice, you will create view templates from an existing 
view modify the view template using Manage View Templates. 
You will then duplicated views and apply the view templates to 
other views, as shown in Figure 1–124.

Figure 1–124

Note: This practice uses view templates in an existing project so 
you can see the impact of what they do. They should be setup 
originally in a project template.

Task 1 - Create a View Template from an existing view and 
Apply View Template to views.

1. In the practice files MEP folder, open Office-Spaces.rvt.

2. In the Project Browser, in the Mechanical>Floor Plans area, 
right-click on the 1 - Mech - Velocity view and select Create 
View Template From View.

3. Name the new view template Velocity Duct Plan and 
click OK.

Practice Objectives

• Create a view template from an existing view.

• Create a view template from within Manage View Templates.

• Duplicate views and apply the view templates.
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4. In the View Templates dialog box, next to V/G Override 
Filters, click Edit.... The Visibility/Graphic Overrides dialog 
box opens with the Filter tab selected. You can see that the 
Filters and overrides setup in the view are included in the 
view template.

5. Click OK twice to close the dialog boxes.

6. Duplicate the 2 - Mech view and rename it as 2 - Mech - 
Velocity.

7. In Properties, in the Identity Data group, select the button 
beside View Template.

8. In the Assign View Template dialog box, select Velocity Duct 
Plan and click OK.

9. Review the View Control Bar options. Note that you cannot 
make any changes to the view controls of this view, as shown 
in Figure 1–125.

Figure 1–125

10.Switch to the 1 - Mech - Velocity view. Note that you can still 
make changes to the View Controls of this view. 

Task 2 - Create a View Template through Manage View 
Templates

1. In the View tab>Graphics panel, expand  (View Template) 

and click  (Manage View Templates). 
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2. In the View Templates dialog box, set the View type filter to 
Floor, Structural, Area Plans.

3. in the Names list, select Architectural Plan and click 

 (Duplicate).

4. Name the new view Space Plan.

5. Next to V/G Overrides Model, click Edit....

6. In the Visibility/Graphic Overrides dialog box, set the Filter 
List to Mechanical, Electrical, and Piping.

7. Select All and clear the checkmark from all of the model 
elements.

8. Select None.

9. Scroll down, select and expand Spaces, and select Interior, 
as shown in Figure 1–126.

Figure 1–126

10.Click OK.

11. In the View Templates dialog box, clear the checkmarks in 
the Include column beside View Scale and View Range. 

12.Change the Discipline to Coordination and click OK.

13.Save the project.
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Task 3 - Apply View Template to Views

1. Use the Duplicate with Detailing command to duplicate the 
1 - Mech and 2 - Mech views and rename them as 1 - 
Spaces and 2 - Spaces.

• You can to include the space tags in the views so you 
must duplicate with detailing.

2. In the Project Browser, select both spaces views.

3. In Properties, in the Identity Data group, select the button 
beside View Template. and apply the Space Plan view 
template to the views.

4. In the Project Browser, the views are automatically moved to 
the Coordination node and the spaces display in the view 
but none of the MEP elements display, as shown in 
Figure 1–127.

Figure 1–127

• If the spaces are not showing as expected, reload the 
linked file.

5. Save and close the project.am
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Chapter Review Questions

1. Which of the following items are NOT set in a template file?

a. Units

b. Annotation Types

c. Title blocks

d. Keyboard Shortcuts

2. What is a label?

a. A text type used in title blocks.

b. A dimension with text instead of numbers.

c. A type of text with variable information.

3. When you want to create new Text Types, such as those 
shown in Figure 1–128, you need to copy an existing one.

Figure 1–128

a. True

b. False

4. Which of the following enables you to assign a view template 
consistently to a view so that no changes can be made to the 
view parameters?

a. In the View Status Bar, lock the view.

b. In Properties, select a View Template.

c. In the Project Browser, right-click on the view and select 
Lock.

d. In the Apply View Template dialog box, select a template.
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5. Which of the following parameters are included in a View 
Template (as shown in Figure 1–129)? (Select all that apply.)

Figure 1–129

a. View Scale

b. V/G Overrides

c. Project Units

d. Detail Level 
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Command Summary

Button Command Location
Templates

Callout Tags • Ribbon: Manage tab>Settings panel>
expand Additional Settings

Elevation Tags • Ribbon: Manage tab>Settings panel>
expand Additional Settings

Floor Plan • Ribbon: View tab>Create panel> 
expand Plan Views

Loaded Tags 
and Symbols

• Ribbon: Annotate tab>Tag panel>
expand the panel title

Section Tags • Ribbon: Manage tab>Settings panel>
expand Additional Settings

Annotation 

Dimension 
Types

• Ribbon: Annotate tab>Dimensions 
panel>expand the panel title

Text • Family Editor

• Ribbon: Create tab>Text panel

Title Blocks

Label • Family Editor

• Ribbon: Create tab>Text panel

New Title Block • Ribbon: File tab> New

Revision 
Schedule

• Family Editor

• Ribbon: View tab>Create panel

View Templates and Filters

ApplyTemplate 
Properties to 
Current View

• Ribbon: View tab>Graphics panel>
expand View Templates

• Project Browser: (right-click on a 
view) Apply Template Properties...

Create View 
Template From 
View

• Ribbon: View tab>Graphics panel>
expand View Templates

• Project Browser: (right-click on a 
view)

Filters • Ribbon: View tab>Graphics panel

Manage View 
Templates

• Ribbon: View tab>Graphics panel>
expand View Templates

Temporary 
View Properties

• View Control Bar
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